Ranged autoattack stays on

Discussion in 'Ranger' started by ARCHIVED-Xoris, Mar 4, 2010.

  1. ARCHIVED-Xoris Guest

    I just got my epic *grins*, and changed all my melay combat arts, with a macro, to go back to ranged autoattack when finished. But I am having a problem that when the critter is dead, my ranged autoattack stays on. Of course, when the tank targets something else, I automatically attack, which can cause some problems.
    I was having this problem before the epic, and macro changes, but not often. Now it seems to be happening with almost every MOB. Has anyone else had this problem, or any ideas how to solve it?
    Thanks.
  2. ARCHIVED-glowsinthedark Guest

    Don't use melee ca's right at the end of the fight is the best advice I can offer you. The issue is that your macro is turning ranged AA back on after the mob is already dead so you either have to A) not target through the tank, B) get real quick on the esc key once the mob dies or C) just don't use CAs that you have macroed to turn AA back on near the very end of the fight.
  3. ARCHIVED-ElsaRat Guest

    This is exactly what happened to me when I first macro-ed my melee arts. After the battle, I'd end up shooting at whatever the tank focussed on next which was not good.
    Eventually I settled on switching to ranged auto-attack manually and I like that better.
  4. ARCHIVED-kartikeya Guest

    I find this happens because of lag, for me. It's something else that would be solved if they would just put in that change that allows us to keep ranged auto attacking when we've used our melee arts (we wouldn't need a macro then, thus we wouldn't have this problem of /autoattack 2 going off a little too late), but I haven't head a single peep about that change since it was pulled back in December, in order to add a toggle option for it. This is kind've what I was afraid of when I saw that it had been pulled--we may never ever see it again, since it's not a priority for any other class, really.
    What I generally do is just be really fast on the draw, and hit the ~ key as soon as the mob is dead. This usually drops me into melee auto attack, which I can then switch off by hitting ~ again. A bit extra annoyance, but usually it means I don't end up pulling things early.
  5. ARCHIVED-suzita Guest

    I have this problem too - the only solution I've found aside from above points is to use /assist (doesn't stop the ranged auto attack being switched on but you don't have anything targetted until you re-click your /assist macro - haven't used this for a while so assume it still works). It isn't very useful for fast kills / grouped mobs as it slows things down a lot but it can help in some situations.
  6. ARCHIVED-donilla Guest

    Frankly, I'm having this problem even without the macro. I trashed all my auto range attack macros a long time ago for just this reason, and resigned myself to toggling on/off manually. After SF thoiugh, my auto range is staying on after a fight, and if I'm not paying attention, the next target get skewered by me first. When the target dies, auto should end, period. After all it goes off when a mob dies during a fight with multiples, it goes off when a proc lands, or a CA lands, it goes off if your timing is off, no reason for it to stay on after the last mob dies.
  7. ARCHIVED-ElsaRat Guest

    By the way, is it still important to switch to ranged auto-attack after a melee attack? With people experimenting and discovering they're doing more damage with melee weapons than their mythical bow, what's the point of always switching back to ranged?
  8. ARCHIVED-Toball Tokor Guest

    ElsaRat wrote:
    I would not think so it did not on release day.
    I would start right on top of the mob with debuffs and melee ca's. Still don't want to interrupt either autoattack with our weak ca's.
    Cast and cancel FA while moving out to ranged CA and Ranged AA distance. Let the ranged CA kick off Ranged AA. Move back in using rear shot and let your first melee ca trigger melee aa then rinse and repeat.
    The 20% bonus is no longer range defined and two fabled's will out parse your mythical in autoattack damage. Unfortunately you must be out of melee aa range to trigger most of your ranged ca's.
  9. ARCHIVED-ElsaRat Guest

    Xoris wrote:
    More recently I found another solution. Instead of targetting through the tank, assist the tank. Create a macro you can hit the the command "/assist tank-name". This targets the mob the tank is attacking (sometimes called hard targetting instead of soft targetting).
    Then when the battle is over if I've forgotten to turn off autoattack and the tank idly picks up another target, I don't suddenly shoot at the target unless I'm hit the assist button.
  10. ARCHIVED-Neiloch Guest

    i don't know why but I don't run into this problem often. Except when the server lags or my game hitch's. Also it happens at my fault when I hit one of my melee macros basically the same time/milliseconds after the mob dies. Since ideally, auto attacks are supposed to shut off themselves when your engaged target is dead.
  11. ARCHIVED-Toball Tokor Guest

    When I used to use the /autoattack 2 in my macro's that happened to me alot the tanks hated me :} So I made a hot key and a hot bar item that was set to "/target_none" on the first entry then "/target {name of tank}" on the second entry. That turns autoattack off but leaves you ready for the next mob.
    I would click it or trigger it every time a mob died. It became a habit. I still do it :) every time I join a group or raid I edit the macro to reflect either the MT or MA. I just don't do it to make sure ranged auto is off anymore.
    I no longer use /autoattack 2, Now I just joust everything and use no macros on ca's. It works better for me but, I am in the minority as I am pretty sure that most rangers still use it.
  12. ARCHIVED-Toball Tokor Guest

Share This Page