Program Crashes After Character Selection Screen

Discussion in 'Players Supporting Players' started by Mystria, Sep 23, 2014.

  1. Thimdirran Active Member

    Same here, been communicating with support, generating log files, updating other files, no change to the error and still can't play. Amusingly I did log into the original EverQuest and claimed my monthly 500 Station Cash. Oh, and occasionally log into Landmark and putz around a bit.
  2. Thimdirran Active Member

    Here is an odd wrinkle. I got the idea to try to run two launchpads each set to a different account (I created a free extra account a few years ago). The first account I press Play on will get the crashing error while the second will be able to play. It doesn't matter which free/paid I start with the second is allowed in error-free. With one account playing, the other will continue to get the error when I try to play it.
  3. Kayan New Member

    Similar problems to everyone here. Game worked fine before last weeks patch. Now, one of 2 things happen. Lanuchpad to black screen of death or launchpad to directx error. I have removed all video drivers and reinstalled, checked directx, deleted the ini files, hell, ive even deleted and reinstalled the game entirely. I've removed all mods from my computer, and I cant get in. SOE, please fix. Clearly something was done during the patch. Thanks!

    For the record- AllAccess member hand have been playing since launch. I just never post on the forms, so Im not some newb. :)
  4. Marso New Member

    So I have the same problem. Only I get no error messages, but simply got a black screen.
    My best solution so far:
    -ini files: eq2_recent and LaunchPad-user to delete from the games directory (with backup of course)
    then set via setting the resolution to 1024 x 768 and then log in directly through the application Everquest2. Not via the Launcher.
    Then simply IG again the desired settings (possibly stored) make. Next time just log back on Everquest2 directly and not via the launcher ..

    Works to change the settings again without me.

    Maybe this is for you a temporary solution to your problem.

    But this process can not really be the solution.

    I hope the Guys at SOE working


    Edit: for me an NVIDIA GeForce GTX 260 is in the computer

    translated with googel translator o_O

    Original Text:

    Also ich habe dasselbe Problem. Nur das ich keine Fehlermeldungen bekomme, sondern einfach nur nen schwarzen Bildschirm hab.
    Meine beste Lösung bisher:
    -Die ini Dateien: eq2_recent und LaunchPad-user aus dem Spieleverzeichniss löschen (mit Sicherheitskopie versteht sich)
    danach mittels Setting die Auflösung auf 1024 x 768 setzen und dann direkt über die Anwendung EverQuest2 einloggen. also nicht über den Launcher.
    Danach einfach IG wieder die gewünschten Einstellungen (evtl. gespeichert) vornehmen. Beim nächsten mal einfach wieder direkt über EverQuest2 einloggen und nicht über den Launcher..

    Funktioniert bei mir ohne die Settings wieder zu ändern.

    Vielleicht ist das ja für Dich auch ein temporärer Ausweg aus Deinem Problem.

    Aber dieser Vorgang kann ja nicht die Lösung sein.

    ich hoffe, die Jungs von SOE arbeitet daran


    Edit: bei mir ist eine NVIDIA GeForce GTX 260 im Rechner
  5. LordTiras Well-Known Member

    Running it twice and seeing it work on the second instance is really interesting, all I can think of on that is that the game is doing things out of order when initializing, and that the second instance takes advantage of the first's mistake (which then locks the first out). But given that DX should share, and that should be impossible, it also suggests that there is a line of bad code someplace in the performance tweaks that's broken and affecting a certain subset of graphics cards. Most people have had issues with one family of nvidia cards, though we've had one AMD person as well chime in. I wonder what each card supports for features versus what the game is trying to use with them...
  6. Kayan New Member

    Still nothing, and still no response. Becoming more frustrated- not so much that I cant get in, but because there has been no SOE response. Clearly, this is an issue for multiple people. Can we get some word? Please?
    Igochan likes this.
  7. Igochan Member

    I agree with Kayan. One week and no response. Amazing.
  8. Mystria New Member

    I did a little more testing with my crash and found that if I set the graphics settings to anything above "Balanced" it would cause a crash. Anything at or below that seemed to work ok. I called tech support, and after working with customer service I did get my problem resolved. After going through all the generic fixes like checking drivers, DirectX and other supporting utilities, and safe booting with minimal drivers, the CS rep suggesting backing up the following files, and then deleting them from my EQ2 installation:

    cache folder (does not apply to Steam users)

    As well as the character specific files, these will appear as follows:

    When I removed all of them, I was able to log in again normally and set my graphics settings to whatever level I wanted. I then tried restoring the files one at a time, and found that in my case, the eq2_recent.ini file was what was causing the problem. I restored all the other files and deleted just the eq2_recent.ini file and now I'm back up and running with my graphics set at "Very High".
    Kayan likes this.
  9. Kayan New Member

    Thanks Mystria. Tried all that. Still nothing. I appreciate you digging around tho.
  10. Kayan New Member

    So here's an interesting glitch for you all to chew on. As i was experimenting tonight. i opened a second copy of EQ2 with a separate account on top of the Black Screen of Death (the one where i can hear the music but not see anything on screen). The second copy of the game opened fine and I was able to actually get into game. It does not matter which account i log into first or second- the second instance always loads with no problems.

    So Odd.
  11. LordTiras Well-Known Member

    So that's now two instances of people being able to launch a second, working, copy of the game on top of a broken first attempt. If there are others who are still having this issue, can you also try this and see if it works? This might at least give some idea of what might be causing it, as it points more towards an improper initialization of some sort.
  12. Thimdirran Active Member

    Didn't I read years ago that folks would do something similar, opening multiple versions of the game, in order to force the game to be played on one of their CPU's lesser used cores back when multiple core CPUs were relatively new?
  13. Wanyen Active Member

    Separate installation for the second copy? Perhaps broken custom UI?
  14. weeg New Member

    been trying to come back and play for a year and a half and it wont play ive played every game there is but cant play
  15. launchee New Member

    I have the same problem here::(
    G:\live\eq2\framework\core\devices\DirectX9RenderDevice.cpp D3Derr Device lost
    or: G:\live\eq2\framework\core\devices\DirectX9RenderDevice.cpp --> 15524

    Is there no official statement from SOE about this problem which concerns lots of people?
  16. launchee New Member

    I was sending now an official support ticket to SOE ....
  17. Igochan Member

    Ok. I fixed it. Format c: Reinstall windows and install Eq2 again.
  18. Kayan New Member

    Well. Directx error is back again. Ridiculous. Still working the same ticket with support, and no resolution.
  19. LordTiras Well-Known Member

    Anyone who sees this should at least try the "Run it twice" test mentioned above (this may require copying the EQ2 folder to a second place and running it from there as well). If this "bad fix" works for everyone who is having an issue, that may help dev pin down the issue even if they can't reproduce it in house.
  20. Kayan New Member

    Update- I dont know what I did, but I am able to get back in now. No clue, other than yet another install.