Program Crashes After Character Selection Screen

Discussion in 'Players Supporting Players' started by Mystria, Sep 23, 2014.

  1. Mystria New Member

    A new error has just started happening. After I select a character it starts to load into the game and then it crashes with a message box that says:

    EverQuest II has detected an unrecoverable error and must shutdown.
    DirectX Error. (D3DERR_INVALIDCALL)

    I haven't been online for about a week and last week everything was fine. Today it downloaded the latest patch, and now this error keeps occurring and I can't get into game. Also, I don't have a G: drive (unless I have some external device plugged into my system, which I don't currently). EQ2 is on my c: drive, and it's not under live\. Any suggestions?
  2. LordTiras Well-Known Member

    That path is from an internal error, and that's just likely from their build machines at SOE (as the .cpp at the end means the file is a C++ file which is the language I believe most of the game's written in). However, that suggests that you're having issues between the new patched version and DirectX. First thing I would try (and I know this is time consuming) is to run a file validation on the game files. You may have had one patch incorrectly. Also, if yuo know where to find Event Viewer, look in that for any DirectX Errors. I'm not at home so I can't look to suggest if any logfiles might help.
  3. Mzirad New Member

    I get almost the same message but the numbers are different and the error is unknown. Although My game is installed on the g: drive the game is not installed in the live directory. I do not even get to the character select screen. I validated the files and it says they are ok.
    EverQuest II has detected an unrecoverable error and must shutdown.
    DirectX Error. (Unknown)
  4. LordTiras Well-Known Member

    Hmm... I had another thought on this one. For anyone having issues with this as of the performance patch, what is the video card you use, and (if you can find it) the driver version you are using (if you installed any on your own - if you just use the Windows 7/8 ones state that instead).
  5. Mzirad New Member

    NVidia GTX 285 two of them in SLI mode latest drivers and Windows 8.1 64 bit with latest drivers. Everything worked fine till latest patch.
  6. Igochan Member

    Same here. Nvidia GTX 285 and windows 7 64 bits. Game crashes.
  7. Mystria New Member

    I use a radeon R9 280X with Catalyst 14.10.1006 (should be current full version) and Win 7 64-bit.
  8. LordTiras Well-Known Member

    And Igochan you are using the latest drivers from NVidia? I assume as you didn't mention it, you're not running two in SLI.
    I don't think this will find an issue, but try running DXDIAG and see if, on the DirectX Files tab it reports any issues with file. I think it won't, but it's worth check and only takes a minute.
    Also, are any of you running custom UIs? There have been issues in the past that have generated this error (such as this one: and deleting a couple of files and re-downloading fixed the issue, in some cases.
    Unfortunately this is a fairly common issue with the game, and has been reported on and off since release in 2004 by many people. In some cases it just stopped, while in others it was never addressed nor was it fixed for those people. It would be interesting to know if EVERYONE who has this issue is running a GTX 285 (we're at 2/3 on this thread), as that would suggest an incompatibility with the drivers when running with that specific chipset.
  9. Mystria New Member

    The only things I have is the EQ2 Map mod.
  10. Igochan Member

    I don't have any mod, no SLI and no problem with the DirectX. Everithing worked fine till the patch :-(
  11. LordTiras Well-Known Member

    OK, so both video companies, Win7 and 8 (and no XP so far!), some with mods, others none.
    Given that this patch changed things in the video code, I'm going to guess that there are a few new things that are happening at startup. The two errors above are from different points in that same file, which would suggest that it's not the EXACT same issue for each of you (just that the end result is the same) so it's probably more than one setting or change that's making this happen.
    I saw in another post on here from a couple years ago of trying to run the EQ2settings.exe, change your resolution, and try launching the game. See if that helps, as occasionally it appears that it can. Once in the game, from what I'm reading, you can change it back to normal. This in particular may work if when you go in to change the setting, the value is blank.
  12. Igochan Member

    I also tried it. I changed my settings and resolution. Nothing.
  13. LordTiras Well-Known Member

    Igochan are you getting into character select or dying before then? Can you post the exact error message that comes up?
    Mystria, try removing the UI and restarting. Given that you clear character select, and die when loading the UI, perhaps the map mod is trying to create an overlay in a way that's no longer supported.
  14. Mzirad New Member

    I finally got in what I did was change video to the lowest settings (Highest performance) in the game settings before pressing the play button. I then had to close the launcher and restart it. I can change settings in game but if I restart launcher the problem is back. Any video setting besides the lowest setting I can set it to will recreate the error for me.
  15. LordTiras Well-Known Member

    Hmm, that's interesting. That sounds like something doesn't initialize right when it first launches. I'd say at this point start collecting things like the logfiles in the EQ2 directory, and a log from dxdiag, as support will probably ask for those.
  16. Mzirad New Member

    Already done and sent
  17. Eles Well-Known Member

    I'm crashing too :(
  18. Ishtannia Member

    I am getting the same message. I cant get on either since they patched yesterday. Sucks too i only get 1 day off per week and paying for this =(
  19. Ishtannia Member

    is there any fix to this? I cant get on and got the same messages, tried what they did and nothing
  20. Ishtannia Member

    I reduced the settings to lowest quality and restarted the launcher. same problem. i cant get into eq2 no matter what I do. =(