Pride Pakiat Quest Feedback & Bugs

Discussion in 'Quest Discussion' started by Kander, Oct 16, 2017.

  1. Kander Developer

    Welcome to Planes of Prophecy Beta!

    There are three faction quest lines within the Plane of Magic. Please post any bugs and feedback regarding the
    Pride Pakiat adventuring quests within this thread.

    When you are describing an issue, be sure to include:
    Quest name
    Quest giver's name
    Quest journal text

    That will help ensure that the issue will be examined and tended to by the appropriate developer, as soon as possible! Thank you!
  2. Jazzalyn Member

    Quest Giver: Izle Tot

    In " Can't Step in the Same River Twice", Myhst River is spelled wrong. Additionally, the update to "wash the messy kidney stones" was really hard to find. The location makes sense, but it took two of us over an hour and a half before we finally stumbled upon it, and we had each checked that location twice.

    In "The Missing Heart Leaves a Hole". Myhst River is spelled wrong again, this time more amusingly as "Mysht River". We're currently stuck on "I need to find some piranha to feed these hearts to." We can see piranha-looking fish (drukyna scaleback) in the marshes, but haven't found any way to interact with them or feed the hearts to them. Out of time tonight, but will continue to take a look tomorrow.
  3. Mermut Well-Known Member

    Quest: Can't Step in the Same River Twice (Repeatable)
    NPC: Izle
    The 2nd step 'find a source of water.....
    The update is a teeny tiny part along the shore of the marsh.. There is absolutely NO visual indication of where this is...
    My friend and I just got lucky and one of us happened to see the 'hand' cursor as we were searching.


    Quest: The Missing Heart Leaves a Hole
    NPC: Izle
    2nd step: Isle is unstatisfied (typo) with the eel hearts I have brought here(typo). She wants to to(typo) go feed them to the piranha.
    I need to fins some piranha to feed these hearts to

    The only piranha we can find in the zone (called drukyna scaleback) don't interact. I can attack them, but even right click gives no other option. Additionally, there is no 'heart' item in inventory, so I can't right-click use that in any fashion.
  4. Kander Developer


    These spots should be easier to find today. I will also be adding additional spots.
  5. Ellah Active Member

    Quest: Can't step in the same river twice, twice - TYPO
    The second update says "I have washed the kindy stones" instead of kidney stonesas does the message that flashes up on the screen.
  6. Mermut Well-Known Member

    Quest: Seven Tomes and No Sense
    NPC: Karo-amat
    Step: I am looking for the plains within the plane. She probably means the Meteherial plains.
    I should look for the seventh tome.

    I've been quartering the plains for over an hour.. periodically killing mobs, scouring the ground, checking the few floating islands/rocks and nothing
  7. Bardonio Member

    Quest: Seven tomes and no sense.
    So I received this quest today and found 1 tome on the cliffs in the bluffs and then searched for 3 hours with no luck. I deleted the quest and hailed the npc to get it again and searched for over an hour and no update. Not sure if it’s just recently this is happening or has been an issue today.
  8. Thand Active Member

    Quest: Seven Tomes and No Sense
    NPC: Karo-amat
    I have got 0 tomes even with locs other people haev just found them. I do not think they are re spawning after one person gets them
  9. Anunnaki Active Member

    Quest: The Introduction
    NPC: Izle Tot
    Issue: On the first step, when I am looking for the scorpion, the first one that runs into you in the south didnt give an update. I spawned him 4 or 5 times and didn't get the update. Deleted the quest and restarted and it worked.
  10. Jazzalyn Member

    @Bardonio and @Thand - Mermut and I worked with Kander and he made them visible for me. Check again and see if you're good now?
  11. Jazzalyn Member

    Quest Giver: Karo-amat
    Quest: Perennial Complications
    I can click on the same flower over and over again for the same update. The harvesting verbiage reads "Place the stacks of books".
  12. Kander Developer

    Fixed for tomorrow, Thank you.
  13. Kander Developer

    Also fixed for tomorrow
  14. Jazzalyn Member

    Quest Giver: Ta-sche-ra-he
    Quest: The Vexing Golden Coin
    I get the message "You feel an unfamiliar energy from this area" at loc 560.33 59.39 405.46 33.37 0.00 0.00.
    Ran around in that area a bunch and finally got my Divining rod to light up. It casts "Divining Location", but I don't receive an update.

    P.S. There's also a spelling mistake. It reads "Kandra Ulands"

    Headed to bed, so not sure if a bug or if I'm missing something. Will check more after work tomorrow
  15. Kristabella Well-Known Member

    Quest name: Can't step in the same river twice, twice
    Quest name: Missing heart leaves another hole
    Quest giver's name: Izle Tot

    Can't step in the same river twice, twice, Need to kill 5 cats along the river
    Missing heart leaves another hole, Need to kill 7 eel along the same river

    At one point you can do BOTH quests at the same time. Here is the problem, there are only about 7 cats in this area, and while there are more eels, you need a couple more of them, and by the time you go wash the stones, and feed the piranha, and return to the quest giver to get this repeatable you must do A LOT, by the time you get back to do it again, you are still having to wait on RESPAWNS, for both cats And eels.

    At the time I was doing it there was only 13 people on. Try doing this with over 100 people on... there is gonna be lots of upset folks.

    Kander made an announcement about letting them know the rate of spawn needs to be upped, he is not on the server atm. So, reporting it here.
  16. Lenecro New Member

    Quest Giver: Izny Rut
    Quest Name: Operation Crustacean Station

    So... we killed 6 of the crabs things and then spawned The Mother Hen.. this guy took about an 30 minutes to kill and required multiple people to join and come help us.. assuming its a bug so posting here (mob had i think a ton of combat mit..)
  17. Theodious Member

    I was in on that fight with Lenecro as Theodious. It was like fighting a PG mob but it was a ^ mob....
  18. Bardonio Member

    so got to this point and the "Pakiat Divining Rod", which locates a diving location, does nothing. there is no feeling like the previous quest. dove in the water at the cliff and searched with no luck on any update or another location in which i felt an unfamiliar energy. will keep searching in case im missing something as wel
  19. Kander Developer


    Say wut? I'll look at it.
  20. Kander Developer

    When you see the golden cups on the quest. Stand below them. You will be able to cast the divining rod.

Share This Page