Plane of Innovation: Masks of the Marvelous [Solo]

Discussion in 'Zone Discussion' started by Gninja, Oct 16, 2017.

  1. Elinea Well-Known Member

    And maybe a little on-screen reminder to cast that buff. I can't tell you how many times I zoned in and forgot the buff and died in 2 seconds to the trash lol.
  2. Sath182 New Member

    Should the bosses in this zone have heroic zone health pools? 15 minutes to kill the cell keeper is a bit ridiculous. Especially when finally progressing through the next few zones and having completely organic feeling bosses.
  3. Leed Member

    Went back in again after zone crashing last time, reset the zone, and started over. I killed the Glitched Guardian 10101 and my quest updated 'Meldrath's spirit dissipated when I defeated the Glitched Guardian!', with the next step being 'Find Meldrath's spirit.'

    Unfortunately in my inventory 'Ancient Clockwork Hand' stayed, and it did NOT turn into 'Electro-Charged Clockwork Hand' as it did for others. The door would not open for me, and I appear to be stuck. Should I try deleting the quest, reseting zone, and starting over?
  4. Arcos Active Member

    Aware that I'm a little slow here - due in part to problem with sapphires and salts - now solved. Now in Masks of the Machine and killed Clockwork Scrounger XVII this morning. Without a merc my SK took about 45 minutes to kill it. No strategy needed as apart from the initial trauma's until he ran out of power he never really touched me. Just overly long and tedious to do. Why make a fight boring?
  5. Sath182 New Member

    I wonder if the resolve check is too high. I got a few pieces out of the tower of thunder that bumped my resolve in PoP gear up to 400 and it went from 15min fights to 50sec fights. However I reduced my resolve to 364 which should be about where I was and still didn't have 15min fights. o_O
  6. Leed Member


    As far as I can tell the HP changes - same gear - one time it takes forever (zone crashes), next time mobs are dying a lot faster (hand doesn't change and last door can't be opened) with the same gear. Happening to other zones too - ACT had ichor mobs in The Coliseum of Valor with billions upon billions of HP one run and 15 minute fights, then next run they die very fast, and ACT says they have only 33,840 HP.
  7. Agulo New Member

  8. JanEQ Member

    Last night my beta-buffed (not copied) necro could not kill The Glitched Guardian 10101 (yes, I remembered to cast that buff). She has 9.2m hps, 37k pot, 4k cb, and 345 resolve outside of that zone. The beta-buff package doesn't contain a merc or a familiar so I went and got Zhugrus for her, but haven't yet gotten a familiar or a deity. I dropped the merc for the last couple of tries and a friend who had completed the same zone came in to try to help and we both died.

    Going to try again after buffing the merc up some and throwing some gear on him. Maybe check the merchants for better beta gear...
  9. Leed Member

    Third time's a charm - it updated and I was able to finish the zone after deleting quest and waiting to reset zone. Please change the exit to return you to Coliseum of Valor near where you zone in (near the portal).

    Edit: Then Gears in the Machine crashed fighting first mob - Repair Bot 5000 - same thing as Masks, zone reset with me back at entrance.
  10. maxximum Member

    Did the quest a while ago but thought I'd try the zone again. The erratic robot is buggy as hell. I killed it seemingly too quick, the clickable npc appeared, and another aggro copy of the robot popped as well which can't be killed, it just heals back to 100%. There also seems to be an issue with the clickable robot running too far ahead or behind, and there's no way to tell where the security scanner is so sometimes you have to let the robot run off and it messes the zone up. I killed the Glitched Cell Keeper and the door to the final room wouldn't open.

    There surely must be an easier way to do this? Have the robot teleport to the cell keeper or something?
  11. Chillispike Active Member

    if you look North at 148.38, 9.89, -233.98 you'll see that the wall isn't touching the floor and you see "nothing" behind
  12. Kazgar New Member

    Hey folks - New beta tester here.
    I ground my way through the Tradeskill achieve, and the Magic Quester achieve (all 3 factions). I made it through the first two Sig line quests, up to the third one, that takes us to Innovation. I have all the beta gear, bunch of orange adorns, my conjy pet is Master (from the previous tier, for the 10% dmg reduction), and my merc is Zhugrus buffed to lvl 10, with beta gear and other items i bought from a faction merchant.
    That 10101 mob wipes me in 2 ticks, every time. I have no clue how to combat it. I've been told I need PG adorns from Live, but I've never done proving grounds. I've been told this is how the Release Sig line is going to be; that it's going to be this hard. I have to say, I've never encountered anything like this in any previous EQ2 expansion. I could always do the content as I went, at the appropriate level, with gear that I received from the quest lines. If this is how PoM is going to be, I'll skip it and wait for the next expansion, then come back and play the content when I'm capable.
    I hope I don't have to do that, I was kinda looking forward to it. But, I've been playing on Fallen Gate progression server, and I like crafting more anyways. My guess is the new expansion won't affect my playing, one way or the other. But I hope I won't be locked out, just because I'm not over-powered with gear from other parts of the game that I don't play.
  13. maxximum Member

    4th time trying to get past erratic robot and still bugged. Tried killing him slow, with and without the electro-charged weapon, and he just goes non-aggro and unclickable so I cannot progress any further.


    Edit: Now 7 times, says he has become severely damaged and becomes unclickable
  14. maxximum Member

    Deleted the electro weapon thingy in my inventory, two of them, to see if it was bugging erratic robot out. Now the electro hand isn't dropping from first name so I can't open the door to robot. . .

    Note: I've already completed that part of the signature quest so I can't delete it to start again.
  15. Teesia New Member

    3 times running zone trying to get the Ancient Clockwork Hand to change to Electro-charged Clockwork Hand and still will not allow me through door. So sad that I cannot progress this quest..... I have tried various differences Deleted hand, deleted and re-accepted quest and killed all three mobs Ancient Clockwork Prototype, Clockwork Scrounger XVII and The Glitched Guardian 10101. Goes to her Illy corner and cries.

    Teazia
    Illusionist of Maj'dul
  16. Teesia New Member

    I forgot to add that on my first attempt I fell asleep at the wheel before I had killed The Glitched Guardian so I logged back in the next day in the same instance and killed him, and the hand was not present in my bag when I went to look for it. I supposed overnight it disappeared. I can verify that it was there before I fell asleep.
  17. maxximum Member

    Went back in on my bruiser and erratic robot still bugged. Auto attacked him to 1% then he powered down and became unclickable. Can't go any further in the zone because I've already completed the sig quest for here so I can't delete it.

    Scrub that bit, opened door behind him and ran to Glitched Cell Keeper. Meldrath ran in the room then disappeared and next door can't be opened, with message 'The door is on lockdown due to security protocol'.

    Just ran it again on bruiser, killed robot, became unclickable and was stuck in combat. I zoned out and back in and he was clickable, then he ran to glitched cell keeper and disappeared. I killed keeper, then Mendrath came running through and door to last boss is still unable to be opened with same message as before.
  18. maxximum Member

    Tried again today after update. Electro thing still not dropping from first mob and I've already completed that quest so can't delete and start again. This was the tenth or so attempt in the past 3 days.
  19. maxximum Member

    Update on this zone:

    Bruiser: completed sig quest and he still has electro-doodah to get past door to erratic robot. Combat starts the instant I open the door, but erratic robot does not aggro. If I aggro him and kill him quick or slow, he powers down and becomes unclickable. I then have to exit the zone and come back in for him to be clickable. I then click him, he runs off to Glitched Cellkeeper and disappears. I kill the cellkeeper, then Meldrath runs through to the next room and then disappears, and the next door to the last boss will not open because of security protocol, regardless of whether I have the electro-doodah equipped.

    Please confirm whether this is bugged or I am missing something, because I've run this zone a good 20 times in a variety of ways now and there's been no dev response.

    Dirge: Completed sig quest and encountered exactly the same problem as bruiser. I noticed I had two of the electro-doodahs in my inventory so I deleted both, thinking that it would drop from first name again. I have killed the first boss countless times and the electro-doodah is not dropping, so I cannot open the door to progress.

    Someone please give me some kind of answer. Has anyone else managed to complete this zone since they finished the sig quest for it?
  20. maxximum Member

    Just asked in general if anyone else had tried the zone since they completed sig quest there and the response was that no-one had. Pressto then tried it and ran into the same issues I have.

Share This Page