Plane of Innovation: Masks of the Marvelous [Solo]

Discussion in 'Zone Discussion' started by Gninja, Oct 16, 2017.

  1. Assissi New Member

    Glitched Cell Keeper:

    Gninja, the cell keeper is now non agro? So I can't proceed thru the door. I know you guys are working on this and we do understand this is just the beta, but when you have time please look into this.

    Regards,
  2. Balcerak Member

    Tried this today. Finding similar things but a few notes:

    1. I noticed that the Electro-Charged Clockwork Hand was still in my inventory from yesterday, even after zone reset. Intended?
    2. Couldn't kill Glitched Cell Keeper as per other folk's notes. Tried camping and back and he was non-agro, so I left zone and reset it. When I went back in, all of the nameds were up till I got to the Erratic Clockwork. It was missing. So quest was stuck at that point. I then deleted the quest and got it again from Druzzil Ro. So at least there seems to be a workaround.

    Will try again once someone says the Glitched Cell Keeper is no longer 'glitched' :)
  3. Vanyel Member

    I managed to kill the Glitched Cell Keeper. I stopped ALL dps except melee Auto attack at 10% and it didn't heal
  4. Vanyel Member

    Gninja, When you open the door that requires the use of the Electro Charged clockwork hand, it puts you into a state of combat for the rest of the zone. /sit, etc doesn't fix it
  5. Vanyel Member

    Gearclaw The Collector
    hits 75% then won't take any more damage

    he sort of slumped over and combat logs says he's not taking damage. He will not move, and he's not attacking me either.. He's damage immunity buff was also NOT active during this state. I sat in combat for 10 mins before running away and out of the zone

    update: fought him 3 more times and he did the same as above. I just didn't wait 10mins again

    update: Gninja told me in game this is part of the script. Have to pay attention to the message it gives you and do something :)
  6. Vile New Member

    Just tried to re-run Masks of the Marvelous solo.
    Erratic clockwork is missing this time round.
  7. Balcerak Member

    Vile, after you quit one time the erratic goes missing. I had to remove quest, get it again from Druzzil Ro and reset zone.
  8. Karsa Active Member



    Reset the zone and now the gate to underground tunnel is locked do to security protocol and I cannot get to last name :eek:
  9. Karsa Active Member

    But evacing to front door seems to fixed the problem
  10. Alakazou Member

    same thing happened to me, tried to evac, relog, nothing worked.
  11. Leed Member

    Might have been a server crash perfectly timed with this but:

    Immediately after killing the Clockwork Scrounger XVII the zone froze, I couldn't loot the chest, I could target mobs, but I couldn't cast anything on them, and after a few minutes it finally kicked me back to character select.

    The server never said it went down, and when I logged back in the instance had reset, even the first named apparently respawned. The nameds in here take a really really long time to kill (I expect on live it'll come down since I'll be using more 101-110 abilities than I am right now), so I didn't try a 2nd time just yet.
  12. Arieva Well-Known Member

    Glitched cell keeper repeatedly healing for me as well. Tried the autoattack only trick and no luck there either
  13. Kuulei Well-Known Member

    I think I found what is causing the bug with him healing from 1% back up to 5%!
    Solo, with no merc, I have no issues.
    If you attempt to kill him with a merc, or a friend in the zone with you, he glitches. Tested with a merc and 2 other runs with a 2nd person in the zone.
    All 3 times deleted the quest, reset the zone and we were able to reproduce the issue.
  14. Toxlas Member

    I haven't been able to get to him for a couple of days due to the immortal boss bug, but last time I fought him there was a right click option to wind his key up. He killed me on doing this and the zone locked up then but I think winding him back up is the script being referred to. The zone lock is now sorted I believe.
  15. Toxlas Member

    I agree. Fought it for half an hour, never got lower than 76%. Exited, dismissed Stampy, 2 minutes later it's dead and I'm on to the next boss. Didn't reset the zone, just dismissed merc.
  16. Toxlas Member

    I can confirm this now. He slumps down, you get an orange message in chat telling you to use his key (maybe should be a red on screen message) right click, use key and carry on. I notice he now has a self destruct timer as well. I finished him before iran outbut I assume he explodes or something. I needed Stampy to heal me through this one, had him on passive throughout.
  17. Vile New Member

    Ok ty will give that a try
  18. Elinea Well-Known Member

    Ran into an issue with the Ancient Clockwork Hand. When I couldn't kill the Glitched Guardian, I logged out to go to work and didn't resume my attempts to kill him until the next day. Before I tried again, I reset the zone to start over, since there'd been fixes after I'd logged off. I reset the zone, and the hand was still in my inventory. When I killed the mob in the fresh zone that drops the hand, I couldn't loot it because I still had the old one. I didn't think it mattered, so I left the chest with the hand and went to kill the next mob. When I got to the Guardian again, it didn't update the hand to be able to open the door (presumably because it was the hand from the previous zone I had reset). The chest with the new hand had expired already, and now the quest won't advance. I'll have to go out and destroy the old hand, reset the zone, and start again.Is it possible to make the hand from a previous zone work for the new zone?
  19. Darchon6 Member

    PLEASE get rid of the stupid damage immunity buffs which occur at specific percentages. As it currently stands, it doesn't matter whether you have 30k or 10 trillion potency, the named encounters will die at EXACTLY the same speed regardless. This defeats the whole purpose of gear progression -- making things die faster. As it currently stands, I have to press 1 CA, wait 5 seconds, press 1 CA, wait 5 seconds, etc, etc. before the NPC is defeated. This is a toxic form of gameplay.

    The same issue plagued certain kunark ascending heroic instances, with Arcanna'se Spire: Forgotten Sanctum being the most notorious of these. I avoided that zone like the plague, btw.
  20. Mermut Well-Known Member

    The furnaces in the zone really should put a det on players when they root them. It will obviously be incurable, but there should be something for players to see effect and duration of the root.

Share This Page