Plane of Innovation: Masks of the Marvelous [Solo]

Discussion in 'Zone Discussion' started by Gninja, Oct 16, 2017.

  1. Mermut Well-Known Member

    The first two names are doable.. The Glitched Guardian 10101 killed the toon in under 30 sec with a hit of 24,029,122 magic damage...
  2. morath Member

    Killed the Glitched Guardian - got the electromagnetic pulse green text. No weapon charge in inventory. Cannot advance.
  3. Efbomb New Member

    first of let me say i am a Berserker with 48 mil health 4,315 CB 42,348 POT and 463 Resolve and i loose power on all named fights. I am using my Fount of Power. I have been able to kill Ancient Clockwork Prototype, and Clockwork Scrounger XVII but on each fight i loose all my power about 7 min into the fight and need to use my auto attack the rest of the fight making it a 10+ min fight on each. When trying to kill The Glitched Guardian 10101 he hits like a freight train and the adds you need to kill take forever to kill as they have way to much HP and i loose power and die 10 sec later from the named smacking me dead. This HP of the named and adds need to be drastically reduced as this is a Solo.
  4. Gninja Developer

    We are aware that the difficulty is currently very high. We have changes in for tonight's update or early morning tomorrow I s'pose.
  5. Efbomb New Member

    Ok thanks for the reply.
  6. Vanyel Member

    Gearclaw the Collector has 2 major bugs:

    1) he can 1 or 2 shot you like the 10101 (or whatever the name) does. So he needs to be toned down
    2) If you die while fighting him, he bugs out and reset to white non aggro and you cant attack him. you then must reset the zone and delete and re-get the quest
  7. Vanyel Member

    Also if you kill the nameds in there too fast (usually by buffing up and blasting ascensions causing them to be 1 shotted), the ghost won't leave them and walk on to the next step
  8. Vanyel Member

    After the patch (the most recent one 10/26/2017 @ 12:01am) a Clockwork Scrounger XVII can not be killed. It gets to 1% health then heals to 5%.. I've been in combat for 20 mins and this endless loop repeats


    looks like someone tried to prevent it from being 1 shotted and the script has gone haywire lol
  9. Mermut Well-Known Member

    Glitched Guardian:
    After the midnight patch.. again.. merc is unfortunately required. There is no way for a coercer in the gear given from the timeline to survive even to 80% w/o a merc.

    I get the mob down to 1% and it heals up to 5%. The one buff on the mob doesn't give any suggestions on what to do. The mob does not emote anything that would give a suggestion on how to actually kill it. I dragged it over to the red lightning thing in to the right of the door on inside.. fought it next to the furnances that root me (w/o putting any det on me at all *grumpy face*) and it still heals back up to 5%.
    There is no right-click option on the mob either.

    This is a solo zone required for the signature line... the strat should not be this arcane.
  10. Vanyel Member

    nothing wrong with needed a merc to complete it.. but a bunch of those are bugged as far as the healing.. looks like it's a panic script gone wrong. You're not missing a strat. It's bugged (As are a lot of bosses after this patch)
  11. Toxlas Member

    I get this as well. I tried getting it down to 1% life just using auto attack (went afk for 15 mins) to have full power. At 1% hit it with everything I had. Still heals back up to 5%. Dragged it all over the zone, no right click options. Just plain bugged.
  12. Mermut Well-Known Member

    Considering it took nearly 5 minutes to get to 1%, it's definitely a 'panic script gone wrong' if it's a panic script that is firing.

    I generally don't use mercs and even in previous expacs when I might have needed them on my weaker toons at the beginning of the expac it wasn't a case of 'die in within 30 secs w/o merc vs 5+ minute fight with merc'.

    I suppose my healer won't need a merc though, as none do enough damage to matter and she's already GOT heals.
  13. Adaac Member

    I fought this mob for 30 minutes the first time it could not be killed. Reset zone went back in and found the same issue even tried mostly auto attack and still cannot kill it, gets to 1% and heals for 5% continuously. Hard to test when you cannot get past second name in first room
  14. Gninja Developer

    We are aware that bosses in Plane of Innovation and Torden, Bastion of Thunder are not dying like they should. We will get it fixed asap.
  15. Mermut Well-Known Member

    When using the Electro-Charged Clockwork Hand to open the door for Legacy of Power: An Innovative Approach, it immediately puts my toon in combat. Nothing is attack.. feigning doesn't break it.
    Additionally the erratic clockwork is not behind the door.
  16. Mermut Well-Known Member

    Aaaaannd... now the Glitched Cell Keeper has the same bug the Glitched Guardian had. It gets to 1% and heals back up to 5%.... And I am now stuck on the third quest of the sig line for the 4th day :S

    There is no right click option. I even requipped the Electro-Charged Clockwork Hand to see if that made a difference... nope.
  17. Bardonio Member

    So the Glitched Cell Keeper cannot be killed in the solo version due to that immortality at 1% regen to 5% repeat infinitely. Will wait another 24 hours, hopefully, for a potential fix. Thanks. Oh I attempted this zone at 7:01 am eastern this morning.
  18. Vanyel Member

    Confirmed as of 852am. Looks like the devs forgot this one. Same as yesterday. Cant be killed and cant progress in the sig line because this zone cant be finished.
  19. Vanyel Member

    Glitched Cell Keeper:

    If you die fighting it, it will reset to white/non aggro and the zone must be reset

    Correction: If you die, go linkdead, etc - anything that "resets" the encounter, this will happen (happens on any boss where the spirit must activate/possess them)
  20. Karsa Active Member

    Glitched Cell Keeper:
    was unkillable got down 1% and would not die... evaced and then mob became white/ non agro. :(

Share This Page