Plane of Disease: The Source [Solo]

Discussion in 'Zone Discussion' started by Chrol, Oct 17, 2017.

  1. Toxlas Member

    It would be good if the water level in the barrel room was a bit lower so you can see there is something there. The only reason I knew to look for barrels was from reading the wiki. They aren't always there, first time I did it there were no barrels, second time there were.
  2. Leed Member


    I would guess Elowith just forgot to dismiss their mount first. I was able to get over there with boots yesterday and get the visage (then Darwol Adan didn't make barrels clickable so I got stuck there).
  3. Chrol Developer

    Yes, they are essentially one encounter. Together, they form Volt--4th named.
  4. Chrol Developer

    I'll make sure to add messaging about the barrels, perhaps even have some floating on the surface!
  5. Leed Member

    Got stuck on Darwol Adan yesterday (barrels not clickable), tried again today, and barrels weren't up at all (seems they don't spawn if instance has gone dormant)

    Edit: After dying, I ran back to him again, and the barrels had spawned, and were clickable before even engaging him in combat.

    After being ported to Wavadozzik Adan upon the death of Darwol I killed the nests, and Adan gained the buff 'Armor of the 7th King' - I ran around room, tried dragging him into the 'toxic' water, but nothing seemed to get rid of its 100% damage reduction.

    Also, the 'an arachnae lacerater' seems to have more HP than the named do. Or something else weird is happening - I was fighting and fighting, and all of a sudden the same ascension ability that was taking 1-2% off their HP suddenly does 20% damage.
  6. Leed Member

    Loaded up ACT and it seems it might not be that their HP is higher, but rather that for some reason my abilities just randomly stop doing almost any damage.

    Same ability vs 'an arachnae lacerater':
    161dmg, 5dmg, 5dmg, 151dmg, 5dmg, 5dmg, 509,621dmg 10:04:18 (CST)
    Same ability vs 'an arachnae lacerater' later in fight:
    230,936,395dmg
    260,291,533dmg

    There was no apparent buff on the mob, nothing to explain why it was mitigating so much more for a long time before suddenly I started doing real damage to it.


    Edit: Ok, so I finally beat the Adan twins, I'm really not used to a solo having quite so many overlapping instantly kill you type effects, but for sure I ran into a bug on that one run where the mob stopped taking damage at 50%. After that run whenever I cast the 7 spells and the spell went off me the buff went off mob at the same time - so it must have just bugged out on that one run where the buff stayed on mob permanently.
  7. Toxlas Member

    If you jump with the Grotesque Visage up, the animation stops halfway through the jump and you end up standing in the air as you glide along.
  8. Toxlas Member

    Floating would be perfect, thanks. Are they supposed to be non-clickable before engaging? I could line them up beforehand and pull him along the barrel line, killing a barrel when needed.
  9. Toxlas Member

    To clarify, this happens if you jump off a raised platform and get the extended jump bit.
  10. maxximum Member

    The trash mobs are still dropping the small chests of plat.
  11. Elfrina Member

    The barrels did not pop on my first try, ok on second try but somewhat buggy moving the barrels. The spider fight is more difficult, the arachne nest pop too fast to be killed, seems the nest are out of range or out of sight.... On the 3rd try the spider did not go below 51% health and NO nest popped, I believe this zone is bugged and I will not be able to finish the sig quest line
  12. Toxlas Member

    Is there any way we could keep the gas mask and the Grotesque Visage illusion? I like them both!
    I was disappointed when the upgraded gas mask didn't show up on appearance though.
  13. Kittybock Well-Known Member

    Buff stayed on the Spider, I ran through every attack I had...over and over. moved around the room, Nada. He stayed at 51%. Went through my quickest cast, as suggested on wiki. I've tried different approaches for 45 minutes!!! Nope. Finally evac'd to break combat and it takes you all the way to the start of the zone.

    Are we sure it is the 7 abilities fast or is there something else?

    Went back in, the curse lifted after 7. Must have been bugged first time
  14. Pixilicious Active Member

    The Arachnae Lacerater trash mobs kills channeler pets, when they supposed to be unkillable. Mine got killed twice recasted it then died again.
    Please fix.
  15. Earar Well-Known Member

    nice that even in solo zone, you need to follow a strat


    though .. kind of disappointed .. gear (solo) from plane of disease looks like gear from plane of magic or innovation.

    and leather gear doesn't look appealling

    so much for appearance :(
  16. Lopsidoo New Member

    After fighting Blighthorn, all the little lepers spawn. If you camp out and come back in, they all disappear and don't come back.
  17. Chrol Developer

    Will be fixed. Thanks!
  18. BuddyT New Member

    Same deal this zone as in Outbreak so I'll just repaste what I said there. There are mobs in this zone called "malevolent retch". "Retch' is the sound one makes when vomiting, a "wretch" is one who is despicable or contemptable. In the Plane of Disease, hard to say which you mean but if its the latter, consider changing that.
  19. Dedith Well-Known Member


    Apparently that buff is taken out by killing a nest while the mob is near it. Found a good write up here: http://eq2library.com/pop/dungeons/plane-of-disease-the-source/

    Problem I have is that the Curse is not emoting when cast so I cannot make an ACT trigger, and the 2nd to 3rd time it lands on you it's not even showing a detrimental for it, so i don't even know I have it and die for without knowing I had it.. I tend to save my single target CAs for this curse.
  20. Stormbourne New Member

    After dealing with Blighthorn, I decided to do a little exploring (since I didn't know where to go next). After skirting some of the mountains near Glutton Gorge, I got a message that said. "Nothing out here but desolation. I should turn back..." I was then ported to the north side of the barrier at -11.25, 94.79, -174.25. Essentially, I'm trapped. I can't get around the area without getting the message and being ported back. Luckily, I had packed some Totems of Escape. But for those that might not have been so lucky, maybe the teleport point should be adjusted somewhere on the south side (or dependent on zone progress).

Share This Page