Phantom Sea Signature Broken

Discussion in 'Quests and Seasonal Events' started by Tipperton, Jul 13, 2015.

  1. Tipperton Member

    Ok, so I have petitioned this in game this morning & have yet to receive an answer so thought I would give this a try in the event that anyone actually works at Daybreak Everything Games.

    Phantom Sea Signature quest is Broken at Allu'thoa Abduction. It allows you to capture the Shaman, hail Corrith, Interrogate the Shaman, but does not advance past or update the quest-line. This quest is a REQUIREMENT to continue the Signature series. All the little side quests have been completed. I have deleted Allu'thoa Abduction & retried it at least a dozen times. Have logged out of game, have zoned, have tried going back to Tranquil sea & talk to Ailena, went back to Qeynos & tried to talk to Queen, all for nothing, the quest is at a dead end.

    A friend in the guild is at the same point on quest-line as myself & is stuck for him also. Have ran into a few others who are also at a dead end on this quest at this point.

    Please fix this.
  2. Rots New Member

    I also know fellow guild mates that are having the same problem please respond back to their petitions!!!!
  3. Uhkla New Member

    This quest will not advance. You capture a "dino" shaman and take him to the camp. Interrogate the shaman with Corrith Midner and the quest does not ting-ding advance. The "Red Book" remains above Corrith Midner and the quest still says " Corrith Midner and I must interrogate the captured Allu'thoa" (dino shaman).
  4. Tipperton Member

    Although it wasn't mentioned in Patch notes for today, the quest is back to normal & working again. Hope the rest of you are able to progress as well.
    Kaitheel likes this.
  5. Kaitheel Developer

    I'm glad that you were able to make it past Allu'thoa Abduction, Tipperton. For my own knowledge, and if anyone else is still experiencing this, can you please tell me a bit more?

    When you hail Corrith, in order to interrogate the Shaman, can you see the Allu'thoa shaman standing next him him? Does the interrogation seem to work, where the conversation is jumping between characters? Lastly, what is the final line of dialogue that you are able to trigger?

    ~ Kaitheel
  6. rbm1956 Member

    Broken again.
    The last line is "your god Alou'thoa, promised you these lands"
    Livejazz likes this.
  7. Aglovale New Member

    Broken again, same issue as above. Red book stays over Corrith's head.
  8. Elinea Well-Known Member

    I tried deleting the quest and getting it again, also tried logging out and back in. The quest stalls each time at this spot in Allu'thoa Abduction. In the middle of interrogating the shaman, the quest breaks at:

    You say to a captured Allu'thoa shaman, "Your god, Clotl'thoa, promised you these lands?"

    There is no more dialogue after this, and the red book remains over Corrith's head. This is as of 9/6/15 (yes, questing during double exp weekend...what can I say).
    Livejazz and Aglovale like this.
  9. Jazzy New Member

    I am also trying to finish the quest Allu'thoa Abduction. I agree with Elinea, but will add that the conversation is not jumping between Corrith Midner and the shaman. This quest is deffinitly still broken.
  10. Elinea Well-Known Member

    I will admit I don't remember how much the conversation is supposed to go back and forth between Corrith and the prisoner. We start out clicking on Corrith with his red book over his head, and he says we need to interrogate the shaman. You tell him you want to do it, and the conversation jumps over to the shaman. I don't know at what point it's supposed to go back to Corrith though, because it's stalling in the middle of the dialogue with the shaman.
  11. Elinea Well-Known Member

    After this morning's patch, I logged in to see if this was fixed. I was able to complete the quest, as the dialogue once again jumped back and forth between shaman and Corrith correctly. I noticed that someone else earlier in the thread reported the same thing only to have the quest break again, so I don't know if something is going on that is breaking the quest repeatedly.

    For now though, it's working again.
  12. Crogoth New Member

    This is still broken. I tried to finish the quest and it won't complete. I even deleted the quest and re-acquired it and it is still bugged when you try to finish the interrogating portion.

    Please fix


    Thanks
  13. Elinea Well-Known Member

    Interesting. I ran it again on another toon on Friday and it finished fine. I don't think I could get another toon to that part before the next patch though, so I can't see if it's broken again (as opposed to still from last week).
  14. Crogoth New Member

    Still broken, logged in and it won't progress past the interrogation of the Shamen. Deleted again and re-tried still didn't work
  15. Kaitheel Developer

    Hey everyone!

    I have brought this bug to our code team, but they have not been able to pin point the cause. As you have experienced, it is an inconsistent bug. When servers are brought up from updates it sometimes start working, other times it does not. We don't know what triggers it, but it is NOT you. It is not something that you are doing or that you can affect. Deleting the quest and re-obtaining it will never resolve this issue. I wish I had more solid news about it, but it has not been forgotten.

    ~ Kaitheel
  16. Carynn Well-Known Member

    I hope they're working on the Eidolon Jungle signature quest series, too, which has a similar bug that prevents you progressing past Power to the Tower in that zone and thus you can't do quests in the Obol Planes, either. That's a lot of quests not being able to be played.
  17. Crogoth New Member

    Thanks for the update
    Kaitheel likes this.
  18. Elinea Well-Known Member

    I just got stuck on the Power to the Tower quest on another toon. That's two signature lines that are inconsistently broken. Maybe it's something with the signature type of quest itself? I did get to finish the Phantom Sea line where I got stuck during the labor day weekend, by logging in when the servers came up and finishing it. People who have tried later in the day are also claiming it's not working still, so something is breaking sometime after the servers come up on patch days. Very weird. I hope it gets fixed soon.
  19. Odyssey Active Member

    I got stuck on power to the tower also. It just kept resetting and never updating.
  20. TechUp Active Member

    I wound up having to have a friend bring over their lvl 100 Berserker to help AOE the mods down on my necromancer. Even then it was close to the wire in finishing. If anyone is on AB and needs help with that one either PM me here or find me in-game (/who all Darkness Grasp, I'm usually the only one on) and I'll bring over one of my lvl 100's and help burn them down.

Share This Page