Mystic 1.0 Not Completing

Discussion in 'Player Support' started by Maugia, Dec 20, 2017.

  1. Maugia New Member

    In the final fight to complete the fabled Mystic 1.0, it's not updating after killing the Shade of Sellok.

    I had to mentor and remove all buffs, blank my AA, remove most gear so that I didn't 1 shot the encounter with some random proc.

    Burn Sellok down slowly, kill his adds. He vanishes at 25% like he's supposed to. I use the Eye of Thalger to see him, continue the fight and kill him. The quest doesn't update with his death, and I am unable to destroy the altar (no interaction possible with it).

    I've tried this 5 times now, to no avail. What am I missing? Or is it just broken, preventing me from starting 2.0?
  2. Porrum Member

    Did you equip the special weapon before trying to destroy the altar?
  3. Maugia New Member

    Yes, equipped the weapon. Wouldn't matter though, the quest is not updating to indicate I have slain the Shade of Sellok.

    I reset my zone again today, deleted and reacquired the quest and went again, to the same result. He goes invisible at 25%. I use the Eye to see him, then finish him off. No quest update. Unable to click the altar with special weapon equipped.
  4. Nirinia New Member

    I have that same exact issue on my Mystic, have been trying for a week with different approaches.
    Still no luck, no info to be had from extensive browsing or asking in general chat..
    I am stumped on what to do.

    I did /bug it, but no idea if that makes any difference.
  5. Nirinia New Member

    Might be worth adding that my Mystic is level 101? Dunno.
  6. Pickleweasle Member

    If you are having this much trouble then / petition it. I ran into a problem with channeler epic as well. /bug did nothing but once I petitioned it the gm told me that it was broken and had been for some time. It is very possible to get this fixed with a petition even if they just give a hint. Also..... Discord is great to use as a tool too.
  7. Sehk New Member

    While the 4/1 update fixed the spirits not updating this quest, it is now getting stuck at 'I must destroy Sellok's altar', even after equipping the cudgel and destroying the altar. I have submitted another /bug in game, and posted to Discord. Hopefully the next fix will result in an obtainable Mystic 1.0 epic.
  8. Nirinia New Member

    Yup, am experiencing the exact same issue as Sehk. Would be nice if they fixed this fully.
  9. Maugia New Member

    Yep. Same issue here. Now stuck at altar.

    And FYI, I did petition this. Had a GM look into it and agree it wasn't working as intended. It was sent up to Devs a few days before patch. At least they fixed part of it, I guess, lol.
  10. Pickleweasle Member

    If it is still messed up then / petition it again. They are only human and make mistakes. Keep feeding the problem to them and will keep seeing it.
  11. Sehk New Member

    Yep, I have submitted bug reports both times, and have been in discussion with GM Violetann who was very helpful and confirmed the first bug. I appreciate that mistakes happen. My post here, on Discord, and an update to GM Violetann are intended to ensure the issue gets 'blanket' coverage and hopefully a speedy and successful fix.

Share This Page