Luclin unlock not working for alts on same account

Discussion in 'Bug Reports' started by Dreanna, Feb 1, 2020.

  1. Dreanna New Member

    I have a character who accessed Luclin and leveled up to 120 there. My alt who is 110 cannot access Luclin through the ever portal.

    Is there a step I'm missing? It says "you did not meet the entrance requirements". I was under the impression that I only had to run the quest chain and unlock this once for all of my characters. They share the same account.
  2. Beee Well-Known Member

    You have to do the pre quest for every alt
    Cyrrena likes this.
  3. Dreanna New Member

    Thank you! I will do that, I thought maybe my account was broken.
    Cyrrena likes this.
  4. Dreanna New Member

    Update: The reason my character could not use the portal to the Blinding is because she was 100. Just tried it with a level 110 and she went right in, no pre-quest needed.
    Cyrrena and Beee like this.
  5. Jaeded Well-Known Member

    You do not need to do the pre-quest on every alt to access Luclin however if you want to run the signature questline the prequest is must be done.
    Cyrrena likes this.
  6. Sajitari New Member

    I've been trying with my 110 character & alts. I have so many alts I forgot who's the main. What's the Pre-Quest?
    Cyrrena likes this.
  7. Marae Well-Known Member

    I believe the "pre-quest" refers to the Light Amongst Shadows quest series, and the stage most of us get stuck on is Light Amongst Shadows: The Vault of Omens, the instance in Jarsath Wastes, which has been devilishly difficult. I only managed to get one of mine through it, with a lot of help. I ran another character in there with a friend and we had our behinds handed to us several times; we finally gave up. I haven't gotten back to it since, but with the recent fixes they've made it might be doable now. Will have to try again.
    Cyrrena likes this.
  8. Cyrrena Well-Known Member

    The Duality's Quests in Teren's Grasp are the prequels. There is an adventure and a tradeskill, you should receive a mail, if not, go to Mara and visit Jerol near the second wooden building on the side where you zone in, he stands at the end by the hitching posts and the carpenter table.
    Breanna likes this.
  9. Almee Well-Known Member

    The access quest is supposed to be fixed now. I haven't been back through yet, but even "fixed" the quest is a bear. I couldn't get a single character through solo because I leveled ascension spells instead of regular spells so the mobs wiped the floor with my characters. But if you ask for help, it will usually be given fairly quickly. I only had two characters, out of 20 or so, that had to wait for awhile to get help. But that's on Maj'Dul. I have no idea what it is like on other servers. Players who are raid equipped breeze through the instance even when Fount of Power isn't working.
    Cyrrena likes this.

Share This Page