Legacy of Power Signature Quests feedback & bugs

Discussion in 'Quest Discussion' started by Kaitheel, Oct 17, 2017.

  1. gmcookie New Member

    In the Signature quest line Legacy of Power: Realm of the Plaguebringer I worked my way through the Crypt of Decay to the Darwol and Wavadozzic encounter. I killed Darwol first then got ported to Wavadozzic. I killed her but when she died I did not get a chest or a quest update and the gate to the Bahly encounter didn't open. So my Signature quest line is now stuck. I can't finish Realm of the Plaguebringer and move on to the next quest.
  2. Chrol Developer

    If you're still stuck and have that instance open, can you PM me your character name, please?
  3. gmcookie New Member

    Chrol,

    I sent you a private message with my character's name but didn't get a reply and the zone is still broken. I can't open the gate to get to the Bahly encounter and finish the zone. You might have been in here, the poison pool where Wavadozzic was seems to have been drained. But the gate to the next encounter (Bahly) still won't open.

    I have an open instance still and my character's name is Charoun.

  4. Aethn New Member

    Step one of this quest is terrible. I am going on day 3 now looking for the 2 of the 4 N/S/E/W locations for the "Find stuff to click at the peaks". What happened to the Blue helper shading on the map? This has been broken for years and frankly its getting aggravating and angering that this still is not fixed. !!!
  5. Scrappyz Well-Known Member


    Nothing's broken about it.. they said 2yrs ago in ToT they won't be doing it again
  6. Chrol Developer

    The gate should open for you now. Good luck!
  7. Chrol Developer

    These are only used for overland timed quests, now.
  8. Stormbourne New Member

    Quest: Legacy of Power: An Innovative Approach
    Zone: Plane of Innovation: Masks of the Marvelous (Solo)
    Issue: I have wended my way through the various updates to the point where the game text says, "The destruction of the Guardian releases an electromagnetic pulse, charging the Clockwork Hand!" However, upon checking my inventory, only the Ancient Clockwork Hand is there. Therefore, I cannot proceed further into the zone to complete the quest.

    As an aside, some of these mob groups can take five to ten minutes to whittle down, even with a decent merc (I'm an Inquisitor, not a DPS, so that might be some of the issue). It seems a bit excessive, unless it's meant to be. Also, could the Fount of Power be applied to our mercenaries as well so that they survive more than one hit?
  9. gmcookie New Member

    Yes, the gate is open now but Bhaly still won't spawn. So I'm still stuck and can't continue in the Signature quest. Character name is Charoun.
  10. gmcookie New Member

    Get some of the Beta Test Gear and put it on your merc. That will help. Also you will find that 16 resolve accolades drop in the instances which will beef your merc up over time. Can you adorn merc gear? I haven't tried that but will. My merc is holding up much better now than when I started the Signature Quest.


  11. Shmogre Well-Known Member

    My concern with this is that it doesn’t give a good picture of how it will be on Live. I and many others are trying to test using the gear that we will be able to get doing things organically (faction quests and merchants, drops, signature). If the only way to make it through solo zones is to beef up with higher-level beta gear, then it’s not a good indicator of the zone balance.
  12. Leed Member

    Quest: Legacy of Power: Glimpse of the Hereother

    I collected everything except the mana-infused lead that W wanted. Then I started killing elementals, I killed many (several of which were earth elementals), but the quest item never would drop. At the suggestion of chat I logged out and then back into the game, and then the very next one I killed dropped the quest update.
  13. Niami DenMother Well-Known Member

    1 player (Jeehi, Illy with pet) was on Legacy of Power: Realm of the Plaguebringer. The other (me as a warden) was already through that part of the sig line.

    The first time we went after Wavdozzik, he hit the 50% mark, emoted, and got stuck like that in immune form. Neither player had the curse, so there was nothing we could do to damage him further. (I didn't think to try targeting Jeehi's personae twin to see if it had the curse or not). We finally broke the encounter after a few minutes of trying to get him to do something, anything.

    The second encounter worked just fine, but I'm hoping there's something in the details above that helps you figure out why he suddenly didn't want to play with us. :)
  14. Xianthia Well-Known Member

    I have been stuck on not being able to do An Innovative Approach for three days now. The Repair Bot is taking me ages to kill, I think I'm following the strat. Each day I've logged in and reset the zone, each day I get to the repair bot and within a few minutes I am dead, multiple times. So it's not that it's an old zone, it's not the gear since I'm using beta provided gear (Narf gear, infused, adorned etc).

    I'm at a wits end, obviously for myself. Yesterday I spent 40 minutes until finally I gave up. Whatever was changed in the past week and a half has taken me out of the equation for this expansion. Not being able to get through an expansions' signature quest line does that.

    Some will tell me to fix the aa's (I have), some will say get better gear, do this or do that. This is beta, how many hoops do I have to jump through in order to see being able to finish a zone, let alone one of the first few mobs. And this is beta things will change, but will they with enough change to actually be doable on live? Some folks are getting through, are the bulk of folks able to?

    A dev on discord mentioned that folks are saying it's too hard but not giving enough information on what's wrong. I was able to do it before, on this exact same character, how come I'm not able to do it now?
  15. Ladylou New Member

    Since you update just now So"Valiz is now not taking damage in the solo instance. Great so now fix this. Now no lunch for you. LOL In fact I am still fighting him and I am not taking damage. Guess I can stand here all day and fight this NPC and I already had lunch. Drink ETOH and awaiting a fix.
  16. Kaitheel Developer

    Those of you who are having troubles with mobs in dungeons should be reporting those troubles in the separate dungeons threads (in the zones section). That will help ensure the different dungeon designers will see the issues.

    ~ Kaitheel
  17. Kaitheel Developer

    More changes submitted for the signature quest line:
    • Legacy of Power: Realm of the Plaguebringer - Quest deletion now removes "a foul-smelling rune" and "Dormant Rune of Symbiosis" from the player's inventory.
    • Legacy of Power: Deep Trouble - An aggressive inkfish no longer breaks its encounter.
    • Legacy of Power: Deep Trouble - A brine wyvern has learned a new trick for its battle.
    I forgot to post these changes on Friday. So instead of my usual "coming soon" it just means they are now on Beta!

    ~ Kaitheel
  18. Mermut Well-Known Member

    Legacy of Power: Realm of the Plaguebringer
    The step to click on the portal is NOT a group update.
    If people don't notice this it can mess up quest progression.
  19. Kaitheel Developer


    Oh! Using the Enigmatic Portal Opening Device was not a group update, and yet, the next step using the portal, takes the entire group in. Good catch! Thank you!

    ~ Kaitheel
  20. Toxlas Member

    The conversation with Druzzil Ro at the end of the quest doesn't make sense. She says "The Ros are stronger as a result of this, as are the Thules, including their mother. "
    My response is "I imagine it would be. "
    Not sure what I'm supposed to be saying but something like"I imagine they are" would make more sense.
    I like how they talk about the family like that. I can imagine the Ros inviting the Thules round for sundowners next to the pool and an evening of bridge. G&T's at the Ros tonight, sweetie! Mwah mwah!

Share This Page