launch error direct x

Discussion in 'Players Supporting Players' started by Dulseris, May 19, 2017.

  1. Dulseris New Member

    i'm making a new thread because it doesn't seem like i got the same issue everyone else has gotten today. I was playing fine this morning. i've checked gfx updates and even rolled back driver to see if recent update messed something up. i got direct x ver. 12. i validated game assets so i'm just kind of puzzled why i'm getting this error. tried to post pic of error but couldnt get it to post right. but anyways it says:

    Everquest II has detected an unrecoverable error and must shutdown.

    <verify>
    G:\live\eq2\framework\core\devices\directx9renderdevice.cpp(1927):
    Directx Error. (error)
    0112a5bc
  2. IvyWillow New Member

    Same, working with support through a petition but you only get outdated copy paste answers which even refer to Windows XP. They could atleast update their copy paste answers ): its sad.
  3. Dulseris New Member

    Yeah I'm at a loss I've uninstalled reinstalled the game, and my video drivers and did a file scan and all that stuff and still keep getting that error. only thing i can figure is i have the game installed on my slave drive because my master drive SSD is only 128 gb so i cant hold much space on it so I installed most my programs on my slave drive. don't know if that could cause an error with it unable to locate a direct x dll file, but I was playing fine before so I don't think that has anything to do with it.I suppose it could just be one of the many problems from their end, but the fact than most people were able to log on eventually yesterday made me realize I probably got a slightly different issue.
  4. Chiska New Member

    Did you ever solve your problem, Dulseris? I'm having the same issue.
  5. Grumpy_Warrior It's a KILT, dang it!

    DirectX versions don't replace each other, so DirectX 12 won't necessarily run a game like EQII designed for v9. You can have libraries for multiple DirectX versions on your computer. On a clean Windows 10 creators computer I used the DirectX installer that pops up when you install EQII from the website, and I haven't had any DirectX errors since April. The dxdiag program (which should already be on your computer) says I have DirectX 12, and looking in C:\Windows\System32 I see files for versions 9 10 and 11. Look for files on your computer that begin with "d3dx" as in:

    d3dx9_34.dll
    d3dx11_42.dll

    etc.
  6. Cyrrena Well-Known Member

    I never installed the DX9 version on my Win 10 computer and I have never had an issue. No clue why it varies from person to person as to whether it will like DX12 or not.

    Cyrrena
  7. Sigrdrifa EQ2 Wiki Author

    It's easy enough to try downloading and installing DirectX 9. If it doesn't fix the problem, then probably we'll need to try some more extensive diagnostics.
  8. Deeeds New Member

    I'm having the same issues. I have completely restored my pc to factory and reinstalled everything and it still does it
  9. Borracho New Member

    It's a daybroke problem. Lots of us getting this unrecoverable error ever sense the login server crashed about a month or so ago. It's happens multiple times a day. I had it happen in PG's every other time I zoned into a new PG. Also massive lag problems that are not related to my internet or PC.
  10. Jimbolini Member

    I have a clean install computer and am having the render crash issue as well. (Crashes before the character select screen)

    Updated DX
    Added the DX 9.0 files
    Graphics drivers up to date, etc.

    Anyone else with ideas?
  11. Cythemia Member

    I hate to necro a thread, but im desperate and digging through these messed up forums for answers.
    Since POP i have been getting alot of DirectX Crashes randomly even when im not doing anything i went afk in the guild hall to make lunch while crafting and came back, Game crashed before i could even sit back in my chair good. ITs ALWAYS Can't find some random file on G:\ that i don't even have...so im guessing its the server data that its looking for and is not finding it. I know its not my hardware, i have 2 old machines that haven't changed a thing and 1 brand new Threadripper and it even crashes on it. Ive Been playing this game for a VERY long time and all the sudden im getting random crashes to the point I can't even play or group. I hate to leave with all the time and investment i have into this game but i feel if they don't stop pumping out boring grind content instead of fixing all the many many faults in the game it will force me and many others out.
  12. Cheallaigh Well-Known Member

    that random file on G is an error on their end, not yours.
  13. Evguenil62 Well-Known Member

    Please be sure that your laptop/PC has at least 6GB of RAM and that there's no other heavy programs running on the background while you play. You video card should have 1GB of memory or more. Your PC should be Windows 10 and your Graphical Card driver should be updated to the latest version. Please check manufacture site of your Graphical Card for that. If you have two monitor connected to your PC try to disable second one. Check also if your PC has a build-in graphic chip and if yes see if you can disable it. There must be enough free space on your hard drive, like 10 GB at least.
  14. Cheallaigh Well-Known Member

    hell no on the win10... 7 is fine... 8 is a sys hog so bad.
  15. Jeckel New Member

    The answer is ... Run as administrator. If this option isn't checked, it will not function correctly.

    Worked for me.

Share This Page