Issue Tracking: DirectX render issues

Discussion in 'General Tech Support Questions' started by ARCHIVED-TSR-TrevorG, Jun 5, 2008.

  1. ARCHIVED-TSR-TrevorG Guest

    ****Please /bug this in game if you can as well please**** We are looking for possible issues with players getting the DirectX9RenderDevice.cpp error. Please post the following information if you are having this issue.

    Service pack:
    Video card make and model:
    Video card driver version:
    Did the fix below work?


    As a side note, you can always try and resolve the issue by doing the following.

    First you will need to download your video cards newest driver. Just the driver not the software utilities such as catalyst or nforce software.
    ATI offers a seperate download of just the driver, where as Nvidia I believe has it as an option when installing. NVIDIA ATI

    as well as the newest version of DirectX9.0c from Microsoft;DisplayLang=en

    and a driver cleaning program

    Once you have both files downloaded, you will need to reboot your PC in SAFEMODE.

    To Get to Safe mode you will need to restart your PC. As soon as it turns back on, start holding down the F8 Key. You should be offered a option screen then instead of it booting into Windows right away. You will want to select SAFE MODE with NETWORKING.

    Windows will now load, but it will look different from what you are used to. Install and use the Driver Cleaner program, this will totally remove any old drivers for your video card.

    After it is finished go ahead and install the DirectX. After this is installed, you will need to reboot the PC, and load it into SAFEMODE again. This time go ahead and install the Video card drivers. Once done, perform a clean boot to verify no other programs are starting.

    CLEAN BOOT Procedure

    1. Select the START button.
    2. Select RUN, then type in "msconfig" (for Vista, type msconfig in the search bar at the bottom of the Start Menu)
    3. Press OK
    4. Select the STARTUP tab.
    5. In the list, uncheck all boxes EXCEPT for SCANREGISTRY and SYSTEM TRAY. If you use Windows XP, please note that SCANREGISTRY and SYSTEM TRAY will not be listed - just uncheck the entire list.
    6. Hit apply and then OK. Restart the computer and try the game again.
  2. ARCHIVED-Sendarr Guest

    Strange; I was in game earlier just today with no problems whatsoever, now I can't get past the patcher.

    OS: Windows Vista Home Premium
    Service Pack: 2, I believe, or whichever was the most recent SP for Vista.
    Video Card Make and Model: Nvidia GeForce 8600 GT
    Driver Version: 7.15.0011.6925 (The newer one after this crashes most games I play.)
    Error: EverQuest II has detected an unrecoverable error and must shutdown. <verify> E:\live\eq2\framework\core\devices\src\DirectX9RenderDevice.cpp (1097): Failed to create D3D device for NVIDIA GeForce 8600 GT.
  3. ARCHIVED-TSR-DanielH Guest

    To the top of the forums you go!
  4. ARCHIVED-TSR-TrevorG Guest


    OS: XP
    Service pack: SP2
    Video card make and model: Nvidia 7600
    Video card driver version: the latest
    Error: <verify> E:\live\eq2\game\client\src\GameScene.cpp (4134) Failed to create zone.
  5. ARCHIVED-EDtertainment24 Guest

    OS: XP
    Service Pack: 2
    Video Card Make and Model: RADEON 9600
    Video Card Driver Version: 8.421.0.0
    Error: Everquest II has detected an unrecoverable error and must shutdown. <verify> E:\live\eq2\framework\core\devices\src\DirectX9RenderDevice.cpp(2443): DirectX Error. (E_OUTOFMEMORY)
  6. ARCHIVED-Derrmerth2 Guest

    OS: Windows XP Pro
    Service Pack: Three
    Video Card: EVGA 9800GTX SSC
    Video card driver: Nvidia 175.16 WHQL
    Error: Everquest II has detected an unrecoverable error and must shutdown
    <verify> E:\live\eq2\framework\core\devices\src\Directx9RnederDevice.cpp (2443)
    Directx Error. (D3DERR_NOTAVAILABLE)

    I just refreshed my Directx 9.0c from the March refresh to the June refresh when this issue started. I've already had the newest Nvidia driver for several weeks with no problem. This error pops up with 94% entity resources loaded when I try to get in to the game. I will try the fix thingy a bit later, just wanted to get my error on the board. I can load to character select just fine.
  7. ARCHIVED-xenaphobia Guest

    OS: Windows XP Media Edition
    Service Pack: Three
    Video Card: ATI Radeon Mobility X1400
    The fix did not work...
  8. ARCHIVED-Acebusted Guest

    OS:Windows Xp
    Service pack:Service Pack 2 (i think)
    Video card make and model:ATI Radeon 9550
    Video card driver version:Latest
    Error:umm... <verify> E:\live\eq2\framework\core\devices\src\DirectX9renderdevice.cpp(1097): Failed to create D3D device for Radeon 9550
    Did the fix below work? Well... I have the latest direct X and drive for my card... the fix dosnt really apply then does it? tried to update and says i dont need to. So no i guess. No it did not work.
    On a related note... I was playing like 6 hours earlier with no problems at all. Now i go to log in and cant.. Not a happy consumer right now. What am i supposed to do? just hope a tech guy reads my post here and tries to fix my problem for me? =/ i want to play again sometime in the near future.
  9. ARCHIVED-Acebusted Guest

    My issue seems to have resolved itself overnight. =) yay!! back to ever-questing.
  10. ARCHIVED-Minstar Guest

    OS: Vista Ultimate
    Service pack: 6.0.6000 build 6000Video card make and model: NVIDIA GeForce 7600 GT
    Video card driver version:
    sRestoreGammaRamp(); Gamma ramps are not saved

    Did the fix below work? No
    Currently checking if a SP1 I can download offers any resolution. Doubt it though, as the error references a drive I do not have, I assume there is a problem somewhere
    edits - I get the error after pressing the Play button from the checkup screen. no other screen is displayed
    edits2 - ^^ didnt work, back to the drawing board, fellas
  11. ARCHIVED-dead_by_seven Guest

    OS: Windows XP
    Service pack: SP2
    Video card: ATI Mobility Radeon 9000 igp
    Video card driver:
    <verify> E:\live\eq2\framework\core\devices\src\DirectX9RenderDevice.cpp (1057):
    DirectX Error. (D3DERR_NOTAVAILABLE)
  12. ARCHIVED-Dfrnchman Guest

    Minaei@Mistmoore wrote:
    Been having this same error message for months, only I am running Vista Home Premium. Runnign a Nvidia 7600 GT with the 7.15.0011.6925 driver. Also tried the 175 driver and always get the same error message when game tries to load after ptacher. Havent been able to get into game in a few months now.

    Have a rather long CS ticket, which latest post from CS team said to post here.
  13. ARCHIVED-Minstar Guest

    it happend for me after the latest patch was updated yesterday
  14. ARCHIVED-bes3rk Guest

    I'm having this problem too.

    OS: XP Media Center Edition
    Service pack: 2 I believe
    Video card make and model: ATX Radeon X1300
    Video card driver version: The latest ones
    Error: DirectX9RenderDevice.cpp DirectX error (E_OUTOFMEMORY)
    Did the fix below work? No

    I tried it, but when I attempt to install my video card drivers in safe mode, it does not work. The only way to install the drivers is when not in safe mode, then it works as normal.
  15. ARCHIVED-xenaphobia Guest

    Forgive me but is this EVER gonna be solved? I've been waiting for a fix for weeks now.
  16. ARCHIVED-Minstar Guest

    it seems my issues have been resolved, after running the patcher just now, it downloaded a bunch of new files, and ran like a charm
    thanks much, tech peeps!
  17. ARCHIVED-Sapphy Guest

    I have tried everything you have suggested and no luck at all - very annoying considering the game was playing perfectly 5 hours ago - and now, no matter what i do, it will not load.

    OS: Vista Home Premium
    Service Pack : 1 v668
    Video card: 2 x Nvidia Geforce Go 7950GTX
    Video card driver version:
    Error: E:\live\eq2\framework\core\devices\src\directX9renderdevice.cpp(9820):srestoregammaramp():gamma ramps are not saved
    Did the fix below work: NO!!!
  18. ARCHIVED-Gregore Guest

    Much dialogue and no action. I've tried everything posted in this and other forums.

    OS: Vista Home Edition 32
    Service Pack: SP1
    Video Card: Raedon 1550
    Video Card driver: 8.6 (tried 8.3 and newer)
    Error: E:\test\eq2\framework\core\devices\DirectX9RenderDevice.cpp (9820):sRestoreGammaRamp();Gamma ramps are not saved
    Did the fix work? nope.

    Still waiting, playing on an old computer with XP... Want to play with two accounts with my son. Disappointed beyond belief.
  19. ARCHIVED-Bofim Guest

    OS: Windows XP Home edition (2002)
    Service Pack: 3
    Video Card Make and Model: Nvidia GeForce 7600 GS
    Video Card Driver version: (downloaded the driver this thread told us to)
    Error: "Everquest II has detected an unrecoverable error and must shutdown. <verify>E:\test\eq2\framework\render\src\VeShader.cpp (8567): m_pPixelShader"
    I tried the fix that was posted in this thread and it did not work or make any noticeable difference. I still get looping combat video sequences, looping/stuttering audio concurrently.
  20. ARCHIVED-Quindeath Guest

    im having the same issue as Bofim...and it looks like we're running close to the same system....the only exception on the error is his is E:\test and mine is E:\live


Share This Page