Fixed Internally Incorrect recipes showing on summoned crafting stations

Discussion in 'Resolved' started by Daryx, Apr 11, 2023.

  1. Daryx Well-Known Member

    Category: Mechanics
    SubCategory: Trade Skills
    Severity: Affects gameplay
    Frequency: Always Happens

    Zone: Myrist, the Great Library
    Location: 278.49, 15.26, 27.20
    Character: Level 110 Channeler

    Summary: Recipes showing up on summoned crafting tables that don't belong
    Description: I've been noticing that when I click on one of the summoned crafting tables from the AA tradeskill line, recipes that don't belong on that station type are showing up. For example, one sage of mine just summoned a Stove and Keg for working on The Scrivener's Tale: Copper for a Tale, and it shows me the weapons from the recipe scroll Divine Weapons of Sky which are FORGE, then the Indestructedible Cookie which is correct, then a Fish Oil Candle which is CHEMISTRY TABLE, a bunch of level 80 foods, then Enchanted Adamantine Ore and Enchanted Azurite Capillary which are CHEMISTRY TABLE, followed by a bunch of Fighter Grandmaster Recipes Volume II which are CHEMISTRY TABLE--and it goes on and on. I tried it on a woodworker and am seeing recipes from Shadowscream Woodworker Studies I (woodworking table) on the stove and keg, and the same bizarre amalgam of other types along with what belongs.

    I have been noticing this on the chemistry table as well during this quest line, and probably the other stations but haven't really been paying attention to the actual ones till now. I don't recall this happening before so it seems to be new, but someone may know differently.
    Lateana, Tedra, Tkia and 5 others like this.
  2. Denmum Developer

    It seems to be new, and it seems to be intermittent. I cannot replicate it now, but it happened on a play character of mine last night. I am trying to get it to reliably reproduce. :(

    If it happens again, please do add info to this thread, and if you cannot find a recipe by targeting the table that it belongs to before we can find this ornery bug, you can always untarget the equipment, hit N, and select the recipe and start to craft without targeting the table (but standing next to it, of course)
    Tedra, Breanna and Twyla like this.
  3. Cusashorn Well-Known Member

    Hmm someone mentioned in Gen Chat on MD yesterday that their attempts to use the Loom in the Thurgadin TS area brought up the woodworking table recipes.
    Breanna and Twyla like this.
  4. Tiberia Member

    What I have found when you target a table and it opens the recipe book is initially it creates a Default: "TableNameHere" filter that seems to open initially.

    I then have to delete this new created filter and everything seems okay for awhile, but then it will randomly come back.
  5. Juraiya Well-Known Member

    That may explain why my tailor on Kael Drakkel couldn't see any of his tailoring recipes on the sewing tables in Frostfang sea.

    After seeing your post, I brought up his recipes, selected the one I wanted, THEN clicked the crafting table, and was able to craft.

    So it may be APPARENTLY intermittent, but what it is, is that it depends upon the order in which you select things.
  6. Cyliena Well-Known Member

    Zone: Sandstone Delta
    Quest: Researchers of Ro: Sandstone Setup
    Character: Zasia on Halls of Fate

    I've been unable to find the items when I directly click the tables for nearly all the crafts during the Sandstone Setup quest. First was a portable work bench 2.0; then the permanent crafting stations in the zone. Items I tried to search for are: Desert Forge, Desert Stove and Keg, Desert Engraved Desk (tried searching for just "desert" for those three), Pest Repellent Scroll (searched for "pest"). However, the Water Purification Tablet (searched for "purification") came up fine when clicking on the table first.

    The work-around to bring up your recipe window first works fine.
    Twyla likes this.
  7. Bahzelina Member

    I am seeing the same thing with regular crafting stations as well as summoned while doing the RoR sig line. The work around of using N while standing next to the station works. Rather disconcerting to see all the incorrect recipes.
    Twyla likes this.
  8. Defender of Hedgehogs Member

    I've just encountered it on the Elaborate Stove & Keg in my guild hall -- there are SOME provisioner recipes showing up, but tons of others that shouldn't be there, like tailoring. It's not even all the correct recipes, just a few of them.
    Twyla likes this.
  9. Traesta Member

    I had this in Sandstone Delta with the forge so I tried using the engraving desk then went back to the forge and the recipes were showing up correctly for the forge.
    Twyla likes this.
  10. Arreouw New Member

    This has been happening to me for a few days now on every crafting station I've used. I just camp to myself and when I get back, it's sorted out, but I wondered if anybody's figured out why it's happening. I'm in Halas right now, and it just happened again. This time, I got food on the Loom, but I've had all sorts of wrong things show up on various stations.
  11. korrigan69 New Member

    Same here, al recipes swaping stations, keg showing woodworking, engraved desk showing food, etc, etc
  12. Tkia Well-Known Member

    Not sure if this is going to help or hinder but this is the weirdness I found last night.
    AB server, character Rowenash, around 02:30 BST 17/4/23
    Level 100 carpenter with all holiday books so normally has lots of recipes on every workstation.
    Zone: Maldura. I picked up a full set of the daily crafting quests then started working round the stations to do the combines.

    Forge - 6 recipes only:
    3 Maldura recipes for the daily quest
    Candied Mushroom rarts - Nek grotto quest recipe marked for 'campfire'
    Preserved Parsnips - DOV quest recipe marked for 'Snowfang campfire'
    Gnomish Spirits - DoV quest recipe marked for 'Pirate distillery'

    Chemistry table - listing loom recipes plus the 3 recipes for the Maldura daily alchemy quest.

    Loom - 3 recipes only
    The Healing salve bandages for the daily quest plus the candied tarts and parsnips recipes showing on the forge.

    Workbench - listing all the chemistry recipes plus mana battery for the daily quest.

    I was about to try one of the chemistry recipes that I had the materials for to see what error (if any) that produced when my internet connection went down. This meant I didn't get a chance to test the combine or look further to see if tart or parsnip recipes were being listed on the station.

    Logged back in after a couple of minutes when the connection was restored. I was still standing in front of the workbench and on clicjing it all the correct workbench recipes now came up. Double checked the other 6 types of station and all were now showing the correct recipes.

    I hope the QA testers can make more sense of it than I can :(
    Whilhelmina likes this.
  13. Denmum Developer

    Every bit helps. Thank you for the details!
    Breanna likes this.
  14. Taled Well-Known Member

    Out of curiosity, is anyone seeing this on the *first* crafting station they use in a day, or is it typically happening when you switch to a second or third station?
  15. Tkia Well-Known Member

    Hard to determine from yesterday as I did the KA quest set first so I used the 2 stations up there 'first'. However these are both special workstations that only display the relevant quest recipes anyway. The Maldura stations listed above were the 'first' 4 normal stations I had used yesterday.

    Today I repeated that Maldura set from a fresh login on HoF and all 7 workstations displayed the correct recipes. However I did notice another behaviour change/inconsistency. I seem to recall that when I last did this I go to the station, click, the filtered list loads then I have to scroll down from the low level recipes at the top to the level 100 quest recipes I want at the bottom. Today the forge, chenistry table, stove and woodworking table all loaded the filter list and then auto-scrolled me to the level 100 recipes at the bottom. The workbench loaded me to the top of the list. The loom dropped me halfway through the level 10 recipes and the desk left me somewheer in level 7. Go figure.
  16. Caith Developer

    We are working on a prospective fix for this, though we have not yet been able to reliably reproduce the issue internally. If anyone does stumble over distinct reproduction steps, please make sure to update the thread so we can verify the fix actually addresses the issue.
    Twyla, Cyliena and Denmum like this.
  17. Pinki Member

    This is how i could reproduce it on Varsoon ( TLE )

    1. go to Butherblock
    2. use your tinkered, portable workbench to make some adornments
    3. zone back into your home city ( FP or Q )
    4. go to one of the craftingbenches and realise that the recipes are not assgined correctly.
  18. korrigan69 New Member

    After last update recipes bug still up.
    Zoning in/out from/to house, craft station not showing correct items
  19. Denmum Developer

    Just to clarify, this was after the update this morning? Thanks!
  20. korrigan69 New Member

    Yes, hoping this issue would be fixed with this morning update but no :(