I keep getting a socket error downloading today's patch

Discussion in 'Player Support' started by Altho, Aug 10, 2017.

  1. Albanara Member

    Unfortunately, same here. Stuck at 0 of 1545k.
  2. Backstabbber New Member

    I have problem to says installing then just shuts down. Can't get on and I was playing yesterday no problems.
  3. garcia Member



    I said the same thing to them
  4. garcia Member


    where on wed page ???
  5. merlincia New Member

    same exact problem here, no idea how to fix this..........not being able to log on to this game after game updates is getting old......
  6. LivingDeth New Member

    if you actually look at the history of it all i have seen posts as old as sept 2011 having the same issues, wether the cause is the same unclear, but when they list a socket failure error 6+yrs ago and we are facing one today seems to me they need to get there DUCKS in ROW so to speak( PG13 of what i was thinking) gets old when earlier i was playing just fine and now cant even get online because launcher WONT work at all and just fails out
  7. Altho Active Member

    You can use a VPN to get patched then you can log in normally. I connected to west coast and it worked. Credit goes to Luciar in Discord (Make sure you disconnect the VPN before logging in!)
  8. pplnotsointelligent Member

    What the heck is this message login failed Get patch and try again bogus
  9. PurpleChicken New Member

    Is this just a certain area? I'm in the northeast, too.
  10. pplnotsointelligent Member

    I take it that its not just me getting this crazy error bull crap, wow spending 80 dollars on this game, is ridiclious when I never had this issue before,, but then again I was having an issue with the game launcher and was playing thru the default settings
  11. LivingDeth New Member

    OK havent ever tried to connect to A Vpn anyone wanna walk me through that if possible?
  12. pplnotsointelligent Member



    idk I'm on the eastcoast
  13. garcia Member



    ok tried that didn't work lol
  14. pplnotsointelligent Member

    so what we just complaining and nothing gonna be attended to? or do the devs know of this issue,, I tried logging on discord and that wont allow me to go to the everquest 2 discord, they need to fix these issues
  15. Hurtsbad New Member

    Is this getting fixed? My patcher wont patch since the update. No I won't reinstall my Operating System. All was working fine before patch this morning.
  16. Backstabbber New Member

    Still problem can't update install patch. I am in NJ so East coast.
  17. pplnotsointelligent Member



    it has nothing to do with the isp I am running on the highest broadband speed there is,, they need to check there servers
  18. Garylev35 New Member

    Is there any way to run EQ2 without using the launchpad?
  19. Backstabbber New Member

    I tried I did the same thing. They say they are working on it hope it gets fixed sooon.
  20. Meredithe_Soulsfire New Member

    Yes but when ever there's been a patch the 'back door' doesn't work until you've run the patcher. =(

Share This Page