House Yrzu: Riddle me this . . . . .

Discussion in 'Quests and Seasonal Events' started by Monkybones, Jan 5, 2018.

  1. Monkybones Member

    This quest seems to be broken. I have spent over 30 minutes trying to find the third update point ( I should investigate the odd light I found ) and it's not there. It's supposed to be at -595, -48, 33 according to 3 sources and eq2maps.

    I'm moving on to something else but this needs to be fixed since it's a faction quest that leads to other quests. Without this quest, I cannot continue. Am I missing something?

    Thanks.
  2. Monkybones Member

    Anyone?

    So how is anyone supposed to compete the faction questline? Cannot be done! Confirmed by 3 other people I know that this quest does not complete! We need this fixed so everyone can complete the other quests it opens up.

    HELP!
  3. Redlight Well-Known Member

    Have you tried deleting the quest and then getting it again? sounds odd but sometimes that works.
  4. Monkybones Member

    No I haven't. I'll try that. Thanks.
  5. Monkybones Member

    Ok, I grouped with my wife and 2 other friends AND did the quest with a different character.

    Now, both the second AND third stop is not there for any of us. This quest IS BROKEN! Without it, it's impossible to finish all the faction quests. I just don't understand why nobody else has reported this since they cannot get to 50k faction in all houses unless they grind the lower repeatables endlessly, which I know that nobody likes doing.

    Oh well, again, I have to stop with this house and move on to another. Only this time there are at lease 3 other people mad about this bug.

    Has ANYONE found a workaround for this issue?
  6. Cronyn Developer

    This isn't something that had come up before, so this seems like a new issue. I wonder if they are falling through the world somehow.

    I'll look at this today and see if I can make a fix to prevent something like this from happening. Thanks for the heads up.
    Dude, Prissetta and Spindle like this.
  7. Anser New Member

    Your Jan 5 problem has returned. The is no update at the waypoint. Looks like this is a recurring problem. Can't continue the quest line without it.
  8. Sigrdrifa Well-Known Member

    I just did this quest on Maj'Dul on my mystic and had no problems whatsoever.

    One old trick for when an NPC is not visible: Go into Options and switch to using Alternate Appearances. Save. Then go back in and set it back to Regular Appearances and save. (Or vice versa as needed).

    If that doesn't fix it, then try /target Elishuru followed by pressing H to hail her. Sometimes for whatever reason, an NPC will fall through the floor or sink into the ground, but this allows you to communicate and usually causes the NPC to pop back up where it belongs.
    Seefar, Kaitheel and Xianthia like this.
  9. Kaitheel Developer


    Hmm, I am unable to reproduce this issue, Anser. Keep in mind that the "whispering spark" at this location is only visible when you are on specific steps of "Riddle Me This." Your quest journal must say, "I should search for the strange light "where the plants walk"" or "Some strange creatures are attacking!"

    I'm not sure if this was the issue you ran into, but there are several steps to this quest that are similar, and it is easy to get them confused if you are running through it on your second, third, or tenth characters (as some of us are wont to do).

    Sigrdrifa's advice is solid, and may help with this or other issues, when the trouble is rendering based.

    ~ Kaitheel
    Seefar and Rosyposy like this.
  10. Mermut Well-Known Member

    I did this quest 2 days ago w/o issue...
    Xianthia likes this.
  11. Aussie_one Member

    well me on on Majdul have dont this with 6 of my 7 chars all with no probs and have worked with 2 others guildies all with alts and no probs ???

Share This Page