House Yrzu Quests Feedback and Bugs

Discussion in 'Quest Discussion' started by Cronyn, Oct 17, 2017.

  1. elkhan New Member

    Hi,

    I was finsihing the quest "Right in the Noze" gave by Elishuru, then before updating and finishing the quest she proposed me the next quest to go find the sphinx Hichapcit.
    I finished the quest for Hichapcit and went back to elishuru, whom closed the quest but remains whit the red book above her head cause not validated the quest "Right in the nose". I tried to cancel the quest and strat from a fresh one ... but obviously Annuk'ka was not to be found in the garden as I already kill him (or her...) ...

    So I'm stuck on the timeline with no more quest to advance the faction of Yrzu.

    Thx for your help !
  2. Anatha Active Member

    Quest name: Land Development
    Quest giver: Majestrix Sangeeta
    Quest journal text: Collect eggs from plumewit nests (0/6)

    spawn rate is really slow. Please speed it up some.
  3. Cronyn Developer

    Okay folks, I made some changes today, and I want to give you a heads up as to what's coming.

    Elishuru is now properly visible in Khali'Yrzu for "No Pride to Speak Of" and "Right in the Nose."

    Reduced the spawn timer for plumewit eggs for the quest "Land Development."

    Olinnisk is now properly visible in Khali'Yrzu for the quest "Further Applications."

    The wisp box placements for both "Light Studies" and "Lighter Studies" have had their visuals changed, which will hopefully make them easier to find. The number of available boxes has also been increased.

    The infused soil has been enlarged, had an effect added, and I've added additional spots for the quest update.

    Think that's about it. These should all be in the next beta update, so let me know if you're still seeing this issues.

    Thanks, all!
  4. Cronyn Developer

    This should be fixed now - she was able to hand out a quest that she shouldn't have been able to. Should see it on the next beta update. You, however, may be broken - since you've completed a later quest in the timeline, you might actually have to recopy the character or start a new one to advance the line (the predicates won't read past the later quest).

    Thanks for reporting the issue!
  5. hoxboa New Member

    Hello Working on Quest Terra Forma Got done With that Part of Quest but there is no Portal to Zone Back to Plane of Magic
  6. Xianthia Well-Known Member


    thank you for these, was about to compose my feedback/bug on those two quests. I was able to get No Pride to Speak Of, but not the Right in the Nose one.
  7. Xianthia Well-Known Member


    Anywhere that you see the plumewits there are eggs, usually always around the rock formations, but also in Pakiat Bluffs. I did the repeatable and had no issues. Hope the location of more eggs helps you.
  8. Succulent Member

    Quest name: Further Applications
    Quest Giver: Olinnisk
    Quest text Return to Olinnisk in Khali'Yrzu

    Olinnisk is disappearing from by the river after getting the quest, and after talking with Mlheda and killing the mob then updating again with Mlheda, all id fine, but Olinnisk is not showing up in Khali'Yrzu
  9. Spartanec New Member

    Complete quest "Futhering Education"
    Olinnisk in Khali'Yrzu (103, 579, -655)
  10. Succulent Member

    had to camp in and out a couple times till she showed up
  11. Anatha Active Member

    Quest name: Learning Their Place
    Quest giver: Alishinu
    Quest journal text: Meet Salindis in Metetherial Plains

    This is still not working properly. I can't complete the quest.
  12. Cronyn Developer


    Yeah, found it. It was possible to be in a state where she wouldn't be visible to you. Closed the loophole. :)

    Thanks for the heads up.
  13. Vanyel Member

    Dress Code
    Will not complete when I walk to Elishuru (it used to before the other quests were fixed)

    This is on a brand new toon I just copied over today
  14. Cronyn Developer


    Hm. Okay so, you don't actually interact with Elishuru for Dress Code - it's given by Salindis and updates on Veliski. Salindis' lines and Elishuru's lines appear to updating properly for me.

    Can you tell me which stage you're on that isn't updating? I might be able to track down the issue that way - there very well could be something that I missed.

    Thanks much!
  15. Vanyel Member

    It says "Search Kandra Uplands for any traces of the magical anomaly"
  16. Vanyel Member

    I found the update. It was a faintly glowing spec in the hills
  17. Vanyel Member

    Quest: Forbidden Studies
    Text: I should meet with Salindis and Talisea in Khali'Yrzu

    Problem: No quest books on map. I found them for the update, and they talked to me, but nothing over their heads.
  18. Vanyel Member

    Quest: Teacher Conference
    Step: Find Telisea near the subversion fount in the Kandara Uplands

    Problem: no book/feather on quest map. After a LONG time looking, she's next to Veliski. What they are next to is the eldritch concentration. From the previous quests, the player has no idea where to find this "fount". I had to find it by trial and error. It only says fount once you right click it

    Not sure if this is intended or not
  19. Gaptia Member

    Water canvas :
    I'm doing quest in dual.
    I found Olinnisk on char one, I click the bubble, mobs spawns. I speak the char 2 to Olinnisk, mobs were killed before char 2 finished talking to npc. So no bubble to clic for char 2. char is stuck, Olinnisk didn't respaw the bubbles.
    I deleted the quest on char 2 and retake it. No bubble in water.
    After that I camped the char and then I see the clcky dark bubbles.
  20. Gaptia Member

    I have the same problemwith "Dress Code"
    I click on the light with char 1, Char 2 gets the update.
    But only char 1 can advance the step. Char 2 have to /camp to be able to click the light, and repeat the steps.

Share This Page