House Vahla Quests Feedback & Bugs

Discussion in 'Quest Discussion' started by Kaitheel, Oct 15, 2017.

  1. Kaitheel Developer

    Welcome to Planes of Prophecy Beta!

    There are three faction quest lines within the Plane of Magic. Please post any bugs and feedback regarding the House Vahla adventuring quests within this thread.

    When you are describing an issue, be sure to include:
    Quest name
    Quest giver's name
    Quest journal text

    That will help ensure that the issue will be examined and tended to by the appropriate developer, as soon as possible! Thank you!


    ~ Kaitheel
  2. Brensia New Member

    Quest Name: Still Not For Breakfast
    Quest Giver's Name: Shirada
    Quest Journal text: Obtain wakingdew root balls 0/8.
    Gather cnidcara egg clutches 0/6.

    The brackish wakingdew mob does not spawn nor drop the root balls needed for this quest. This is the repeatable version after the initial set.
  3. Kaitheel Developer

    Thank you, Brensia!

    With the next update this should be fixed. (I think there is one planned for tomorrow)
    • Still Not for Breakfast - Brackish wakingdew now spawn wakingdew root balls, no matter if you are on quest or not.
    ~ Kaitheel
  4. Leed Member

    Not sure if patch happened this morning yet or not (there was a client update from last night anyway), but they seemed to spawn the balls for me until I had 2 balls collected for the quest. Then they stopped spawning them. Was that the original bug? (also, the respawn rate on them might need to be upped, with 2-3 people hunting them they are permanently dead)
  5. Kaitheel Developer


    The original bug was that they wouldn't spawn at all when doing the repeatable version of the quest.

    I suspect what you're experiencing here is how you only ever spawn one root ball at a time, no matter how many Brackish wakingdew you kill. Defeat the root ball one you are fighting, and killing another Brackish wakingdew will spawn another ball.

    ~ Kaitheel
  6. Leed Member

    No, unfortunately there was no chance at all of me rounding up more than 1 brackish at a time with other people present and the respawn rate. I had the ball spawn for the first two, but then after that they just stopped. I thought perhaps they just weren't a 100% chance, so I killed 4-5 more (one at a time) without any spawning before I went to do 'Steal it all back' again. Could one have spawned under the ground or somewhere else, not be engaged in combat, and not be visible - yet still be considered as 'linked' to me and preventing any more from spawning?

    Edit: It's seeming the later might be it - I camped out, and back in, and they started spawning for me again.
  7. Kaitheel Developer


    Hmmm... possibly. I'll definitely take a look at it! Thank you.

    ~ Kaitheel
  8. Elaurana New Member

    Quest name: Sphinx Outside the Box
    Quest giver's name: Pannaxxun
    Quest journal text: (upon completion of the quest)

    This quest gave my mystic a sphinx illusion. Upon completing the quest, the illusion dropped but my flying mount did as well. When I attempted several times to recast the mount from the mount window I received error message: [BUG] Cannot cast. Failure type unimplemented: 43. Failure reason [unknown].

    Camping to myself does appear to fix the issue.
  9. Moss Member

    Quest name : Serving the Mindfold Matriarch
    Quest giver's name: Mindfold Matriarch Taneesha
    Quest journal text: "Deposit fibre the metethererial fibre strands within the evewers in __"

    NPC says : "Please deposit the strands of metetherial fibre within the containers _ location _ ."

    The "location" of the containers in missing in both the quest journal and the NPC text.

    Any help would be appreciate to advance on this quest
  10. Jasym Member

    Quest name: Here Comes the Bribe
    Quest giver's name: Meskhenar
    Quest journal text: "...Solve Meskhenar's riddle"

    Not sure if this is broken or I'm just blind, but I'm posting this in case it's not working...

    I've solved the riddle and know to look for a clicky. Several of us were on this quest at same time and a waypoint close to the quest giver was found. When I go to the waypoint I do not see anything there nor if I mouse over the area do I get anything to click on. Does this quest have a random spawn site?

    I'm not the only player not finding something at this waypoint.
  11. Mvrda New Member

    I am also having the same issue
  12. Moss Member

    Quest name : Serving the Mindfold Matriarch

    The clickable containers are in the city, I don't know why I was not able to see them the first time but I now stuck on next quest

    Quest : Counterfeitr It to Win It
    Quest giver's name: Mindfold Matriarch Taneesha
    Quest journal text: Swap the eetetherial ewers in Khali'Yrzeu

    I've visitied the whole place and could not find any clickable items or invisible items to validate the quest.
  13. knine Active Member


    Same issue. Nothing at the waypoint or anywhere close.
  14. Xianthia Well-Known Member

    Quest name Serving the Mainfold Matriarch
    Quest giver's name : Mindfold Matriarch Taneesha
    Quest journal text : The Mainfold Matriarch has asked that I gather strands of metetherial fibre from the Metetherial Plains, as preparation for the colloquy.

    The updates are actually in the Stratafold, not the plains.

    Once those updates are done, the quest auto updates and the journal description tells you to take the fibres to the ewers in ___ . Not sure if that's intended, but thought I'd mention.
  15. Xianthia Well-Known Member

    Quest name Counterfit it to Win it
    Quest giver's name : Chandira
    Quest journal text : Swap the imitation ewers for real ones in Yrzu.

    Not sure this is intended or just a bit of fun on how to get to the ewers. The ewers in Yrzu are spawning under the world. I was able to get to them but not without having to do some flying contortions :D Are the ewers supposed to be under the world or on the ground above?
  16. Jasym Member

    Quest name: Here Comes the Bribe
    Quest giver's name: Meskhenar
    Quest journal text: "...Solve Meskhenar's riddle"

    I finally got found the clicky item tonight after the update. I killed A Molded Sandbrute and the item was underneath him. Funny, I must have killed him 5-6 times earlier today.
  17. Alize New Member

    Quest Name: Oh Ye, Of Riddle Faith
    Quest giver's Name: Pannaxxun
    Quest Journal text: Gather tufts of spinx fur

    The hair brushes for this updates are very hard to click, theres only a very small Point which is really hard to hit
  18. Alize New Member

    Quest Name: Koyame's Elemental Study
    Quest giver's Name: Koyame
    Quest Journal text: Obtain planar earth/water/fire/air elemental samples (3 of each kind)

    Seems that some of the elementals (earth and fire) can only obtained on the small 2 Islands. There are 4 Mobs at all which can be every type of elemental. So updates take really long, even if you are the only one doing the quest.
  19. Earar Well-Known Member

    So Doing quest "here comes the bribe" ;;; I found the calabash, killed the mobs, Meskhenar appeared ... I can talk to him

    3rd part of the dialogue, I have "continue listening" option ... I click ... but the dialogue stops. I cannot move on
  20. Earar Well-Known Member

    worked, I had to be between meskhenar and irdd ... but didn't know that ...

Share This Page