Harvesting Macro for the New Macro System

Discussion in 'Tradeskill Discussion' started by ARCHIVED-Ripchi, Mar 29, 2007.

  1. ARCHIVED-deKoven Guest

    Hmmm, guess I don't really understand this at all. I was able to get a "Harvest" macro going which I made by adding the skills to a macro page. It works in that I can harvest, gather, lumber or fish just by clicking one hot button. When I looked at your macro I compared it with my toon and had/have a basic question. Are you using "non-issue" harvesting tools? When I open my inventory I don't seem to have a pick or shovel or fishing rod. Harvesting works so they (the tools) must be around but I can't seem to find them. Finally, I don't really understand how/why this macro would be any different than just clicking on the resource. Same-o, same-o; one click, one harvest. What am I missing in the discussion? :shock:
  2. ARCHIVED-MadTexan3 Guest

    [p]You need to have the harvesting tools (Woodworker makes them) in your inventory to make the most of this macro.[/p][p]The beauty of the macro is that it equips the right tool into your charm slot, harvests the node and replaces the item you had in the charm slot before harvesting when it's completed.[/p]
  3. ARCHIVED-Faymar Guest

    hah, very cool. I looked at this and thought, "that can't work" .... tried it and it's perfect. Swapping items faster than the speed of light! That's great. Well done.
  4. ARCHIVED-Zarevil Guest

    Now if it would just ignore the "you cannot mine this node" and other such messages as it attempts the different skills until it finds the right one. This is very nice macro.
  5. ARCHIVED-Rijacki Guest

    There are crafter made harvesting tools which speed up the time of each harvest attempt. You are correct in saying you don't -need- them, but many find the speed increase nice. I actually keep not getting 'round to getting a set for Rijacki and I harvest with her nearly all the time. I've always been reluctant to give up that many inventory slots for harvesting. Bad enough I loose one whole bag-worth of slots for my big bag o' harvest from Mara.
  6. ARCHIVED-deKoven Guest

    Rijacki wrote:
    Indeed, I find that I have little enough space at times. And add to that, why would one really need faster harvesting times. Of course, I'm retired and have (and use) hours each day to play (I'm single and fairly sedentary, ya know).

    'Course, the highest I've reached so far is lvl 24 wiz so as I get up higher I might feel differently about things. I'm still trying out different characters and types. So far I seem to have settled on a wizard (of any race) which seems to have the requisite cojones to go up against those baddies of whatever persuasion. I find that the "tank" chars need to get up close even to initiate combat whereas wiz and others of the spell type can initiate combat from a fairly "safe" distance, getting at least some damage in before the baddie even closes. This can be crucial at times.

    :XD:
  7. ARCHIVED-Calthine Guest

    You know those people who seem to monopolize a ahrvesting area and clear it faster than stuff pops? They're using tools. Basicly you can get more harvests in for the time you have and maximize your play time.
  8. ARCHIVED-Tamalain Guest

    I had the error about Transactions as well. Fixed it by switching the tools to use Charm slot 2. Charm 1 doesn't like to be swapped in and out all the time.
  9. ARCHIVED-bks6721 Guest

    I also use the above macro and love it! But, is there a way to silence the tool swap, its much too loud compared to all the other sounds.
  10. ARCHIVED-rumblepants79 Guest

    Theoretically what this should do is it goes down each command until it hits one that works. So say if you are mining it will stop there and you'll have an equipped mining tool and then once done it'll reach the end of the command. However what I'm seeing though is that the game runs all the commands at once but since you can only queue a certain number of actions it disregards some of the commands in the macro. A good test is if you remove the last command to re-equip your original charm, theoretically the same macro should still work since it'll cycle through the commands until it finds the right harvesting action. However for me it doesn't. :( Unless I'm reading this the wrong way. Once you trigger the macro, it'll only equip the first tool.
  11. ARCHIVED-dartie Guest

    [p]I was also getting the "Not currently in a bank transaction" message when I tried to use this macro.[/p][p]I followed another poster's advice and changed everything from charm slot 1 to charm slot 2, but that didn't solve the problem. [/p][p]I logged out and back in. That didn't solve the problem. [/p][p]I went to a banker and got the "end of bank transaction" message, then tried harvesting again, and still got the transaction error.[/p][p]Thinking the problem might be my no-value torch (since the OP uses one of the Tish Ticker torches), I destroyed my no-value torch, replaced it with the standard 3 silver kind, and tried again. [/p][p]Whether that is what eliminated the "transaction" error message or not, I don't know, but I'm no longer getting the message.[/p][p]Unfortunately, the macro still doesn't work for me. [/p][p]I thought it was working, but my torch never re-equips, and the harvest tool in my inventory only changes when I have the torch equipped to begin with.[/p][p]My first semi-successful harvest was on an animal den. I have my harvest skills set up exactly like the macro posted above (mining on top; trapping on bottom). I got a message that I couldn't mine, gather, or forest; my trapping item was equipped, and I did harvest the animal den. [/p][p]But when I finished, the trapping item stayed equipped. I moved to rocks, and my pick was not automatically equipped. In fact, no matter what I tried to harvest, my hex doll and trapping item remained equipped unless I manually removed them from their slots and replaced them with something else. [/p][p]I thought the torch might be my problem, so I switched the macro to swap out my hex doll. I had the same problems. [/p][p]It sounds like a lot of folks are having great success with this macro. I want in on it, but I'm not having any luck so far.[/p][p] [/p][p]P.S. The only difference between the way the macro looks on my screen and the way it appears here is that the image here doesn't have a box with "primary" checked anywhere. I don't know what that box does, but I've tried everything I can think of to get rid of it. No matter what I do, however, the first box ends up checking itself. Could that be the problem?[/p][p] [/p]
  12. ARCHIVED-CoLD MeTaL Guest

    [p]I just roll up to the node, target it and press 'f'[/p][p]While equiping the tools is a PITA, what you should be asking for is that the tools work 'from our bags without being equipped'.[/p][p] [/p][p] [/p]
  13. ARCHIVED-Calthine Guest

    CoLD MeTaL wrote:
    That never made sense to me. It's tool. Can't use it if I'm not holding it...
  14. ARCHIVED-CoLD MeTaL Guest

    [p]I can use my carpet without holding it, my horse whistle, my shard, my heart, my posion, my manastone, any of a 1000 potions, totems, yada, yada, yada, yada[/p][p]I can use an arrow without taking the arrow out and knocking it, before I shoot. I also don't have to switch out my bow for my sword, which would 'make sense' more than a tool.[/p][p]The fact that it is on my person, taking an inventory slot, and leave the little micro-management out, it is assumed that I take it out to use when i need it. [/p][p]:)[/p][p]I utterly detest micro-management. KISS always works for me. :) At some level there is 'too much detail' for a game.[/p][p]Does it detract from the 'immersion'? That is different for each person, I tend to visualize and immerse without the micro-management.[/p][p]The animation already has a 'tool' in use without me equipping anything. Where did that one come from ?[/p]
  15. ARCHIVED-dartie Guest

    CoLD MeTaL wrote:
    Haha! I remember when I first started playing. My wiz had no strength and was quickly overburdened with copper. I didn't realize the copper was the problem, and assumed that the problem must be the pick and axe and other harvesting equipment on my character. I kept going through my bags trying to find it, but it was nowhere to be seen except when I was in the act of harvesting. Wasted a lot of time figuring out that we appear to carry magically invisible and weightless harvesting tools, so I would have no problem with letting the items affect harvesting even if they stayed in our packs.
    Or alternatively, I'd love to make the macro work!
  16. ARCHIVED-Prrasha Guest

    I'm pretty sure the 'bank transaction' thing is related to having identical items in either your normal or shared bank slots. When I was handing out a set of tinker-made tools to all my alts, I set up this macro, and got the occasional "bank transaction" related error, until all of my alts had picked up their tools from the shared bank. So be sure you only have one torch/hex doll/shovel/etc that the game could be considering, before assuming the macro is broken. It might be trying to equip that extra shovel in your shared bank slots from the middle of the Sinking Sands... You can see a similar effect if you try to examine a Lore and Legend item (skeleton leg, etc) from inventory when you also have some banked... you'll get the quest update, but the L&L item that gets eaten is the one in your bank, not in your backpacks. (Doing this to free up backpack space, only to have the wrong one go away, is annoying.)
  17. ARCHIVED-CoLD MeTaL Guest

    I think they fixed that.
  18. ARCHIVED-SkinnyFats_EQ2 Guest

    I don't think it is fixed. Just last night I examined two L&L items from my inventory, got two update dings, and neither item disappeared from my inventory. I assume I also had copies of the items in my bank, but am not sure. I know for certain they were still in my bags after updating the quest.
  19. ARCHIVED-CoLD MeTaL Guest

    [p]You know i had some L&L items in the shared bank right click got quest blue window click examine, it didn't disappear, I thought "Great re-usable L&L items", i bet one i had somewhere else disappeared.[/p][p]Reminds me of Steven Wright:[/p][p]In my house there's this light switch that doesn't do anything. Every so often I would flick it on and off just to check. Yesterday, I got a call from a woman in Germany. She said, "Cut it out." -- Steven Wright [/p]
  20. ARCHIVED-dartie Guest

    Finally got this to work.
    Other people clearly have success using the icons (for gathering, mining etc.) in conjunction with the use spell/ability option on the macro.
    For me, the problems vanished when I used "/useability mining", etc. in conjunction with the command option.
    I hope that helps some other folks.

Share This Page