GU120 Tradeskill and Merchant Updates

Discussion in 'Beta Quests Discussion' started by Denmum, Jul 26, 2022.

Thread Status:
Not open for further replies.
  1. Denmum Developer

    I found another issue with recipe granting for the level 60 quest series for Dora Wickett. It should be working in tomorrow's beta patch. Sorry about that!
    Breanna and Uwkete-of-Crushbone like this.
  2. Chikkin Well-Known Member

    Quest: Barren Doors - got recipe for basic doorbot, scribed it since it popped in bags but didn;t auto scribe. Made one, it did not update quest.
    made 2 more using blueprint feature, still no updates, quest still says craft basic doorbot 0/3

    I put in a bug report, but deleting and re-getting the quest did not help, deleting quest also left the 3 bots I made in my bags. Making more doorbots still does not update quest
  3. Cyliena Well-Known Member

    I submitted a bug report, but thought I should post about this too. For "The Hangry Halfling: Svarni Expanse", the Svarni Silverfin fish harvest is not being auto-consumed by the quest while the quest is still updating. All other harvests appear to have been auto-consumed correctly. Moving on to the other two Hangry quests to check on them as well. :)

    edit: "The Hangry Halfling: Mahngavi Wastes" and "The Hangry Halfling: Karuupa Jungle" are both fine, all common resources are auto-consumed.

    The pop-up text of these quests says: "Quest Item Found! resources 77/100" (or whatever number you're at).... Can the "resources" be changed to something a bit less generic? Maybe "Resources for Duffin"?

    The "Shallow Forlorn Bowl" reward... I swear we have a house item using that art already. Or maybe it's just something very similar. Unfortunately, I didn't copy over my carpenter, and EQ2 Decorators website seems to be down.

    edit: After placing the bowl, the color does look darker than the house item I'm thinking of, though the style is quite similar from my recollection. I am wondering though about why the cup is a different color scheme than the bowl and plate? I do like them all as they are, I'm just curious. :)

    edit: OMG the base size of the silverware and cleaver is MASSIVE (compared to what utensils should be). They are about the base size of the plate plus half of the bowl. :D The utensils size down just fine so this isn't a problem, but just wanted to say that I'm in tears from giggling over their base sizes.
  4. Denmum Developer

    It should (really, truly!) be working after today's beta update, but you may need to delete the quest and re-obtain it for it to properly catch the quest trigger fix. Sorry about that!
    Chikkin and Breanna like this.
  5. Denmum Developer

    Edit: Aha! The patch hadn't gone in yet due to the downtime not allowing any patch work while the back end work was going on. Patch should be going in (going down in 4 more minutes) and the fix with it. I'll report back once the server is back up and I am sure it is behaving.
    Breanna likes this.
  6. Denmum Developer

    I cannot duplicate this. The silverfin autoconsumed just fine for me, as did all of the other non-rare resources. When you say that the quest was still updating, were you going by the quest helper, or were you relying on the on-screen updates at the top of your screen (which cannot keep up with the speed at which we harvest, so still "ping" away after the quest requirements are met.?) Was it possible that your pack pony did some autonomous harvesting that dropped into your bags?

    With regards to the dishes, there are some that are similar, some that are broken, etc., etc I couldn't get a matching cup, as I was "just" scrounging through the art that was made for Forlorn Gist, and was able to set aside a few for this. (Nothing extra was made for this quest, so it was up to my scrounging skills.) I think I am going to tweak the base size of the silverware down just a tad. :)
    Breanna likes this.
  7. Cyliena Well-Known Member

    It was the quest helper I was looking at while that was happening. I have the quest in my journal again so I'll go re-try it now just to see if I was crazy (maybe they were from bonus harvests and I wasn't paying attention to that at the time).

    edit: my apologies, you're correct, it auto-consumes the fish. I must've been getting bonus harvests at the time, which I didn't pay attention to until the two later quests.

    If you do tweak the base silverware size down some, please keep the max size that they go to. :D I recall seeing a comically large fork and knife wall hanging at a store once, but could absolutely envision someone doing that in a cottage type build on EQ2.

    There's a nice wooden-looking bowl right next to Duffin... can that possibly be added in as a reward, too?
    Breanna likes this.
  8. Denmum Developer

    Doorbot crafting now works properly for "Barren Doors". If you picked up that quest before today's update, please delete and re-obtain it - I didn't do a force-reset of the quest for beta.
    Chikkin and Breanna like this.
  9. Chikkin Well-Known Member

    small bug got in with the change to Barren Doors, quest journal says
    I must craft 3 Basic Doorbots
    Craft Basic Doorbot 0/2
    Quest updates for first 2 crafted (even when using blueprint) and progresses to next step

    If there's any time for suggestions, might I suggest inspecting the palace of awakened personally as a last step?

    Nest top of stairs, then El'Arad top of stairs, then Palace personally
  10. Chikkin Well-Known Member

    Tenebrous Doors quest also needs the journal part of text adjusted to say "I need to craft 2 Doorbots"

    Bonemire Doors quest - Halls of Fate has a very tiny and specific spot where the releasing of bot works? I walked around the cloud pad area and it finally worked, it was getting frustrating though.
    - Cacotoxic Stain pad for Sepulcher update does not have the blue dot on map guiding you to the bot release spot
  11. Rosyposy Well-Known Member

    We met Raffik's parents in KA, maybe one of them wants to quest? Or maybe Raffik has a long-lost sibling who needs to quest to be reunited with family?
    Breanna likes this.
  12. Ashlie Active Member

    I ran the quest today.

    In Barren Doors it seems a bit odd that we are asked to craft 2 doorbots, but then place 3 of them. I did this part before the patch today.

    In Bonemire Doors after crafting the upgraded doorbots the quest helper just says "whichever door" scanned. That makes it sound like it was already done. It would make more sense to say Scan "whichever door". This same wording is used for the bot placements for Loping Doors.

    There is not a blue dot for the Blackscale Sepulcher doorbot release point.
  13. Denmum Developer

    Actually, you make two and place two. After you release the Doorbot for the Nest of the Great Egg, it tells you: "Examine the door to the Palace of the Awakened". Even squishies can safely physically travel to that one and thus you examine it yourself.

    I'll work on the wording a bit.

    That has already been fixed internally and is headed for beta tomorrow. :)
    Breanna likes this.
  14. Denmum Developer

    That's a slim possibility, but, the biggest thing is that there have been 5 expansions since the quest line was touched, and a 6th expansion is on the horizon. That's a lot of new quests to make, new recipes to come up with (including whatever item will require the amalgamation, which needs input from Itemization, etc.) Definitely not impossible, but there are a lot of other priorities. I may decide to do it anyway, I may decide to do something totally different for amalgamations in the upper tiers, or I may do nothing at all with it. I don't know yet.
    Bludd and Rosyposy like this.
Thread Status:
Not open for further replies.