F.S. Distillery: Distill or be killed Heroic Lift is bugged

Discussion in 'Resolved' started by Rynnn, May 14, 2021.

  1. Rynnn Member

    F.S. Distillery: Distill or be killed Heroic:
    Lift is bugged to get to the two final bosses for the Destroy the rum master's book.
    I've been in the zone for more then 3 hours, everything is dead except for the last two bosses.
    I can't get the platform lever for the lift to come down. :/ Has this been an issue for anyone else???
  2. MSG1 Member

    yes, you have to be mentored down to get the levers out a chest from 1st boss
  3. Rynnn Member

    That doesn't make any sense. There was someone just the other day that was doing the heroic just as I did and they weren't any higher then the level of the quest and the lift was bugged on them as well. So I don't believe it has anything to do with your level. I've talked with others that have run that same quest on Heroic and are level 120 like I am, they weren't mentored down and the lift worked fine for them.

    Just need a dev to check it out.
  4. Benj Active Member

    I ran the zone a month or so ago, and experienced the same thing. The final lift wasn't active. I had killed every named, and I was mentored to 100 the entire time. On a whim, I left the zone, did something else, and came back to the same instance. Lo and behold, the lift was working again! I don't remember getting any levers from any boss, but it's possible I overlooked many of the "scripty" elements of the zone, seeing as most enemies died in one hit.
  5. Kaitheel Developer

    I was unable to reproduce this issue, Rynnn, but as others can attest it does happen. There are no character predicates on the lever. It doesn't take into account your level or even zone progression. The lever is only checking the location of the platform. So, if the platform is at the top, it is suppose to then lower it, and while it is at the bottom, it is suppose to raise it. What you and others have experienced must have been an intermittent bug where the lever didn't recognize the location of the platform. These kinds of issues can often be resolved by the zone being closed and reopened, hence why someone who exits to do something (like getting mentored) might return to find the lever working.

    ~ Kaitheel
    Breanna likes this.
  6. Gandolph Member

    I can confirm that this bugs still exists ran the zone this morning and was unable to get the lift to work to get to the last named, zoning did not help, thanks
  7. Sionx Renaissance Ranger

    Thanks for the clarification Kaitheel.

    I am also experiencing the same issue now where the final platform lever does not respond to a left or right click. I tried camping to myself (no change in the lever status), then I left the zone from the entry portal (no change). I just tried exiting and relaunching the EQ2 client (no change). I'll come back in a few hours or tomorrow to see if the platform position resets.
  8. Chrol Developer

    I believe this was caused by the Platform Lever not recognizing the fact that you defeated The Red Corsair. A fix is in and should go out with the next update. Thanks!
    Breanna, Xianthia and Bludd like this.
  9. Kaitheel Developer

    I have no idea how I missed the predicate that Chrol identified. Yikes. I am so glad he could find what I didn't and that he could correct it.

    ~ Kaitheel
    Breanna, Xianthia and Bludd like this.