Disappearing items in Layout Editor + Solution (I hope)

Discussion in 'Norrathian Homeshow' started by Ratbill, Nov 14, 2017 at 11:10 AM.

  1. Ratbill Well-Known Member

    Hi all. During a deco raid, there was a discussion about disappearing items when using the layout editor. I first thought it was a bug that only I had, but it seems pretty general. First, I want to point out that I do not know what is causing it. I have tried different ways/things, but it keeps happening. I have been working a lot with the editor lately, and it was annoying me greatly.

    A complete example, as happened during my latest build:
    It was for the YtD17 event, so only Dessert Urns were used. I had created an object (object A) with the editor, using DUPLICATE several times and shifting it north each time. No problems when loading the layout in the house. I used CREATE OBJECT in the editor to create another object (object B). After saving the layout and loading it in my house, 2 urns from object A + 2 urns from object B where moved to the moving crate. At the start of loading, they appear in the house. Almost at the end, they disappear and are moved to the moving crate. Both objects now had some gaps from the missing urns. At this point my blood pressure is going up pretty fast. This has happened to me before with flat floors that are easy to fix holes, but this would be nearly impossible to fix. As it seemed like I had to do it all over, I started to experiment with things to correct this problem. I will save you the details on all I have tried, but I did come across something that worked. It may not be elegant, but it worked for me and I hope it will work for you too.

    The Solution:
    When the 4 urns disappeared after loading the layout, I placed 4 urns by hand and loaded the same layout again. The original urns appear and disappear when loading and the extra placed urns are automatically moved to the gap that was created. (I did not do any saving between the first load and the 2nd load.) These 4 extra placed urns are not in the layout file you are trying to load. I had to do this every time for each new thing I did with the editor. After the 5th time, I just placed 10 extra urns every time I wanted to load a changed layout and had no more problems. I remove the extra urns each time before a save and place them back each time before a load. Every time, a few of the extra urns disappeared to fill the gaps.

    Like I said, I have no idea what is causing it, but here is a step by step solution, based on the above story.
    I am not saying that it works, but it is worth testing, as it can save you a great deal of aggravation and make working with the editor a lot easier. It is always annoying when it happens, but it isn't a problem when you know how to fix it.


    Solution:
    1 - Load the layout and check if there are any gaps because of disappeared items. These can be anywhere, so do a good check. (so far for me, it are always items that are created/placed with the editor.)

    2 - Place a new one of that item near the gap and do that for each missing item. DO NOT REMOVE THE ITEMS FROM THE MOVING CRATE, it has to be a completely new one.

    3 - After placing all items near their corresponding gaps, load the same layout again.

    4 - If all goes the same as in my case, the items should fill the gaps and all problems are solved. :)


    After typing this, I get the idea that the editor places items from the moving crate into the house, but does sometimes not remove the item from the moving crate, making it a duplicate with the same item ID. When the layout is loaded, it shows on the screen, as the contents of the house are rendered first. At the end of the load, the moving crate contents are resolved, placing the items back in the crate. I have no idea why the extra placed items would fill the gaps, I am just glad they do.

    If people have tried the above, please give feedback to see if it works every time for everybody. :)
    Uwkete-of-Crushbone likes this.
  2. Uwkete-of-Crushbone Well-Known Member

    Hmm! I'm going to be working on an object that has like 112 identical items as parts of its construction, so I'll give this a shot... ;->

    But the last time I made one, I finally just gave up and placed all 112 by hand. :-/

    Uwk
    who wonders: Sennen's OpenSource editor is slightly less sophisticated (doesn't move things by secondary cardinal directions, for example [NW/SE/NE/SW]), but would it have those same problems... :-/
    Ratbill likes this.
  3. Merriel Well-Known Member

    Ratbill, team {DVC} has encountered this issue as well. It seems to have something to do with the moving crate, so our workaround has been to just not place the items in the moving crate. We set the items down in the house, and when taking a New from Diff, we just resize or move up or down or rotate the items we want in the Without file.

    This is not always foolproof, however, as I did recently use our workaround method and it still pulled items from a build as opposed to using the new items in the house, but in this particular case, the items that were set down had originally been in the moving crate then removed into my inventory and then placed down on the floor, so the fact that they had been in the moving crate to begin with may have had something to do with it.

    I really think that to avoid this issue, the items should never be placed in the moving crate at all.
    Ratbill and Uwkete-of-Crushbone like this.
  4. Uwkete-of-Crushbone Well-Known Member

    I blush to admit, I thought I'd gotten the whole With-Without-Working thing down and understood, but I eventually just went back to my usual "place something, Save it, tweak it in the [your favorite flavor here] Editor, Load it from there; lather, rinse, repeat" stuff. I freely admit to tearing my hair out over mistakes I could have probably corrected more easily if I did do the 3 W's, but if it's a really important, convoluted build (like, more than two rooms [or even just two really filled rooms] and too fancy to risk), what I'll do is save my beloved Notepad file as a .txt file. It won't be usable at all as a reference file for the game, but I can at least see what the numbers were for a problem child item before I messed it up. :-/

    Uwk
    Ratbill likes this.
  5. Ratbill Well-Known Member

    The option of not using the crate sounds interesting, but how do you create something like a 200 item spiral coil of 1440° total with a Z increase without using the moving crate? Or actually anything new. The most things I do is building rows, create spirals and circles and mirror items. For all these actions, the editor uses the items in the moving crate. It is a major pain to do that by hand, even when using a spreadsheet with formulas. With the editor, it takes only a few minutes by determining the base coordinates with a column (like tall elm column), diff that and write down numbers. Enter numbers in the create object tool and poof. Ok, it may take a few tries to get it perfect, but it's very fast. If there is a way to do it in the same amount of time without the use of the moving crate, I am eager to find out how that is done.

    When I am doing patchwork, like aligning items by changing x-y-z to the same number, there is indeed no change in the moving crate and I hardly ever see any items disappear. The problem arises mostly when I am creating large objects of more than 20 items.
    Merriel and Uwkete-of-Crushbone like this.
  6. Uwkete-of-Crushbone Well-Known Member

    More than 20 different items? Or at least the design would be noticeable if all 20 didn't make it through...yeah. I try not to take anything out of the Moving Crate with the editors, since I've had issues with that before, and I either place all, say, 50+ tiles (from a recent example) some place on the floor that isn't going to be tiled with them and change their coords. Or find room for them in my inventory bags and place them individually (though thanks, Oaky, for that lovely how-to video in wall-making! That helped! :D). Or line them up approximately where they need to wind up (done that for spiral staircases, then just adjusted the heights), then number-crunched. ;->

    I mean, if nothing else, you still gotta put the item down at some point to right-click on it and send it to the Moving Crate in the first place, right? Or am I missing some fast/easy way of doing that (likely)... :-/

    Uwk
    Ratbill likes this.
  7. Ratbill Well-Known Member

    The easiest way to get items in the moving crate, is placing them in an empty house (small inn-rooms are perfect) and use the house window to move all items to the desired house. This does not effect items already placed in the house that you are moving to.

    As for the hand placing, that kinda defeats the purpose of the editor. I tried that with a floor that was not aligned with the x-y axis. It turned out horrible. With Build Row, that goes in a sec without any effort. If not using the moving crate is done as you described Uwkete, than it is not suited for most things I do with the editor unfortunately.
    Uwkete-of-Crushbone likes this.
  8. Ocarinah Well-Known Member

    So if you are using duplicate after already having items placed in the house it does tend to bug out unless you make sure to load all of the items (original ones) and the new duplicate items with one load file. I like to use moving crate differently than most people. I like to place all of the items that will have large amounts of like building blocks down, using the diff feature. I like to set all of those items to the exact same spot like 1, 1, 1 or something so I know it is not in use. Anything in moving crate that doesn't have a home is set to the same number so I know it is really available. After loading them into that spot using editor, I then will move then into moving crate using editor. When I need to use those items I add what I need from moving crate into the group using editor. I usually use copy paste. If I need to use duplicate then after I have done so I create a new group ALL Black Marble Tile or whatever it is I am working with. I have all of that item, previously placed and duplicate items. I then I save that group with ALL items and load it up. I haven't had an issue unless I try placing the items into an unallowed area and those items stay in moving crate. The only items that I do never use duplicate on are house portals, house actors and mannequins. Those are a pain in the rump.

    The other thing I use moving crate for is trying to sink items somewhere the editor won't let me. If item is in the way, I pack it up temporarily. When I am done I can just unpack using editor and it goes right back to its spot. Because of this use is why I set all unused items to exact same spot like 1, 1, 1 or 0, 0, 0. You have to load them into the spot tho and then after you loaded them you can place into moving crate. Changing the values on an item directly in moving crate using the layout editor will get reset if you load a new file for the house.
    Ratbill and Uwkete-of-Crushbone like this.
  9. Ratbill Well-Known Member

    So many different ways that everybody uses the editor. But as it seems, it could be an anchor point problem. If the anchor point of the item in the moving crate is illegal for the house, it could do weird stuff. Looks like it is back to the editor (and the desert urns) for some more testing. :)
    Uwkete-of-Crushbone likes this.
  10. JesDyr Well-Known Member

    Soo .. without a very detailed step by step, it is hard to know where things are going wrong, but that doesn't really matter. I am not 100% sure I remember everything correctly about how the EQ2 client loads layouts so I wont get into that. I will say It will always try to get an exact match of an item based on the UID in the layout. I built the later versions of the editor to use the UIDs for many things.

    First you want to check your settings. Make sure Auto Replace UIDs is checked. This will cause the editor to "pull" items from the crate whenever it "creates" a line. If it cannot get an item from the crate tab, or the auto replace is off, it will give the new line a UID that is negative. If you see a negative UID, there is a chance you will have a problem like you are currently having.

    The second thing is to understand that if you pickup an item in game and place it back down, it will change the UID for that item. If the layout you are working with is from before you picked up and replaced that item, The editor will have the old UID and when that layout is loaded by EQ2, there will not be an exact match, and it could cause missing items.

    So how do you fix things once it is all mess up? The answer is to create a layout that does not include any items in the moving crate in the editor. How you do this differs slightly depend on what version you are using. In the 1.7 versions, click the crate tab (In 1.8 versions, select the filter "Crate only"), then click the area next to the "ItemID" heading to select everything, and then hit the delete key on your keyboard. The use "Save As" under file to save it as a new layout. Loading this new layout in-game should fix the problem.

    There are some other tricks you can use, but honestly I don't remember the exact steps anymore :)
  11. Uwkete-of-Crushbone Well-Known Member

    That's why we need you back in, bud! :D

    Uwk
    Ratbill likes this.
  12. Ratbill Well-Known Member

    Thanks. This info will help a lot in the tests.
    I always do check if there are any negative or strange UID's before saving, as this is indeed a cause for disappearing items. For the example mentioned in my first post, I am sure this is not the case.
    So far, my series of test will be focused on X-Y-Z coordinates and UID's of items that are in or come out of the moving crate. Also some tests will be done with an empty moving crate. As chemical analyst, it is a hobby of mine to figure things out. And this is definitely something I want to figure out. My goal in this is to be able to have an empty house with 1200 items in the moving crate, open the editor, create things with the editor till all 1200 items are used, save it and load it into the house without any problems. It shouldn't be that hard to get to the bottom of this, we are talking about computer programs, there is only 1 & 0.
  13. Uwkete-of-Crushbone Well-Known Member

    LOL! True, but it's the configurations that make all the difference...organic chemistry is only C-H bonds. :D

    Uwk
    Ratbill and Prissetta like this.
  14. JesDyr Well-Known Member

    If those are the only steps, I don't think you would have a problem. It is normally the starting and stopping where things go wrong. My normal process was to always work with freshly saved layouts whenever possible to ensure the UIDs were always correct.

    I will always encourage such behavior :) .. Like I said, It has been a while for me. I did a ton of testing mostly on early layout versions before they added the Unique IDs. I think Maevianiu has posted some info in the past about how the game loads layouts (nothing too detailed), but I think most of the good information was on the old forms. I remember some information from Rothgar? early on as well.
    Ratbill and Uwkete-of-Crushbone like this.
  15. Ratbill Well-Known Member

    There is a lot of info scattered about. I have been reading different articles, but the exact problem isn't yet clear to me. I am no different than all the others who have looked into this. Whatever the outcome of my tests will be, it will most likely not be anything groundbreaking or new. But if I do things myself, I see what happens. That makes it easier for me to understand what happens. And I can come up with a way of working with the editor that works for me. If others can benefit from that, it would be great.

    My thanks to everybody, because now I have a clear path to follow during testing. And special thanks to you JesDyr, it is always nice to have feedback from the developer, and it helped a lot also. It will take some time before I'm finished with my tests. But when I'm done, I will post the results here. :)
  16. Uwkete-of-Crushbone Well-Known Member

    Please do! :)

    We can peer-review them! :D

    Uwk
    Ratbill and Prissetta like this.
  17. Merriel Well-Known Member

    That is one of the problems we had when creating the "jewel" at the top of the tower in the Isle of Refuge home we decorated in Fyreskayle's Jurassic Safari on Maj'dul server. Vas came up with a solution that worked, though it was very tedious and required a bunch of manual copying over of locations, but it did work in the end.

    We used both tinkered windows, the yellow and the green to create the jewel. We wanted the entire jewel done in the yellow windows, so for each circle, we placed the correct number of green windows into the house, and the correct number of yellow windows into the house. Using the circle tool, we created a circle using the green windows, then copied the location of the green windows to the yellow windows. We needed a new New from Diff for each circle created. Once we replaced the green windows with the yellow windows, we would do the next circle in green windows, then once that circle was complete, we would replace the locations of those windows with the yellow windows in the new New from Diff. When we got to the last circle, we looked up and decided we liked the contrasting windows and decided not to replace the last circle with yellow windows, but kept the green ones for that last circle.

    The reason we had to do it this way is because using New from Diff, when the circle tool would create the circle, it would replace the UID's with fake UID's, as if the windows did not exist in the home, so if we used the yellow windows to create the circles, it would pull windows from the previously created circles. By using the green windows which only existed in the current circle, it could only pull from the green windows already existing in the house, since they were all supposed to be part of that circle.
  18. Uwkete-of-Crushbone Well-Known Member

    Oy...and you used different colored windows to keep track of what you'd already done before ("Yellow means we're finished with that circle.")? Sounds logical. :)

    Uwk
    Ratbill, Prissetta and Merriel like this.

Share This Page