Custom UI Issues

Discussion in 'General Gameplay Discussion' started by Tiberia, Jan 27, 2023.

  1. Tiberia Member

    I have tried posting this on the interface boards, but there isn't any real traffic over there these days.

    I have created a UI element that extends a window and basically adds the noncombat abilities that players can unlock over time. This includes the summing of crafting tables, artisan goblin, pack pony, tracking harvestables, refining, salvaging, transmuting, and adornment reclamation.

    The issue I am having is that I have setup each button in exactly the same way, however some of them are simply greyed out and do nothing unless I add the useability command to them.

    For example:
    Summon Forge works perfectly using ActionData="spell 307303251 20775682 711502966"
    The icon lights and displays properly. The tooltip shows the correct information about the spell.

    Summon Stove & Keg does not work using ActionData="spell 2352318192 20775686 3633124458"
    The icon remains dark and the tooltip does not show. I can only get this button to work with OnPress="useability 2352318192"

    In my UI XML, all other attributes are exactly the same except for the ToolTip which I have tried removing but resulted in no change.

    I will be happy to share the entire file with anyone that asks and would love if someone could point me in the right direction.

    Thank you!