Continuation Of Freeport Timeline

Discussion in 'General TLE Discussion' started by Xephane, Aug 23, 2015.

  1. Xephane Active Member

    I probably should have mentioned this before when I was actually doing the zone, but I feel as though one of the quests in the Freeport City Quest timeline was bugged out badly for TLE. I remember I continued the quests in the line over level 40 because I needed the extra boost of exp to get to level 50, and these quests were helping me a bunch.

    I ended up getting stuck at one point. I was sent to Slaver Isle and had to grab a bunch of Slaves out of their cages but this quest was not easy to do, as it is in a very bugged state.

    1. The mobs in here are extremely strong, lots of hp and very difficult to solo.

    2. Almost every single mob in here has different aggro ranges as well as social aggro, causing half the zone to rush at you on about 90% of pulls.

    3. Mobs have abilites like Jugular Slice and other forms of CC that lock you down for long periods of time.

    I understand these quests were not intended to be done at launch, as they were a fairly recent addition to the regular servers, but giving these quests some fine tuning to make them soloable on TLE would be great. I am aware that TLE content is not supposed to be solo-able, but the Freeport lines were created as solo quests. Cheers :)
    dirgenoobforreal and Alenna like this.
  2. Rhodris Well-Known Member

    Is this the one where you have to sneak in and avoid the guards? I got stuck on that one and could never get past the 2nd or 3rd guard (can't remember now) so stopped doing this quest series some time back.
  3. Xephane Active Member

    No, you have to go to Slaver Isle and kill a bunch of slavers (every mob in the zone) and then pick up slaves so Academy can use them as experiments for Wraithguards.

    Edit: The quest series I am talking about is continuing the quest line for the level 20 cloak.
    Rhodris likes this.
  4. Kraetec Active Member

    I actually opened a ticket for this very quest ("Set Sail for Slaver's Isle") as a Shadowknight. Here is the response that I've received thus far. (Please note that the newest entries on this ticket are at the top.)


    To be honest, I just haven't had the time to make an official report on the issue tracker (and, I was actually going to post here first to see if anyone else ...other than summoners... had beat it.)

    Anyway, my guess is that the problem is a combination of the fact that this quest was tested with characters with 50+ AAs and/or the mitigation nerf on the TLE server. Can anyone confirm that the mobs are indeed heroic on the live servers on this quest?
    Xephane likes this.
  5. Xephane Active Member

    I beat it as a bruiser, it just took me a ton of tries and broke my gear almost twice. I don't know how I did it but I had some pulls pull half the zone, while some pulls didn't. It's not just about clearing it as a certain class, it's about clearing it as ANYTHING.
  6. Kraetec Active Member

    Hmm ...I dunno. I have pretty good gear (definitely Mastercrafted or better in every slot) and I was able to kill ONE of them in that third pull ONCE. SKs don't have a ton of single target dps (other than harm touch) so I struggled to kill even one before dying. The insane dps the mobs put out (when you're getting beat on by 13 heroics at a time), plus the CC they do ...make it really tough.

    I can only assume that necros probably die a few times too before getting it done. But, I imagine it's a little less death than the rest of us because their pet can tank as well as most of us, and they typically have greater single target dps.

    One thing that is interesting is that at the time I first tried this quest, I was getting server discoveries on quite a few of the prior quests. (This was a couple weeks ago.) So, I just don't think many people are doing these quests and I guess any developers playing on the TLE have most likely not tried them either.
    Xephane likes this.
  7. splatterpunk28 Well-Known Member

    Well if shadow knight's can't do it, my illy certainly can't. I broke my gear trying. Submitted bug report and /petition.
  8. dirgenoobforreal Well-Known Member

    This still hasnt been fixed. You have to mentor your way through or duo some of the one you can duo.
    Xephane likes this.
  9. Xephane Active Member

    I had to make a level 1 toon so my mother could mentor me and clear it. This was very recent. Still crazy bugged, but doesn't seem like it will be fixed. Silly how it's been an issue for like 2 years now hehe.
    Meneltel likes this.

Share This Page