Cleric Spell: Odyssey bug

Discussion in 'Beta Class Discussion' started by Boldac, Apr 3, 2022.

  1. Boldac Member

    Odyssey is giving the "That zone is currently unavailable" message.

    Tried zoning, running to other zones, running to my bind zone (Qeynos Capital Disctrict) and porting across the world and trying again, same error. Call to Home works just fine.
    Ayodi and Breanna like this.
  2. Riverbear Active Member

    Required component to spell from class trainer: Odyssey Stones. Just tested under different conditions, spell works fine with required component.
    Be well :)
    Breanna and Ayodi like this.
  3. Beneeto Member

    Is that a recent change they've made? Odyssey hasn't required stones in ages. Does Call of the Hero also require the pearl "ammo" from the Conjuror trainer again?
    Riverbear likes this.
  4. Riverbear Active Member

    It has been in my humble experience of /play 200+ days playing Templars that the components have been needed / used when casting Odyssey. I did not look to watch the pile tick down each and every time, yet I replenished the stacks from time to time. imho Odyssey has always needed rocks to rock :)

    Perhaps a Conji can address you further inquiry, I don't know them sugar from snow.

    Be Well :)
  5. Deafxint New Member

    Actually this occurs for me when I haven't manually set my recall point. Even though my call to home will return me to Qeynos by default, if I don't set my recall point manually to Qeynos Odyssey won't work and will return the error you are getting.

    Try setting your recall point and then doing it again?
  6. Beneeto Member

    I played a Templar both on Kaladim and recently on Live, have never had any problems casting Odyssey while having never bought a single stone. Like I said, they haven't been required in years.

    This might be it actually, for all of my characters I manually use the rebind spell to set their location in front of the broker/city merchants for faster unloading of junk.
  7. Boldac Member

    Looks like its the default recall point that is causing the issue.
    Beneeto likes this.
  8. Nata Member

    Yeah, this has been a problem since they changed Odyssey to no longer send the person back to their home 'temple'.

    The spell used to force the player cast on to return to 'church'. I thought that was fun flavor.

    But when they changed that in like LU9, they changed it to your custom bind point instead. If you haven't set a custom bind point, then the spell fails.
  9. Spectre Active Member


    Not a bug. Try binding somewhere first then should work. If you never bound it does not work.