Camera spinning upward

Discussion in 'Player Support' started by Klalorn, Jan 17, 2013.

  1. Klalorn New Member

    While playing occasionally when I left or right click and drag to rotate my camera it will send my camera view spinning violently upward and in different directions very fast. It is very, very jarring to have at and moment playing EQ2, a chance of having my camera randomly spaz out. Any help would be very much appreciated!
    Stonedreamer likes this.
  2. TSR-AlexS Customer Service

    What's the mouse sensitivity set to? Try to lower it in the settings to see if it makes a difference.
  3. Klalorn New Member

    Thank you for the help! I appreciate someone offering advice, but it does not help solve my problem. It seems while moving my camera with my mouse there is moments, inbetween my intended movement path, when (something) throws my camera into a tantrum. It will spin in circles very quickly and throw the camera straight up. It seems to interrupt my intedent camera movement, I will be mid-way between altering my camera angle and then suddenly my camera shoots in a totally different direction.

    I do not belive it is my mouse sensitivity because the camera problem happens randomly and is extremly faster than any rate I could move the mouse, and it only happns when rotating my camera. I've never had problems or lost control while moving my mouse around clicking abilities or any other action besides turning my camera.

    If i could try and use an example it's as if I had inteded to turn my head 90 degrees and before I could complete my intended arc someone would jerk my head upward mid movement.


    This problem seems to be random, I've done a bit of snooping to see if I can save everyone some time and trouble. Does anyone think a Wacom tablet could cause this trouble interfering with my mouse movement?
  4. TSR-AlexS Customer Service

    I would unplug the tablet just in case. Any extra peripherals should be disconnected for troubleshooting purposes. Check to make sure your drivers are up to date too. See if that makes a difference.
  5. Hampetheus New Member

    I'm having the same issue. If Eq2 is open my mouse behaves badly. Gonna put up a video when I get a chance to get on. If I hold a mouse button down the view slowly rotates and if I try to move the mouse it spins rapidly and usually ends up looking straight down. If eq is minimized or closed altogether the mouse works fine. I removed a controller I had recently put on my system as well as the software for it and it is still acting up.
  6. redwoodtreesprite Well-Known Member

    If it is just your character's point of view spinning in a circle, I believe it is a Windows glitch. Usually only fixable by logging completely out and in. I have also encountered this identical thing in LOTRO, as well as the keep moving forward bug. That one is usually fixed by pressing a different forward movement button.
  7. Karrane Well-Known Member

    If it happens again, try minimizing your game to the task bar, click on your desktop screen, and then bring the game back up. That might fix it. I know I occasionally run in weird circles and cant stop, camera goes wonky, etc. Dropping to task bar and clicking helps fix that every time it happens.

    GL!!
  8. Hampetheus New Member



    In the video here I am trying to slowly pan in a circle but the mouse keeps tugging to a straight down view. This happens 100% of the time now. I have removed all recently added hardware and software. If I take the game out to windowed mode and try to move the pointer outside the game window it just snaps back to the top right corner of the game screen. If I minimize the game it works fine and without EverQuest running the mouse works flawlessly.
  9. Tylia Well-Known Member

    I have this problem if I am holding down my mouse button to move my camera angle and I accidentally move my mouse pointer out of the game window to the task bar. (I do not play in full screen mode)
  10. Krishtah New Member

    This is now happening after a fresh install on my laptop, wasn't happing an hour ago! GRR!
  11. Krishtah New Member

  12. Krishtah New Member

    Some details about the problem: even when NOT holding left or right mouse button and moving the cursor around the screen the cursor refuses to go below the EverQuestII game window. It will go to the title bar of the window fine but will jump back up when I try to move further down to click on my taskbar. Is this a Windows problem?
  13. TSR-AlexS Customer Service

    What kind of mouse are you using? (just checking to see if there's a correlation between systems.)
  14. Rarrum Active Member

    I'm having a very similar problem. 90% of the time mouse camera controls (both left and right click are affected) work fine. But it occasionally "glitches" when I first click the button if the mouse is moving (even VERY slowly) when the mouse button is pressed. Even a few pixels of mouse movement can make the camera go flying in a random direction.

    I can reproduce this reliably, though the steps are a little weird: Move the mouse to one side of the screen, then start spam clicking the left mouse button while very slowly moving it to the other side of the screen. The camera should very slowly move in that direction since you're doing tiny little camera adjustments... but sometimes it just jerks crazily in that direction instead.

    I originally had this problem using a Microsoft Intellimouse Optical.. at first I blamed the mouse, so I bought a new Razor and even a microfiber mousepad.. but the problem persists. I'm running windows 7 64-bit.
  15. Rarrum Active Member

    I believe I found a fix: Uninstalling wacom tablet drivers.

    I never used to have the problem... it started not that long ago... and I just happened to remember temporarily using that tablet on my windows pc to try something around that same time. It hasn't been plugged in since then, but apparently just having the drivers installed caused this.
  16. TSR-AlexS Customer Service

    Thanks for the update Rarrum. I will still be watching this thread just in case others are still having this issue.
  17. solk New Member

    This is an issue on my wife's computer (running windows 8). My computer (windows 7) doesn't have the problem. The recreation method listed above does it on her machine... slowly slide mouse across the screen, any direction, clicking and un clicking either the right OR the left mouse buttons and sometimes it is abruptly looking straight down on her characters head or looking up at her horse's butt.
  18. Eileithia Active Member

    This is a common problem with windows 8.1 in many games, not just EQ2.. I don't think a reliable fix has been found yet. I wish it had, as I'm having the same issue.. every so often, one click of the mouse and i'm looking up my butt.. VERY annoying trying to heal, or grab a target when your camera just goes stupid on you.
    Edelphia likes this.
  19. The-Plethora Active Member

    This issue seems to be mainly confined to the new update of Windows 8.1. As more and more people are upgrading to this more people are getting this problem, although I don't believe it is solely confined to 8.1 as I have always had it to some degree on other OS although nowhere near as bad. With 8.1 I didn't want to play. Happy to report there is a fix though and it worked for me, it's located in this thread...

    https://forums.station.sony.com/eq2...s-with-windows-8-1.541186/page-2#post-5995743
    Seefar likes this.
  20. Juraviel Active Member

    I just got a brand new gaming pc that came with Windows 8.1 preinstalled and I am having these issues all of a sudden. It happened once in a blue moon on my old computer running Windows 7 but ever since I got the new pc with 8.1 it's been nearly unplayable due to the camera spinning and zooming randomly when using the mouse to move, click items and so forth.

    I've done some reading on the forums and tried two different fixes suggested - the registry edit and the program compatibility disable display scaling, but neither has worked so far.

    Has there been any update to the 8.1 issue and if so where might I get this information?

    Thank you,

    Jura

Share This Page