Fixed Internally BoZ OS Quest Bugged by VoV version

Discussion in 'Resolved' started by Disrption, Nov 29, 2023.

  1. Disrption Active Member

    As the title states, when I try to consume the new OS item I get a message stating I already have the VoV version.
    Elinea, Bellamorte, Twyla and 2 others like this.
  2. ShirQuickpaw Member

    I can confirm that after claiming the Overseer Quest for Ballads, that when trying to unpack the box, it fails with the error message that this account has already VoV adventure line activated.
    Twyla and Brailyn like this.
  3. Lateana Older than Dirt, Playing EQII since 2004

    Same here.
    Twyla and Brailyn like this.
  4. Brailyn Member

    Same here. My Mission Crate is also gone out of my bag as well.
    Twyla likes this.
  5. Games'nGhosts Active Member

    Same here! Mine is no longer in my bags!
    Twyla likes this.
  6. Twyla Well-Known Member

    I put mine in my personal bank with other things that can't be deleted if you already have them. I thought it was an odd message when I tried to unpack it since it clearly states it's for BoZ and the little quest icon is BoZ. Hopefully, it will still be in my bag when/if they fix this.
  7. ShirQuickpaw Member

    After rechecking this morning, I was still in possesion of the crate and it did work as expected at least from inside our guild hall. I got the new overseer quest granted
  8. Brailyn Member

    The crate is No Destroy, and like a crazy person, i keep looking in my Restore Tab, hoping that its gonna pop its silly little crate head in there, like OPE! I was just teasing! Here I am !!!....... But it has not shown up there.
  9. axxis32 Member

    All of a sudden, I could claim it... so I did. The mission appears and everything looks correct. Until you check the rewards!!!! The rewards are VoV things... you know, lvl 120 equipment, things with 140 resolve (or something along those lines). Silly little me thought that this quest would give 125-130 lvl gear and stuffs, my bad.
  10. Bellamorte Active Member

    Same here,
    I actually petitioned first then thought to come here and saw the thread.
  11. Alyndrys Well-Known Member

    Yesterday same thing happened for me. It worked for me today. I got a blue 30 min Ballads of Zimara quest.
  12. Xenn New Member

    Category: Content
    SubCategory: Other
    Severity: Affects gameplay
    Frequency: Always Happens

    Zone: Zimara Breadth
    Location: -877.96, 188.72, 356.72
    Character: Level 126 Ranger

    Summary: Ballads of Zimara Overseer Adventures
    Description: I claimed my paid for Ballads of Zimara Overseers Adventures pack from the claim window for it only to give me an error when trying to unpack it. It stated You already have Visions of Vetrovia Overseers quests when attempting to unpack. Then the item disappeared from my inventory. I do not have the Zimara quests in my Overseers window. Please help i paid for this feature.

    Twyla and Brailyn like this.
  13. Krafoogoo New Member

  14. Brailyn Member

    This is well written, this should be the official BUG submittal for me as well!
    Xenn likes this.
  15. Elinea Well-Known Member

    I'm glad to see this thread here, cause I was upset when my box poofed after trying to unpack it.
  16. Disrption Active Member

    OK, Day 2 of Expansion. My box poofed yesterday, no quest. Devs please work on this as I did pay for it and no box to unpack anymore and no quest. Our accounts are flagged for this, please have it auto-gifted to accounts that are flagged for it so we get another chance to enjoy content we paid for? Appreciate it!
  17. Xenn New Member

    I just received an in game notification I was granted Ballads of Zimara overseer quest, I hope everyone else did or will soon.
  18. axxis32 Member

    The rewards from these quest STILL gives out Vision of Vetrovia gear (lvl 120), NOT 125-130 gear, meaning we only get useless items from it.
  19. Twyla Well-Known Member

    Mine worked fine on both accounts today. Haven't claimed the reward from them yet so I can't confirm that part.
  20. Elinea Well-Known Member

    If I got a notification, it was buried amongst quest dialogue lol. But I checked my overseer window and the new mission is listed there now. Guess it just took a bit to catch up?