Cannot Reproduce Belliza's Greatshield of Honor does not give the option to add weapon essences

Discussion in 'Resolved' started by Hiburp, Jun 24, 2020.

  1. Hiburp Member

    Belliza's Greatshield of Honor does not give the option to add weapon essences.

    When I try to imbue weapon essences the secondary weapon is not an option. My primary and range are the only options available.

    I tried removing the adornments, unequip/equip and camping to self and still no go.
  2. Elysse Member

    I have the same problem on my healers and my SK. It does not allow you to imbue essences into the secondary item even though the item states that it will gain experience as essences are imbued.
  3. Einhander65 New Member

    The fabled overseer shield wont let me add weapon essences either. I got a got a second one and muted it for a mana but got last xpac essences instead so looks like the items are bugged
  4. Notagain New Member

    Same issue on my pally.
  5. Elysse Member

    I tried to add planar essences to Nadine's Spiked Towershield, Salvesetter's Buckler and Salvesetter's Bucker of Air, all of which state they should increase in power with essences and none of which gave me the option to do so.
    I tried to extract the essence from Nadine's Spiked Towershield and got the message that it is 'missing the required classification'. When I transmuted Nadine's spiked towershield it gave me an Infusion of the Planes which is clearly incorrect for a level 120 fabled item.
  6. Elysse Member

    This issue has still not been resolved. It appears a number of secondary items from the overseer quests lack the necessary flag to be imbued or have their essence extracted.
  7. Sigrdrifa EQ2 Wiki Author

  8. Ratalthor Developer

    We have not been able to reproduce this. We are able to level up the shield with essences. Is this still happening for anybody?

Share This Page