Battle of Nexus bugged?

Discussion in 'Bug Reports' started by Kebarb, Mar 23, 2020.

  1. Kebarb New Member

    Okay, this is weird. I just finished the Listless Spires solo instance. But there's a problem. I was doing the Battle of Nexus quest and when I realized I actually talked to the ghosts after speaking Apprentice Trevyr instead of before, I tried to reenter the instance after resetting it. Then there's no way I can enter Fordel Midst. Am I missing something out or is there a bug somewhere?

    Edit: I actually finished the instance. However, the update never kicked in and I got locked out (i.e. Trevyr couldn't be found at the Fordel Midst cave site.
  2. Semperfifofum Well-Known Member

    I'm not sure I understand. Is the quest asking you to speak to Trevyr at this time? What's the current objective?
  3. Kebarb New Member

    Maybe it's better for me to list down what happened step by step.

    1. I took the quest and entered the Listless Spires instance.
    2. I got the first update.
    3. This was where things messed up. I confused the update for actually talking to Trevyr. As a result, I started freeing the spirits.
    4. Then I got into the Old Witherby fight.
    5. I forgot which one came first after that, but it's one after the other. Namely, fighting the second named and talking to Trevyr.
    6. Went down the ramp and start taking down all the mobs before fighting the last named.
    7. Won the fight, exited the zone, and then I realised Trevyr wasn't there outside.
    8. Reset the instance in order to get the six ghosts update correctly done.
    9. Tried going back to the instance. Nothing popped up, let alone able to choose the instance.

    Edit: I tried zoning in and out of Aurelian Coast. The quest then went missing in my quest journal.
  4. Kebarb New Member

    Additional info.
    Character name: Aryden (lvl 120 Half-Elf Ranger)
    Server: Antonia Bayle
    Custom UI: EQ Map
  5. Semperfifofum Well-Known Member

    The quest helper has an annoying habit of resetting in an unhelpful way when you zone in or out of an instance. It used to work properly, but now it's not so good. Also the journal has a checkmark at the bottom for "hidden quests" which might help.

    If you reset the instance then you have to speak to Trevyr again by the crystal. I guess, not sure.

    If you reset the instance and then entered...and it was empty, then I don't know how to fix that, sounds like a bug.

    Try this. Use the chat box, and type /df (enter) Under persistent instances tab, choose "reset all" if you see anything there. Try entering the solo instance again. (Still empty?)
    Kebarb and Breanna like this.
  6. Kebarb New Member


    Reset all greyed out. Remembered I was able to do that this morning, but had to rush off soon. So didn't try entering. Gonna try again after server reset.
  7. Kebarb New Member

    Okay. Still can't go in. Can only wait for the devs to fix this. :(
  8. Kebarb New Member

    Okay, tried doing a reset per Semperfifofum suggested just now. I ran Sambata Village last night to allow this to happen. Did /df command and reset. Still cannot enter. :(
  9. Semperfifofum Well-Known Member

    :( Not sure there's any other road then but /petition
  10. Kebarb New Member

    Okay, I now feel like a moron here. Apparently, what happened was that the quest got auto-deleted. How I found that out? Thankfully, I procrastinated on the Splinter of the Maiden's Eye quest. Al'Kabor was there waiting for me to retake it.

    This post can now be taken down. Apologies for the hullabaloo.

    P.S: I'm now keeping my fingers crossed that one of the devs will see this final post and inform his/her colleagues at the petition department about this.

    Add P.S: Again, my apologies to those whose time I've wasted especially Semperfifofum.

Share This Page