Ascension of Tol'Ren Gem won't socket

Discussion in 'Tips, Tricks, FAQs, and New Player Discussion' started by EQ_Jack, Oct 11, 2019.

  1. EQ_Jack Active Member

    So I have a bunch of 'Ascension of Tol'Ren' White Adorn, Level 100 Gems.

    I try to use them (right click use) and it won't show gear that can take them.

    For example:

    I have a level 100 Chest piece with an available white adorn Socket read to be used. but its not recognized by the "Apply Ascension of Tol'Ren to' dialog.

    I've tried taking the chest piece off. I've tried drag and drop. nothing works.

    Why can't I use these?
  2. Cyrrena Well-Known Member

    It doesn't say what piece it can be applied to? They can only be applied to specific pieces. So I would try something else like a piece of jewelry or a charm or a weapon.
  3. EQ_Jack Active Member

    Thank you for sharing.

    I figured it out. there is a small web page like link at the bottom of the dialog that pops up. By clicking that, the dialog will then list the rest of gear that can be upgraded.

Share This Page