An obulus frontier seedling

Discussion in 'Items and Equipment' started by Arclite, Dec 7, 2017 at 7:33 AM.

  1. Arclite Active Member

    So I did all the quests a while back to get the seedling. I doubled checked my quest journal and the last quest completed was "The gardening goblin".

    After PoP launch, i wanted to benefit from the rare harvesting and went inside my house to look for the seedling only to find it was not there. I checked my house items list and it was not there. So I petitioned for it and thankfully a very helpful GM restored the item in my inventory citing that I might have lost it somewhere and If i can get it back from the overflowing inventory without an error saying "lore-equip" then it means i do not have it.

    So i got the seedling in my house yesterday (without an error). Still not 24 hours yet but i do not see the goblin. Will it appear after the 24 hour period or did i mess this up in some way?

    THanks
  2. Febrith Well-Known Member

    He will show up - it should be after 24 hours - click on it and he'll then give you the first little mission - go and get soil or some such, I can't remember now as it was a while ago. You'll get a quest each day after that for I think 3-4 days before the plant starts producing for you.
  3. Porrum Member

    You might need to re-position it. The goblin appears near the plant, so if you've set the plant next to a wall or other object, he might be inside that wall.
    Shmogre likes this.
  4. Arclite Active Member

  5. Arclite Active Member

    Right. As i suspected. There might be something wrong. Over 30 hours now and still no goblin. Went back to twark to see may be Growf will give me the quest again.

    Not sure what to do next.

    Any pointers?

Share This Page