Confirmed Ambient Occlusion on Mouse-Over

Discussion in 'Bug Reports' started by Sturmlocke, Aug 11, 2021.

  1. Sturmlocke Linux enthusiast playing EQ2 via Proton.

    Hello there,

    I just wanted to add my vote for a couple of issues that have been plaguing the world of Norrath for some time now.
    • Issue #1 is best described here (broken shadows and more)
    • Issue #2 is best described here (broken water refraction and flickering reflections in the water)
    EQ2 looks so much more beautiful with gpu shadows and it used to look even better a couple of years back with water refraction working. EQ2 has some of the best, if not the best, water dungeons that an mmo can offer. I love water dungeons and it's a shame the beautiful water rendering has been broken for so long now. Not sure when it went bad tbh, might have been after the removal of shaders 3.0, but I have been missing it ever since.

    I have been absent from the world of Norrath for some time now, just came back last year and subbed for an entire year immediately. This time around, I decided to start from scratch in order to let nostalgia hit me. Is Mepps still around? If so, @Mepps: Do you have some more in-depth / technical knowhow surrounding these two bugs? What would it take to fix it?

    I'll continue to resub for many years, especially after becoming a father myself now. My children are going to grow up playing EQ2 with me and I'd love to see EQ2 shine like it did when I tried playing this beautiful gem with my Radeon 8500 and Geforce 3 many eons ago. This game was an entire decade ahead of the competition and it still holds a special place in my gamer heart.

    Thank you, stay healthy and cheers,
  2. Sturmlocke Linux enthusiast playing EQ2 via Proton.

    Uwkete-of-Crushbone and Shalyn90 like this.
  3. Sturmlocke Linux enthusiast playing EQ2 via Proton.

    Update: Just wanted to let you guys know that I reached out to Josh from Github in order to troubleshoot these shader issues. Josh already fixed a nasty Nvidia bug for us Linux dxvk users last time around, which means that he might have some understanding of this type of bug. I sent him a few DX9 traces of EQ2 and he's taking a look at them. That being said, I also have another question. Everyone probably already knows how much I like my water in EQ2 :) I couldn't help but notice that a few areas in the game, where water touches the landmass, looks pretty simple, see here:


    In addition, beautiful water and wave rendering:



    Three questions:
    1. After feeling and seeing the wind and salty water breeze on this ship again, out of sheer curiosity, is the EQ2 engine capable of creating more enhanced procedural water waves, like a simpler version of the ones seen in Black Desert, for example?
    2. Would it be a huge undertaking to add a little bit of foam, floating plant life or something else to cover up the water lines when water gets in touch with the land?
    3. Is it possible to add similar waves, like the ones you see above, to certain / old zones in the game, without breaking a leg? For example, the beach near the starting zone in the Greater Faydark looks beautiful, but it would look even better with a few stronger or more advanced waves hitting the beach
    Not expecting any of this to get done, just curious.

    Uwkete-of-Crushbone likes this.
  4. Maergoth Well-Known Member

    Category: Art
    SubCategory: Other art problem
    Severity: Cosmetic
    Frequency: Always Happens

    Zone: Qeynos Province District (And More)
    Location: 883.81, -25.43, 30.12
    Character: Level 50 Paladin

    Summary: Ambient Occlusion only works when targeted or moused on something
    Description: Literally as described in the summary. With Ambient Occlusion turned on, it only works in a lot of situations when I have my mouse overtop of an interactive object, or a mob, or have something targeted.

    I can provide evidence from my stream, and it happens indoors and outdoors. Also a weird slight display stretching effect when toggling it on or off.

    EDIT: Noticed some other weirdness. Turns out I had something wrong with a UI file that was causing this. Weird, but seems to be resolved.

    So a fresh install seemingly fixed it, until I restarted my game. And then it returned to being bugged again.
    Skywind42, Taled, Arandar and 2 others like this.
  5. Maergoth Well-Known Member

  6. Maergoth Well-Known Member

    Not to bump, but I wanted to add that *all* post processing effects disable unless you have a target or mouse-over. Including Sun Shafts.

    Aethos and Twyla like this.
  7. Maergoth Well-Known Member

    Adding some more context. It seems to be some weird interaction with GPU shadows. Since AO is tied to GPU shadows in some way, and so are these artifacts. And they show up in the same situation that AO does: when I target something.


    For context, I have a fresh EQ2 install (including ini files) running on RTX 3090 with freshly reinstalled graphics drivers, no OC and no tweaks to my nvidia control panel settings.
    Benj, Beee, Sturmlocke and 1 other person like this.
  8. Maergoth Well-Known Member

    More information:

    It seems to be a universal problem with post-processing effects being tied to UI elements showing (ie a target ring, or a mob's highlight when you mouse over it) Whatever code hides those unless you're targeting them *is also cancelling all post-processing effects*

    Looks like some off-screen optimization is also affecting things like ambient occlusion and sunshafts

    If there is a desire to investigate further I can keep going, but if this is something that doesn't matter, would like to know.

    Sturmlocke and Twyla like this.
  9. Ratalthor Developer

    Can you PM me your game settings, the file called: "eq2_recent.ini"
    You can paste it in a message to me.
    Aterskia, Sturmlocke and Twyla like this.
  10. Maergoth Well-Known Member

    Did some more investigating after Ratalthor responded, so I could deliver something useful.

    Turns out, it's in-game MSAA. Disable MSAA and this problem (and all associated ones described in this thread) disappear. Not sure what the compatibility issue is there, but I'm going to just force AA through my NVCPL for now until the bug is fixed, if it gets fixed.
    Sturmlocke and Twyla like this.
  11. Ratalthor Developer

    I merged the thread "Ambient Occlusion on Mouse-Over" with the "Shadow and Water Refraction Glitches" thread because we believe them to be the same issue.
  12. Maergoth Well-Known Member

    They may have a similar solution, but the "shadow" glitches and missing water ripples as mentioned in the thread are very much *not* resolved by disabling in-game antialiasing.

    Additionally, I'm still getting the occasional texture artifact when using GPU shadows (my prismatic longsword sometimes becomes a large square plane until I toggle them on and off, for example)

    Otherwise, thanks for taking note. I'm sure a fix is distant but at least it's documented.
    Sturmlocke and Twyla like this.
  13. vexen Member

    I get those same triangles when using shaders but they go through my whole body
    Sturmlocke and Twyla like this.
  14. Sturmlocke Linux enthusiast playing EQ2 via Proton.

    Wow, I wasn't notified about all the feedback in here. Just got a hint and decided to check, so here I am.

    Can confirm everything that was posted above by the others.

    See here for a few more screenshots that I took during the 64b beta:

    Josh from Github hasn't had the time to analyse my dx9 traces yet, he's super busy working on the Steam Deck, Proton and DXVK, so I'm glad that we're getting some attention on this from our devs.

    Will provide my eq2 ini later and can also provide more logs, such as dx9 traces or Proton logs if it helps troubleshoot and fix this. Fixing this would allow me to progress with my EQ2 relaxation YT series easier as it's been somewhat of a challenge to find the right viewpoint or angle in order to avoid the water and shadow issues when filming in old zones.
    Twyla likes this.
  15. Sturmlocke Linux enthusiast playing EQ2 via Proton.

    Twyla likes this.
  16. Aterskia Active Member

    me'es seems tio hav SAM issue! sum ting 'bout "Gpu shadows" :confused:
    Sturmlocke 'gested i share awlsew.
    mine's happin in Anchor of Bazzul zone. noticed in other Void-type zones too.

    hav OptiPlex 790, i7 CPU, 16GB(Kubuntu2204) ram, and Radeon RX 6400; on Steam w/ Proton7.0-3



    then, withOUT mouseover/target, weird sky.

    and WITH mouseover/target (on PC or NPC) normal sky.

    @Ratalthor: should I PM you eqclient.ini too?
    Twyla and Sturmlocke like this.
  17. Aterskia Active Member

    @Ratalthor: shud I PM yu's eqclient.ini too?
    wuds be'es usefuls, ya ya?
  18. Sturmlocke Linux enthusiast playing EQ2 via Proton.

    Sent you my ini @Ratalthor

    Let us know if you need anything else and good luck troubleshooting this one
  19. Ratalthor Developer

    We will be addressing this issue in the upcoming expansion.
    Twyla, Breanna and Sturmlocke like this.
  20. Sturmlocke Linux enthusiast playing EQ2 via Proton.



    Ratalthor, we literally just had a discussion about this the other day, and here you come along, confirming that you'll be fixing this. I knew it. I knew you guys could do it. My dear engineer, you guys rock! Thank you!

    Ok, just for that, I am going to be putting in a bit of extra effort into my upcoming Youtube videos for dcuo, eq2 and swg. I have an idea, will share more once I have it done.

    Again, thank you SO much for rising up to this challenge and performing your magics.

    This might not mean a lot to some folks, but to me and many others, it does in fact mean a lot and shows that a positive trend is upon us. Keep up the great work.
    Twyla and Breanna like this.