Fixed Internally 'A More Aggressive Method' Boar doesn't update

Discussion in 'Resolved' started by Bugejoah, Mar 16, 2022.

  1. Bugejoah New Member

    Category: Content
    SubCategory: Quest Related
    Severity: Affects gameplay
    Frequency: Always Happens

    Zone: Darklight Wood
    Location: 265.60, -19.96, 2.91
    Character: Level 10 Shadowknight

    Summary: 'A More Aggressive Method' fails to update
    Description: I am doing the quest 'A More Aggressive Method' and the quest fails to update when the boardfiend explodes. I have tried grabbing a new boarfiend multiple times, and even deleting and restarting the quest, but to no avail.
    Carynn, Buggabug and Twyla like this.
  2. Buggabug Active Member

    20 attempts, tried deleting, relogging, no merc, no pet, no mount. boarfiend explodes but quest does not update. on Kael Drakkel server.
    Twyla likes this.
  3. Ramblon Member

    Yes. I was also having this problem with this quest.
    Twyla likes this.
  4. Taled Well-Known Member

    Per the wiki ( for this quest, there are a *number* of known issues that can cause this not to update properly - Are you making sure to kill the mushrooms one by one and let the boarfiend eat the shroomlings from individual fungusmen before killing another?
    Twyla likes this.
  5. Kachorto New Member

    still bugged for me too...and I killed the shrooms slow one at a time
    Twyla likes this.
  6. Kachorto New Member

    on Varsoon server player name is Weplaya
  7. Chrol Developer

    Tested this a bit and it always updated. However, taking a quick look at some of the entities involved in the quest, I see that the boar will only recognize you for approximately 168 minutes from the moment you acquire it. So, just don't go afk for any length of time before heading out for some shroomlings.

    Also, I don't know why this quest isn't called "A Boar Aggressive Method." That's the real bug!
    Bludd, Twyla, Taled and 1 other person like this.
  8. Taled Well-Known Member

    I knew there was a reason I liked you..
  9. Bludd Well-Known Member

    Taled likes this.
  10. Buggabug Active Member

    Still having this issue on Kael as well, nothing I do fixes it. And I'm taking the boarfiend directly to the mushrooms no scenic route involved, not even a coffee run or bathroom break.
  11. Chrol Developer

    Can you reply or PM me your character name, please?
  12. Chrol Developer

    Finally was able to reproduce the bug! I pushed the fix on live servers so it should update for everyone on the first attempt. A more permanent fix will go in with the next update.
    Jinksie, Twyla and Dude like this.
  13. Dude Well-Known Member

    The more important question is ... did you fix the name of the quest? :D
    Taled likes this.
  14. Skoozer New Member

    I'm just here to report that today (6/4/2022)on Varsoon server I am doing this quest and have tried three times so far (going on my 4th attempt) and the quest has not updated. So, it has not updated for me on the first attempt. :(
    EDIT: I gave up after the 7th failed attempt at getting this quest to update.
  15. Cherna New Member

    Yeah still having the same issue on Varsoon. I've now had six or seven boars explode, no quest update. Tried getting a new boar, no update. Tried deleting the quest and doing it all over, no update.
  16. Chrol Developer

    Strange. I just tested this on Varsoon and it's working. I even forced the bug to take affect which was preventing the quest from updating previously, as the fix that is in now ignores that and grants the update.

    There is a step after getting the boar that requires you to speak to Vornlin before you go off getting shroomlings with your boarfiend. Are you doing that first?
  17. Skoozer New Member

    Just tried it again and still no update. The boarfiend explodes but no update.
    And, yes, I did speak to Vornlin after obtaining the boarfiend. Everything is ticked off (in the journal) up until it tells me to take the boarfiend to the bog.
  18. Cherna New Member

    Yes, over and over. Same as Skoozer above, everything ticked off, I go straight to the bog, he eats the shoomlings and nothing updates.
  19. Chrol Developer

    Can either of you, if still bugged, send me a PM with your character name, please?
  20. Dude Well-Known Member

    Just finished it with no problems on Varsoon at 5:51pm eastern time.