Fixed Internally Unable to leave/assign/loot duplicate item in advanced loot.

Discussion in 'Resolved' started by Lemerian, Nov 17, 2021.

  1. Lemerian Elder

    Since the patch, I've run into an issue where, when multiple of the same item drops, I cannot do anything with the second item -- I can't leave it on corpse, I can't assign it to anyone, I can't loot it myself).

    The most recent example is below:


    I set both items to "Leave on Corpse" using the button (ie, I didn't do each individually) but only one was actually shown as being left. The other one stayed in the advanced loot window and I could not do any actions on it. I was six boxing at the time and confirmed in the other windows that they still saw the item in window.

    At this time, I evacuated and when I loaded back in, the advanced loot window was no longer up (even though when I evacuated, it was up with the Glowing Orb still in it). I went back to the corpse and tried to loot it but nothing showed up (just an empty advanced loot window). All other items were looted, so it should have brought up the normal corpse loot window with the two Glowing Orb of Luclinite in it but it did not.

    So far, of the few times since the patch I've gotten duplicate items on a single corpse, this behavior has been the same every time.

    Edit: FWIW, after the 15 minute timer expired, I was able to access the corpse and both orbs were on there. So, no loot will be lost it seems, but it's an extreme inconvenience.
  2. niente Developer

    The advanced loot window never really supported multiple copies of the same item. The original code said "hey, this item has this ID, let's stack them together!" regardless if the item actually stacks or not. Beyond that, it is quite a nightmare to work with.
  3. Lemerian Elder

    Does that mean this is confirmed or not going to be fixed? Or more of a "Not this piece of code again!" sentiment :)

    It was previously able to do the above actions without issue so I'm thinking something must have changed.
  4. Dailor Augur

    It isn't ideal, but we were able to work around by swapping master looter to assign the duplicate.
    Joules_Bianchi likes this.
  5. Lemerian Elder

    Thanks for that tip, I didn't even think of trying that. Like you said, not ideal, but at least it's a workaround.
  6. Arienya1978 New Member

    I just ran across this issue for the first time yesterday as well.
  7. Cragzop Cranky Wizard

    But it's worked fine until this last patch. Someone changed something.

    And I have experienced this as well since the patch.

    Just now, killed King Tormax and he had two White Dragon Scale Sashes. Set all to Leave On Corpse, but one belt was left. Can't do anything with it. Changing looter in group did not help.

    The only other thing to add is that if I hit the Leave On Corpse while the specific item window is up, I get the message:
    You cannot perform that action right now. Please try again in a moment.
    Syndr and Herf like this.
  8. Jumbur Improved Familiar

    This bug slowed our raid down considerably, today. :(
    Xanadas likes this.
  9. Mulerien Elder

    ^ same with us, after waiting the 15 minutes for four events and trying to cycle looters and such, we found if someone drops raid, opens the chest, leaves it all on corpse, then zones out, it will all get left on the corpse.
  10. Thunderkiks Augur

    Did the Plane of Smoke trial Speakers Amphitheater tonight and had the issue with the sigils you are supposed to loot to go up too the platforms. Any extras on the 4 mobs on platforms I couldn't do anything with their 2nd drop. They all drop 2 items. I could loot the first one but the second one could not be looted by an other member in group and couldn't be left on the corpse either. Luckily I only had 2 characters in there so wasn't a big issue for me but if anyone has a full group they wont be able to get all up to the boss fight at the end. Needs to be fixed though and didn't happen before the lore item change.
    Syndr likes this.
  11. Penelo New Member

    We were doing MPG trials on Saturday. Raid tool would bug out on the multiple runes that would drop. After giving out the first one I would pass master looter to another person who could give out the second one and assign the other loot drops as well.

    When doing this one time the loot window further bugged and some items stayed in my personal loot window after handing off the raid tool. It only happened the one time. Note this "extra" ring didn't actually exist, was not on the corpse which went away after all the other items were looted. Only then did it disappear out of my advloot.

  12. Penelo New Member

    On a separate instance we ran Hollows DZ for signets. At the end the mob drops 6 signets. You can only assign/leave one. Then when you pass master looter the new person can assign/leave one. After that the remaining 4 pieces bug out and you can't assign/leave them even if you pass master looter to someone else or back to yourself.

    After you wait the 15 minutes for the corpse to unlock you can loot them off the corpse. We did not try re-logging or anything else.
  13. Windance Augur

    We just had another prime time tantor chest get bugged ... 15 min x 50+ people sitting around waiting for the chest to unlock.
  14. Fufinski New Member

    This bug is really messed up.

    After assigning a few drops in the raid window (could be 1 could be 4, seems random) of the same item, the loot window completely bugs out. Putting multiple items on free grab occasionally works for one or two then just bugs out, cant assign, cant leave on corpse. Switching loot master occasionally lets you assign more items, but then bugs out again. Basically have to wait for corpse rot. I do hope this will atleast be fixed before SoD drops as I can see that being a right pita.
    Conq likes this.
  15. Conq Augur

    This is still an issue. Tunare server raiding with my guild M+T, then again raiding with an open raid force on Fri+Sat - all duplicate spells are unassignable and only lootable once the 15-minute (chest) corpse timer is up. Ores and armor drop duplicates did not act this way, just the spells. I see "Confimed" in the title to this thread, does this mean this will be fixed one day? Soon?
    RustyOfOz likes this.
  16. RustyOfOz Journeyman

    Good report Conq. This is painful for the entire raid force.
    If anyone else has this issue, please upvote by clicking Like on the original post.
  17. Nags69 New Member

    Same issue yesterdays raid - as people already mentioned - you can change the loot master and that helps for the next 1-2 items - then completely bugs out.
  18. Drakang Augur

    Raid leader reset Advanced loot options to not use Advanced loot. Then in Raid Options change loot to everyone. All items left in chest. Can then do loot old school by linking the chest contents and having people loot from the chest. Royal pain but works till they fix it.
  19. Windance Augur

    Any idea if a fix is planned? Raid leader forgot to setup things and we sat around for 10+ min just waiting for stuff to unlock.
  20. Fanelien New Member

    Still a real pain in the , any chance of a fix in the next patch?