Unable to interact with Vendor NPCs

Discussion in 'Player Support' started by Skvoid, Feb 9, 2017.

  1. Skvoid Elder

    I have this weird issue only on my Iksar Sk account. I can target NPCs and hail, but right clicking to sell to them is almost impossible, once in 20 30 clicks I will hit the right spot and manage to get a vendor window up. It's like the click window to interact has shrunk for this character to some tiny tiny point? All my other accounts work no issue whatsoever.
    Has anyone else experienced this?
  2. Tvarian Augur

    Experiencing any lag issues?

    Do you have a pet, familiar or merc standing between you and the NPC, causing your click to kinda hit them instead? I think there is a click through option somewhere.

    I have not had this problem, so just thinking of some simple things that may be tying you up.
  3. Skvoid Elder

    I checked all the click through options they seem to be the same as my other accounts. No familiar or mercs in the way either. It is a odd problem for sure and I have never experienced it before on any other characters.
  4. Skvoid Elder

    Ok so after infuriating me still and trying things like removing all my ormentation armour thinking it might be a issue with that I accidently discovered that clicking a few feet below where the NPC vendor is standing lets me interact with them all the time, it's like the vendor interaction box has moved below the vendor? I made a youtube video which is linked here for you to observe.
  5. Gidono https://everquest.allakhazam.com

    I just went to the NPC you have in your video and right click on his upper body and the vendor window popped up just fine. You might try looking for some updated drivers for your mouse.
  6. Skvoid Elder

    I run three accounts at once and only that character has any issue clicking on vendors, so it's not a mouse issue, as they are all running on same PC.
  7. CatsPaws No response to your post cause your on ignore

    Just curious does it happen no matter if your running that account all by itself or all three at once or in any order? Since it is just the one account I would suspect a burp in your char ini files for that char. You could delete them and let them rebuild. You will want to make a copy first since that will wipe out a lot of your settings but should also be easy to copy from the other ui from options.
  8. CatsPaws No response to your post cause your on ignore

    Oh wait, validate files first on that char - that is the easy way.
  9. Skvoid Elder

    How do you validate files on that character? I run all 3 EQ accounts from the same install folder, so they all use the same EQ files only the character UIs etc are different etc.
  10. CatsPaws No response to your post cause your on ignore

    AH, I run multiple icons on desktop. Sometimes helps with troubleshooting. Anyway, when you log into that char name on the screen right before you hit play there will be a cog (advanced tools) in lower left corner. Hit that and then choose to validate.
  11. Kruler Journeyman

    I did have a weird bug in EQ1 awhile ago if I had Nvidia settings set to "Use My Preference" instead of "Let application decide". Had all sorts of issues such as NPC click box was below their knees and certain text wont display right, long story short, in control panel Nvidia always have it on "LET 3D Application decide" with EQ1
  12. Xikteny Augur

    I have this exact issue, as well. I find that using the Use Centerscreen (should be 'u' by default) keybind is more reliable. Even though I play in third person most of the time, which isn't optimal for using this keybind, it still does work with proper positioning/camera placement.

    This issue has been affecting me for a while now, but not, like, that long. Right-clicking used to work fine. o_O

    ETA: one thing to note is that I have absolutely no problems with left-clicking (ie targetting) NPCs.
  13. Lion of God Elder

    This thread popped up first on google when I searched it, so I'll post the solution I found here. . .

    I merely logged out and logged back in and I was able to right click merchants again.