Test Update 9/12/2023 - New Bugs Only

Discussion in 'Test Update Notes and Bug Roundup' started by EQ Dev, Sep 12, 2023.

Thread Status:
Not open for further replies.
  1. Quick New Member

    OMG! This worked! All my buttons and mostly window placement is correct. I just need to increase the scaling. Thank you!

    So very disappointed in DBG's support here... :mad:
  2. Bernel Augur

    Those of you with failing eqclient.ini files should save the bad ones so the devs can look at it if necessary. Before you delete it and get a new one, make a copy.
    Scila and Wulfhere like this.
  3. Sdoofbuc Augur

    Everything is blue on two different computers for me. One of them is a fresh clean install of Win 11 and EQ.

    Where do I get the latest Visual C++ redistribution package? Any which one do I need? I see 2005, 2008, 2010, 2012, 2013, 2015, 2017, 2019 and 2022. Both x86 and x64 versions of each.
  4. aniam Journeyman

    To get rid of blue tint uncheck use new Ui under display in options and restart game
  5. MyShadower All-natural Intelligence

    From a dev on page 2.

    You definitely need x64 because EQ switched over to 64 bit and they say the latest which should cover anything needing older versions. However, issues can arise between installs that need separate versions. Installing the latest "should" not be an issue.
    Skuz likes this.
  6. Sdoofbuc Augur

    Ohhh... I already did that.

    I posted sever times in this thread that I was getting an error Failed to load the graphics DLL!.

    I installed vc_redist.x64.exe and that fixed it and can login and play now. Two different computers. Both running Windows 11. One of the computers has a fresh clean install of Windows and EQ.

    That did nothing for the blue. The whole game is very blue. Trying to figure out how to fix that.
  7. Skuz I am become Wrath, the Destroyer of Worlds.

    I think that's not been fixed by players so far, its an issue with the new ui.
  8. Sdoofbuc Augur

    Great, that makes me feel a lot better.

    If it's only me. Then it's my problem to fix. If it's everyone, then it's DBG's problem to fix.
    Skuz likes this.
  9. X1234 Journeyman

    Okay, so what was the fix for crashing upon zoning? I have the new UI currently switched off, but have been switching between off/on since the update.
    Note; I have also been using a custom UI.
    PoK and FM are the two zones I’ve spent the most time in recently, and both zones have been fine with loading my toons etc.
    but as soon as I head to Eastern Wastes, any character I’m on crashes.
    I’ve hit ‘reset UI’ just in case it was a UI type bug, but that hasn’t solved the problem. And yes, I’m aware I’ll most likely have to manually set up my UI again.
  10. Thanalis New Member

    I had the issue of crashing when zoning to the Plane of Tranquility. I renamed the eqclient.ini to start with a fresh eqclient.ini and was able to load into the zone without crashing. I opened the Display settings and changing Sky Type from Simple to Complex caused an immediate crash.

    I tried to reload back in to that character and would crash during loading. I edited the new eqclient.ini and changed Sky=2 to Sky=1 and was able to load back in to the Plane of Tranquility.

    After loading in, I messed around with the various display settings except for the Sky Type and was able to change everything else with no crashes.

    An interesting note, Sky Type: Complex worked fine in Plane of Knowledge.
    Skuz and Cairbrae like this.
  11. Captain Video Augur

    Aside from the blue tint, I have a significant problem I haven't seen anyone else mention.

    My primary monitor has a native resolution of 4K (3840x2160), and I have several applications which depend on my native desktop resolution matching that. I can't play EQ at that resolution because the text is too small (known issue which a new UI is supposed to address...). So I set my fullscreen resolution in-game to 2560x1440, and everything is fine. Well except for one thing. Windows 10/11 will do unwanted things with high DPI resolution apps if they don't match the desktop's native resolution. But, there is a fix for that: In the app's properties (for us this is eqgame.exe), under the Compatibility tab, there is a button labelled "Change high DPI settings", and in that sub-menu there is a checkbox labelled "High DPI scaling override" = "Application". Checking that box allows EQ to run as expected in fullscreen mode at 2560x1440 without the need to change any system settings, specifically native desktop resolution.

    The problem is, this doesn't work in the DX11 EQ app. It appears to be ignoring the checkbox, and tries to scale things based on the system's native resolution. I can make it work by changing the desktop to 2560x1440, but for me this breaks other apps and I don't want to keep having to switch back and forth ad infinitum just for the sake of EQ. I'm fairly sure it's a simple DX11 call to replace the DX9 call for the same purpose in the existing Live client.

    A >lot< of people will complain about this if it isn't changed before the whole thing gets pushed to Live.
    Metanis and Skuz like this.
  12. Cairbrae Developer

    I've entered Stillmoon Temple successfully with Simple Sky Type. However, Complex Sky Type does trigger a crash.

    Setting Options, Display, Sky Type to Simple (or None) can be a workaround for some zone crashes.
    Svann2, Metanis, Skuz and 2 others like this.
  13. Angahran Augur

    Also do a comparison, see if anyone can narrow down what entry in the 'bad' eqclient.ini is causing the crash?
  14. Kompacte_of_Test Journeyman

  15. Revolio New Member

    This was a fun bug! We in the Iron Bank of Bravos just attempted the Raid Expedition: Dispelling the Shadows in Plane of Shadow https://everquest.allakhazam.com/db/quest.html?quest=6840

    During the event, about half of our raid force crashed to desktop. Perhaps something with a blue particle effect? Ultimately we could not complete the event because it caused too much chaos.

    Additionally, we attempted the Zlandicar raid in CoV and the restless ice textures failed to load for, I think, all attendees. We couldn't see the ramp where we were supposed to be fighting, instead all the player characters were hovering high in the air when standing on any of those textures.

    Hope this helps!
    Cairbrae and Skuz like this.
  16. Skuz I am become Wrath, the Destroyer of Worlds.

    So in summary, so far EQ DX11 crashing fixes are:

    1. Download & Install new C++ Runtimes - https://aka.ms/vs/17/release/vc_redist.x64.exe
    2. Rename eqclient.ini and allow game to patch in a new copy
    3. Change sky from complex to simple.
    Fanra, Barton and Metanis like this.
  17. testbot22 New Member

    I run 3 boxes - Win 11/Win 10/Win 7. Runnable except for Win 7 box. Prior to patch Win 7 box was fine except for the Inventory window having some odd texturing.

    Win 11/Win 10 boxes have ~ approx. 50% of corpses killed get stuck in the upright position instead of collapsing to the ground.properly. Seems to be consistent across both boxes in respect to what corpses get stuck upright.and which corpses fall to the ground.

    Win 7 box. - EQ crashes shortly after pressing play and refuses to start. Very similar to what other users have posted. Win 7x64, Service Pack 1, DX 11. Have tried updating the DX and the Visual c++ distributables. Below is what I see in the DBG.txt file. Fatal Error #630 mean anything?

    [Sun Sep 17 07:21:17 2023]00000:Starting EverQuest (Built Sep 12 2023 12:43:46)
    [Sun Sep 17 07:21:17 2023]00001:EverQuest Configuration Type: RELEASE_NON_AVATAR
    [Sun Sep 17 07:21:17 2023]00002:Timezone: UTC-8h00m
    [Sun Sep 17 07:21:17 2023]00003:Loading graphics DLL.
    [Sun Sep 17 07:21:18 2023]00004:Graphics DLL Configuration Type: GraphicsDLL9
    [Sun Sep 17 07:21:18 2023]00005:Graphics DLL Version 2.00.12345
    [Sun Sep 17 07:21:18 2023]00006:Initializing timers.
    [Sun Sep 17 07:21:19 2023]00007:Checking critical files.
    [Sun Sep 17 07:21:19 2023]00008:Initializing WinSock.
    [Sun Sep 17 07:21:19 2023]00009:Enumerating 3D devices.
    [Sun Sep 17 07:21:19 2023]00000:Found adapter #0 - AMD Radeon HD 6800 Series (

    [Sun Sep 17 07:21:19 2023]00001:Adapter #0 - AMD Radeon HD 6800 Series :

    [Sun Sep 17 07:21:19 2023]00002:32Bit = 1, D32 = 0, D24 = 0, D16 = 0

    [Sun Sep 17 07:21:19 2023]00003:16Bit(565) = 1, D32 = 0, D24 = 0, D16 = 0

    [Sun Sep 17 07:21:19 2023]00004:16Bit(1555) = 0, D32 = 0, D24 = 0, D16 = 0

    [Sun Sep 17 07:21:19 2023]00010:Creating window.
    [Sun Sep 17 07:21:19 2023]00011:Checking display driver version.
    [Sun Sep 17 07:21:20 2023]00012:Activating window.
    [Sun Sep 17 07:21:20 2023]00005:CRender::InitDevice: Using 32bit mode.

    [Sun Sep 17 07:21:20 2023]00006:CRender::InitDevice: Using vsync 0.

    [Sun Sep 17 07:21:20 2023]00007:CRender::InitDevice: Using 24bit depth buffer with 8 bit stencil.

    [Sun Sep 17 07:21:20 2023]00008:CRender::InitDevice: HardwareTnL Enabled.
    [Sun Sep 17 07:21:20 2023]00009:Using hardware vertex shaders.

    [Sun Sep 17 07:21:20 2023]00010:Initializing render system.
    [Sun Sep 17 07:21:20 2023]00011:Trilinear Mipmapping available.

    [Sun Sep 17 07:21:20 2023]00012:Vertex Shader Version: 5.0

    [Sun Sep 17 07:21:20 2023]00013:pixel Shader Version: 5.0

    [Sun Sep 17 07:21:20 2023]00014:Initializing engine internals.
    [Sun Sep 17 07:21:20 2023]00015:CRender::InitDevice completed successfully.

    [Sun Sep 17 07:21:20 2023]00000:EQ Window Width: 640 Height: 480
    [Sun Sep 17 07:21:21 2023]00013:Dump generation request succeeded: C:\Crash\7ad26dce-1196-4f47-9a27-9f4d6ec83b7b.dmp
    [Sun Sep 17 07:21:21 2023]00014:Fatal error occurred in mainthread! (Release Client #630)

    [Sun Sep 17 07:21:21 2023]00015:Client Version: Sep 12 2023 12:43:46
    [Sun Sep 17 07:21:21 2023]00016:Skin Directory:

    [Sun Sep 17 07:21:21 2023]00017:Graphics DLL Loaded: Graphics DLL Version 2.00.12345
    [Sun Sep 17 07:21:21 2023]00018:Graphics Build Date: Sep 12 2023 12:40:25
    [Sun Sep 17 07:21:21 2023]00019:Video Card: AMD Radeon HD 6800 Series,

    [Sun Sep 17 07:21:21 2023]00020:processor: 4 of type 8664
    [Sun Sep 17 07:21:21 2023]00021:Memory: Load: 42, Total Phys: 8109, Avail Phys: 4655, Total Page: 16216, Avail Page: 12083, Total Virtual: 8388607, Avail Virtual: 8388326, FreeBlocks: 8378680,4096,3068,1743,247,114,102,64,57,26
    [Sun Sep 17 07:21:21 2023]00022:CPU: Intel(R) Core(TM) i5-2400 CPU @ 3.10GHz 3036
    [Sun Sep 17 07:21:21 2023]00023:pools: Temp: 0(0). Persistent: 0(0). OnDemand: 0(0). Zone: 0(0)
    [Sun Sep 17 07:21:21 2023]00024:MaxTextures: 0k, CurrentTextures: 0k, HighQualityTextures: 0k
    [Sun Sep 17 07:21:21 2023]00025:Memory Mode: Balanced
  18. Metanis Bad Company

    I would add that prior to spending a lot of time troubleshooting everyone should ensure they patch Windows and their video driver set as well. And upgrade their toaster so they can run Windows 10 or 11 and retire those Win7 and 8 machines!
    Barton and Skuz like this.
  19. Angahran Augur

    2. Has anyone done a comparison of a 'bad' eqclient.ini and a clean one to try determine what, exactly, is causing the crash?

    3. I just logged into Test to see how bad it was and checked and it appears I have the sky set to complex with no apparent issues.
  20. I_Love_My_Bandwidth Mercslayer

    Deleted and repatched my eqclient.ini, all defaults. No changes. New texture issue. Didn't see this one reported.

    System is Ryzen 5500, B450, Radeon 6600XT, 16GB.

Thread Status:
Not open for further replies.