TDS: Loyal is the Heart (Caverns of Endless Songs)

Discussion in 'Bug Reports' started by Ryhme, Oct 22, 2022.

  1. Ryhme Lorekeeper

    "Find Dagda's Shield beneath the coral formation" is not updating.
    Deleted the quest, tried it a couple of times, can click the shield but no update at all...
  2. Soulbanshee Augur

    Use "Find Item" to make sure you didn't already loot Dagda's Shield.

    The quest does not update on click.
  3. Loup Garou De loop de loop

    when you click it a giant octopus should spawn and after you kill it then you loot the shield. I hate water fighting and this one was scary lol.

    So you don't get the big squid mob?
  4. Ryhme Lorekeeper

    I did that quest and the whole line of TDS for a couple of toons. This is the first time it does not work at this step.Neither does it update at the spot or the area, nor after clicking the shield, nor is a mob spawning - unusual - but I am used that TDS bugs out regularly in different zone parts.

    I would be happy for a fix. Nearly every time I make the progression, another part is bugged...
    Last time Caverns and the rest was not even accessible... :confused:
    I would not even need that xpac if these stupid access restrictions wouldn't be there.
    The only reason to come there is the TBL Boots and the explorer achievements.
    The only exception would be the once and a while questline for the tyrannosaur illusion and the ornaments of Thulisaur. Hell DGB, I plead for removing these restrictions, so that a normal gameplay would be possible instead of running always through that buggy content...
  5. Soulbanshee Augur

    Open find item, look for "Dagda's Shield". It won't trigger if you already had one looted for some reason.

    It also won't update until you kill the octopus and loot from it's corpse, thats normal.

    TDS keying was not removed, you are still required to do the progression to enter the zones. At least Caverns, Degmar, Thuli, Combine, and Arx are all keyed.
  6. NeverPayForLag Augur

    There was no Shield, it only is present if you kill the mob. And because I didn't kill the mob, I had no shield. The mob did not spawn.Rezoning, relogging, didn't worked.

    After a day now I returned, took the shield again, now the mob appeared. I killed the mob, got the shield, the quest updated now, like it should.

    It seems it was either a server glitch or a zone bug. Obviously a zone reset was necessary.