task 'All Rivers Lead to the Sea'.

Discussion in 'Player Support' started by draginn, May 17, 2017.

  1. draginn Elder

    The task is bugged now! After getting mission and doing first hail to FV and following you get update in first room. You then you
    Kill the tinkerers and constructs to find out what happened to Galeth 0/9 (Arx Mentis.
    Problem is you can only kill the constructs which is 2 in room. You cant Hit or cast on the Tinkerers. It was working before last nights patch! We did mission then worked fine. We didn't get time ACH, Because I had power go out. but mission worked then. We have tried to camp have others grab task same problem. You cant continue because the Tinkerers cant be hit casted or argo'd in any way!
  2. ZenMaster Augur

    I am having the same issue with TDS#4: Edge of Balance. You cannot cast or melee praetorians. Someone has reported the same issue on "Cover of Night". here https://dgcissuetracker.com/browse/EQ-1533

    It looks like an issue with mobs in several instances.
  3. Lyrical Augur

    Looks like many of the HAs across expansions are now borked.
  4. P-Diddy New Member

    Add Crying for the Dead in Degmar. I did the combines and got the Memorial Ceremony Announcement. You get to the part where you click the scroll in 5 rooms and nothing happens. No spawns and no "you are in the wrong spot". I can click it anywhere. This isn't a HA though.
  5. Restac Journeyman

    Life after Death in EWK was broken yesterday. Tried 2 different times, got stuck on step 3 first try, step 8 or 9 on the last try. Mobs wouldn't spawn. I even got stuck on a solo partisan mission in chelsith. Was supposed to kill slavers and free slaves. Supposed to kill the slavers and the slaves stop attacking and join your rebel cause. Problem was they slaves never stopped attacking like they're supposed to. I finally got tired of broken quests and logged off. Nothing was working right. Sounds about typical after a patch. Fix one thing, break 3 others :(

Share This Page