Splash Type Spells Feeling Clunky

Discussion in 'The Veterans' Lounge' started by Lubianx, Feb 20, 2022.

  1. Lubianx Augur

    Before I post a bug, has anyone else noticed that splash spells, particularly pally, is a lot more clunky than it used to be?

    Previously click spell, target ground and click. Now sometimes I need to click the spell multiple times prior to the target ring even showing. Even then sometimes the target ring just disappears prior to casting splash

    This occurred in a few different raids and even on Shei missions.
  2. Soulbanshee Augur

    Is it the clicking, or just the freetarget ring? Any event auras will display over (and block) the free target ring graphic.
  3. Lubianx Augur

    It's actually both. Someones it just wont cast the spell and show the ring, and other times it wont click

    I am aware of the display issue in relation to auras. It still should cast though.

    I am also aware of terrain issues but it just seems like it's something else.

    I had this happen on events from Shei group mission (no auras), to PoWar raid (it still sucks after all this time), to Shei raid, to Doomshade (without auras and up on the inner circle). So it's a mixture of auras and terrain.

    It has only been since the recent patch
  4. Soulbanshee Augur

    If you can figure out anything more reproducible, maybe needs to be reported. Are spell gems on global cooldown or any AAs been cast just before? Check for any error messages like LOS. One of our pallies has said he can't click over rocks.
  5. Elemental Augur

    I have noticed this also seems its an height issue possibly
  6. Iuwene Master

    I can't get a targetring for remote auras on my chanter at all. The aura will cast when I click the spell and then click somewhere on the screen, but no target ring. Hard to aim correctly with it.
  7. Maedhros High King

    The only problem I have is that if there happens to be a pebble on the ground where I try to "place" my splash target ring, the Z axis will get confused and give me the red ring instead of the green.
    But thats been happening for 10 years.
    Otherwise splash seems the same to me as it always has.
    Warpeace likes this.
  8. Sissruukk Rogue One

    I ran into this problem while running ToV Velk's Lab. I normally am the one to pick up the item to click on, and when I clicked on it, no ground target ring came up, and clicking on the ground did not activate the aura. I tried multiple times unsuccessfully.
  9. Raccoo Augur

  10. Iuwene Master

    Following the instructions in the link above fixed it. Thank you.
  11. Paladin Augur

    Personally, I would rather they just eliminate the target ring (ground click) aspect. In todays events (raids) it is mighty crowded and having to click the ground usually means getting a target you don't want to have / attack.

    I'd rather it was just a click and the AoE happens (no target ring, no ground click. Just double the range, and make it so.