Seals of Darkhollow

Discussion in 'The Veterans' Lounge' started by Ninelder, Dec 6, 2017 at 1:17 AM.

  1. Ninelder New Member

    There is unfortunately no tradeskill subforum to post this in, but my toon is close to finishing 350 tailoring he only has the many types of seals left. He did not do the Seals of Darkhollow quest back when DoDh was current, and he cannot get the quest to do it now. The NPC will give him the original ancestral high-elven armour book quest which he did but is useles, but he cannot get the Seals of Darkhollow book required to make seal patterns which are required for 350 tailoring. Any help?
  2. Diani Elder

    With getting the quest I cannot help.
    Maybe an alt or a friend can do it for you. The book can be traded.
  3. Nightops Augur

    The quest still works, I just did mine for tailoring this past week.

    I went to the high-elf npc and said the quest phrase (listed on alla's) and I was shown a pop-up box to select the quest for the Darkhollow seals task. Go and get your Darkhollow geode and turn it in to get 200 seal patterns.

    The Geode is easy to get but the Fine Silk Swatch (for alternate last blood seal) and Shimmering Silk (for alternate Chronal seal) are very very rare.


    **I do not know if I did a pre-quest back in the days of the darkhollow expansion, but I can't remember anything required. Just as a side note, if you did all of those pattern quests, you may have dumped them onto the NPC near PoK library that will hold those things for you.
    Xianzu_Monk_Tunare likes this.
  4. CatsPaws Augur

    Who is that npc please? I know of the guy in the lobby, Tavid Dennant. But don't remember the guy in POK
  5. Ninelder New Member

    I just did the first quest yesterday, and he gives you a {supplies} prompt but wont respond when you hit it, i even tried giving him a geode and nothing. There is nothing written on any resource i can find that can help me it seems
    thanks for your reply!
  6. Ninelder New Member

    Tried going back unillusioned and he gave it to me. For some reason he will give me the racial only book quest in illusion form but not the generic geode quest if illusioned. So problem solved, I would call it a bug, just hope others can find this before they start ripping their hair out like i was!
  7. CatsPaws Augur

Share This Page