Fixed Internally Patcher locking out accounts

Discussion in 'Resolved' started by yepmetoo, Mar 11, 2021.

  1. yepmetoo Abazzagorath

    Something wonky going on with the patcher recently. You log into account A, no problem. Go to log into account B, says you're "playing" it and can't log in. Over and over. Sometimes you can delete the account info and enter it as a new account, and it lets you log in, other times no.

    Also, the other part is that you switch accounts, it clearly shows your other account name and marketplace currency and whatever, click login, and it logs you in to a completely different account.

    Exiting all active eq accounts will let you log in. So just stopped working right in the last week, makes it annoying when you regularly log in and switch between multiple accounts.
    Miminona, Demendred, Baldur and 11 others like this.
  2. javiere New Member

    +1 having same issue
  3. Herf Augur

    I can't recall if this was the problem I had, but whatever the problem I had was, it was fixed by removing two files:
    C:\Users\Public\Daybreak Game Company\Installed Games\EverQuest\LaunchPad.libs\LaunchPad.Cache\Cookies

    C:\Users\Public\Daybreak Game Company\Installed Games\EverQuest\LaunchPad.libs\LaunchPad.Cache\Cookies-journal

    They are recreated when you try to login and it fixed the login problem I was having.
  4. I_Love_My_Bandwidth Mercslayer

    Gang, if you are having the same issue feel free to post, but per the Bug Forum Rules, you have to 'LIKE' the first post in the thread to count your vote towards having the bug noticed and worked on.
  5. Joules_Bianchi A certain gnome

    also having a semi related issue of- I run the launcer for the first account login, it works fine, every subequent account login after that, the patcher does not connect on the first try, it requires a close and rerun to open further accounts on the same machine.
  6. Ratalthor Developer

    We haven't been able to reproduce this issue. Can anybody provide additional repro steps? Please make certain that the client completely closes before trying to log in again.
  7. Distance35 New Member

    Same. The account I logged out of last night is the only one allowing me to log in. When I try to switch accounts, it does switch over and look/act like everything is good, however when I enter server select screen, it is still the one I logged out of last night.
  8. Fenthen aka Rath

    I have 100% of the time had to close the patcher and re-launch it to switch to a new account.

    No. We aren't closing clients to log into a new client.
  9. Yinla Ye Ol' Dragon

    Logging in second account gets this occasionally. I run first through steam 2nd by a different patcher.

    It seems to occur when I hit play before it has updated all account info. Possibly due to patcher lag.

    This is on AB if that makes a difference
  10. WeezFv Lorekeeper

    Had this problem with 1 out 3 accounts,.. what i did to fix it was,.. i selected log into new account and re-entered my info and its been workin just fine ever since,.. not sayin there wasnt a problem but after i did that,.. it wasnt tryin to log out an account i already had logged in. but yeah at first i had this problem with 1 account and after i did that it went away and didnt bother to post about it,.. maybe it was an update or a cookie thing? lol

    and i always use the same launcher and on windows 10 if that helps
  11. Bigstomp Augur

    I had this problem (or very similar) the other day.

    Launcher, Drop down, select account A.
    Click play and continue through server select, char select, and into world.
    Launcher again, select account B.
    Click play, reach server select.
    Server select tells me you already have a character logged in on this account.
    Repeat a few times making sure it was not something I was doing wrong.
    Removed account from the menu.
    Re-added account and signed in.
    Everything is good again now.

    It's almost like it saved invalid credentials or in this case valid but the wrong accounts credentials in whatever powers the accounts menu.
  12. yepmetoo Abazzagorath

    When it happens, closing the patcher client does nothing.

    The only way to clear it is to log out of EVERY account.

    So like, as an example, same computer, log in to Account A. I'm in world. Load patcher again, switch it from Account A to Account B, button turns to "Play", click play, get to server select, click to enter server, gives me the "active character" thing, will even send the request to boot from server and if I tab over, the request pops up on the character from account A.

    Cancel out and leave the second client, run patcher again, same deal. Only way to get it right, is log out of every account open, then start over.

    Its just annoying for people running a bunch of accounts.

    Doesn't happen all the time.

    For me, all clients are run from the same folder, only other piece of relevant info I can give.

    Basically, the patcher displays the correct username, accesses that account because it shows your station cash balance. But when you log in, it logs you into a different account. Not always the one you already were on either. I've logged on A and B, went to log in C, and it logged me into D. I logged back out of D, ran patcher again and logged into C, and again, once I get to server select it logged me back into D (easy to tell without going to character select because D was silver and C was subscribed).

    Hasn't happened to me for the last week, for what its worth, but its a really odd bug.
  13. yepmetoo Abazzagorath

    I removed and readded login/pw, one time if fixed it, other times it didn't. Was hit or miss.
  14. Aanuvane Augur

    Trying to log in a 4th account right now and when I choose the account I do not have a character logged into, it says "Playing" and won't let me click the play button.

    If I choose one of the accounts that I actually do have logged in - the play button is enabling.

    If I choose either one of the other two of the accounts that I actually do have logged in, it says "Playing"

    I am using "saved" credentials.

    Just tried opening the patcher again and got a "cannot connect message"

    Got the patcher to open again, clicked the x next to the account I'm trying to log in and re-entered the credentials for that account and now I'm stuck on "installing".

    The only way I know to solve this is to log everyone out, reboot and start over.

    The 4th account I am attempting to log in has been in offline trader mode for at least 2 days.

    I'm pretty sure my PC has been rebooted at least once since that account was in offline trader mode.

    Edit: After rebooting, I am able to log in the account that was causing me issues a few minutes ago.
  15. Aanuvane Augur

    A comment on this scenario - I have encountered this as well - what I find is that I have to "go slow" through the patcher select to make absolutely sure it's changed over from Account A to Account B. It looks like I've chose Account B because the name appears in the screen, but in reality, that page didn't "reload" between selections. As long as I can see the expected DB Cash balance with the account, I find I end up in the right place/account.

    However, as I think we are both trying to point out - even if it's doing something weird/slow in flipping from A to B, you should not be allowed to try to log in an account that actually is actively playing on your current PC. At least that's the way it's worked since multi-boxing on the same PC became a thing up until a few weeks/months ago as far as I can recall.
  16. Ratalthor Developer

  17. Aanuvane Augur

    I just sent you a PM.

    Started PC this morning - was off all night.

    Logged in Account 1 - fine, no problems
    Tried to log in Account 2 - patcher giving me the "playing" message on the button, can't log it in.
    Changed to Account 1 in the patcher, I get the "play" button (this shouldn't happen)
    Try to log in Account 3, no problems
    Try to log in Account 2 an hour later, still getting the "Playing" message on the button

    Account 2 is not logged in on my machine and it was a "fresh" boot.

    Went to second PC and could log in Account 2 just fine.
    yepmetoo likes this.
  18. Aanuvane Augur

    I was able to log in Account 2 ~14 hours later after logging out of all other accounts on the original PC without rebooting.
  19. Ratalthor Developer

    Has anybody had this issue happen to them again recently?
  20. Febb Augur

    I don't know if this is still happening to people but I fixed this issue by installing EQ for each account into their own directory on the root of the C drive. Then linking a shortcut for each accounts launchpad exe to the desktop. It will always show just that account by default when you load up the launchpad.