Palace of Embers quest

Discussion in 'Player Support' started by Arkeal_Rathe_Bots, Dec 15, 2018.

  1. Arkeal_Rathe_Bots Lorekeeper

    Anyone else having a hard time today getting the names to spawn for this quest? Yesterday I did the whole task in about 2 hours. Today, I cant even get the first name to spawn to "force" me into Aalishae.

    Did spiders yesterday and popped Spider Tender guy, today killed them for over 2 hours and nothing. Moved camps to a different type, been here about 1.5 hours and still nothing. bug or crap luck?
  2. svann Augur

    When we first got there he was up so we got most of the group a free update, but then we got one more join group to try to catch up. We killed for 4 hours in front of the aalishai door trying to get the last person in group to pass this step. Im wondering if it breaks if some are past the step and some arent.
  3. Nightops Augur

    I have been having the same issue with this task. killing dozens of the same mob type with no success.

    First night I tried killing the birds. Spent about 90+ mins chain pulling with Pal,sham, zerk x2, bard, and clr merc.

    Since we did not make progress on the task, I had the second group drop the task and request at the same time. Second afternoon, I spent 2+ hours working the spiders with pal, zerk, bard, and 3 mercs.

    I do not know the name of the NPC which is supposed to spawn so I can not confirm if it was on track already. I did notice only a handful of other players in the zone each time and none of them appeared to stay long or be actively killing when I ran my bard around for collects.
  4. Telkiney Elder

    A group I was in has this issue when we started looking around in an area we had not been killing in and found the named up but we had known another group was over there.

    We determined the other group incidentally spawned it and assumed since there was one spawn up in the zone, he would not have popped for us. No one was around so we brought it down and gone credit.

    I've done this quest a few times now, I recommend looking around every so often if you have killed more than 30 mobs and see if there is a named mob up with a bracket below the name... likely is the mob you need.
  5. Arkeal_Rathe_Bots Lorekeeper

    Something else we found (which was our issue) is if someone that has completed the task, gets it again to do it with the group and DOES NOT destroy their old contract of war, the names will not spawn
  6. svann Augur

    Good advice, but I had track up the whole time and he was never spawned.
    That might have been it. I had dropped the quest and regot it. May not have destroyed the first contract.
  7. Sinimyn New Member

    I am hoping someone can answer this for me....

    Does anyone know if one of our toons needs to drop this task and totally redo after he died just before we killed the All Consuming Sound? He is now stuck on this step:

    3. You will have to kill the ambassador to prevent him from reporting what you have done. 0/1 Aalishai Palace of Embers

    He cannot advance, nor are we certain if we can repop the named (we are trying). all others in the group have completed it and no one has any of the items left in inventory except for him.

    Thanks in advance to any responses.
  8. Conq Augur

    You can either wait for someone else to trigger that mob and be in the group that kills (and gets xp for) the ambassador or else restart the quest. In my experience, those are your options, having helped 10+ people through this same issue on Tunare.
    Conq
  9. Sinimyn New Member


    Thanks, that's what we figured. We are just going to redo it ourselves.

Share This Page