Overseer Bug Post Migration

Discussion in 'Bug Reports' started by Gherig, Apr 21, 2021.

  1. Gherig Addicted since Aug 1st, 1998

    There is a issue with Overseer for a few people since this migration.

    Every single agent I have is either incapacitated for 36 hours, Banished for 18 hrs, Discredited for 18 hrs or Discouraged for 4 hours. When i logged out pre-migration I had 0 active quests, so no way they could have failed. AND ... the timers are not ticking down.
  2. Gherig Addicted since Aug 1st, 1998

    I cant even do White, Green or Blue conversion quests, cant assign anyone to them also.
  3. Soulbanshee Augur

    Do you bypass launcher to log in?

    Check your system date/time to the second, and time zone (fix while logged out of the game). Overseer is very sensitive to local computer clock jitter. Differences of even just a couple seconds makes it go haywire because it can't calculate the timers correctly.

    All else, log all the way to desktop and back in, sometimes loading account data across the different systems does not sync correctly, and it just failed to load your overseer and that may be what you get by default.
  4. Gherig Addicted since Aug 1st, 1998

    This is happening on every quest I choose. I can't assign anything and the timers do not tick off. I use the normal way to log in, I don't mess with clocks and multiple platforms to log in with. Its a bug and it wont go away. My quests are 0/5 my overall avail is 0/10

  5. Yinla Ye Ol' Dragon

    Mine is working fine on AB. Could be a server issue, which server are you on?
  6. Gherig Addicted since Aug 1st, 1998

    Cazic but my other 2 accounts are fine on that server.
  7. Zinth Augur

    are all your agents rangers? they tripped over the shoelaces during the migration and got severely injured? it would be a plausible explanation for sure.
  8. niente Developer

    Am I misunderstanding, this screenshot is of the chance for an agent to be incapacitated and the duration/incap type if you start the quest? So the 1st slot in Deadly Blade Oil has a 2% chance for your level 4 Merchant to be Blacklisted for 36 hours.
    Fenthen likes this.
  9. Febb Augur

    This is normal in the quest window. It shows you the chance of what can happen to your agents. Can you post a screenshot of your agent page where all of your agents are incapicitated?
    Fenthen likes this.
  10. Fenthen Just a homeless burnout

    I feel like maybe you don't understand how Overseer works...?
  11. Gherig Addicted since Aug 1st, 1998

    Pretty sure after more then a year I know how it works.
  12. Gherig Addicted since Aug 1st, 1998

    The issue I have is I cant assign an agent to any slot, in any quest at all. When I click the "select agent" button, nothing happens on any quest. I checked them all and clicked each select tab, none of them let me assign agents to create new quests. My quest count is 0/5 slots used and my daily total is 0/10 used also.

    Its not my computer or my download of the game like others suggested since I was able to log in 2 other accounts and assign 5 quests for each account like normal using the same computer.
  13. Gherig Addicted since Aug 1st, 1998

    niente Just checked again after the quest rotated for the day. I still cant assign any agents to start tasks. Every quest the tab to interact pushes down and nothing happens. The account is tied to this forum account, you are more then welcome to log in and try it yourself.
  14. Niskin Clockwork Arguer

    Could this be a UI issue? I don't see the part of the window where the agent options would show up. Is it just cut out of the screenshot or missing from the window? Can you make the overseer window bigger or scroll it down somehow?
  15. Gherig Addicted since Aug 1st, 1998

    Not UI, I was able to log in 2 other accounts and Overseer worked perfectly same computer and install. I don't think I explained my issue correctly....

    When I click to select and assign an agent to a quest, nothing pops up, nothing happens but the buttons goes down and up and that's it. The options to chose agents to assign does not popup even though I have several agents with the requests trait available and all my agents in my agent list are status: Ready.

    i.e. I cant start any new quests
  16. Gherig Addicted since Aug 1st, 1998

    I ran the file check tool, nothing was downloaded but now it works. So whatever the issue was it is working now after running that tool, even though it found no bad or missing files.
    Metanis likes this.
  17. Niskin Clockwork Arguer

    I still think it was a UI issue, which would explain why a file check might have fixed it. See below.

    When you click to select and assign, nothing should pop up. There is a panel below that one where the agents appear. That panel is not visible in the window in your screenshot.


    The red oval thing is the bottom bar of your overseer window. The orange one is your scroll bar for the middle panel, which goes past the bottom bar. So you aren't even seeing all of the middle panel, let alone the bottom panel. When you click Select Agent (green circle), the region where the agent would be displayed wasn't even visible in the box.

    I think if you had made the window taller you would have seen it, but maybe not. Maybe that panel was broke and the file fix restored the layout.

    EDIT: It's also important to note that checking other characters won't tell you anything, the UI files are separate for each character.
  18. Gherig Addicted since Aug 1st, 1998

    There is no UI issue, you just scroll down and the section is there for the agents when the button works, you can see the 4th agent is showing in that particular task, you just scroll past it. I use Snip Tool to take that screenshot and snipped off the bottom half since it wasn't relevant to my question.

    Either way it works now.
  19. Alkerion New Member

    As the others pointed out the window you linked looks completely normal and they explained why. That is why I cannot fault him for questioning your knowledge of the system when you didn't show a problem but a normal looking screen.
  20. Niskin Clockwork Arguer

    Ok, bear with me here for a second, not trying to be a jerk, I just don't think you understand what I'm saying. In your screenshot, the bar at the bottom goes all the way across the Overseer window, showing the down arrow on the quest list. That is the bottom of the Overseer window. It doesn't matter where you clipped the pic, that is the full window. There should be a separator bar between the required agent slots on the right, and the agent selection area that would be below it. Your window is too short to show it.

    Maybe you shrunk the window and I misunderstood what you mean, but this is what it should look like:


    Red is the separator I can't see in your screenshot.
    Orange is the bottom bar I see in your screenshot.
    Green is where the agents display.

    Maybe the UI file got borked and it didn't show that section until you repaired. All I'm saying is that the screenshot you provided doesn't show enough of the window for people to determine whether it was missing or just beyond the bottom bar and not visible. Glad it's working for you now though.