Odd issues with keys not working in game.

Discussion in 'Player Support' started by BrokenAgain, Mar 7, 2014.

  1. BrokenAgain New Member

    My main computer crapped out on me and I took one of my Windows Vista Laptops out of retirement.

    With a fresh install of EQ, having no modifications or changing any of the default settings. I can not use the += key or the '" key. They simply do not work. If I attempt to change (which would be default) Hotbar 1, slot 12 key and press the += key, I instead get a ? in it's place.

    As you can see from the body of the text, this problem is not a mechanical/hardware issue and i am able to use them in this dialogue. I asked our servers gen chat and others seemed to have the same issue. Please help, this is a minor frustration, but a frustration none the less.
  2. TSR-SeanF Augur

    In most cases this can occur due to a function lock on your laptop. I would suggest checking for any kind of function bind keys on the laptop and try toggling them to see if they resolve the issue.
  3. Treesmasha New Member

    I forgot exactly where I got this from, but maybe it will help.

    The issue is primarily the infrared remote control for the multimedia while for a few others it Logitech G15 software. Windows is overriding/not releasing those keystrokes (or allowing EQ to override it). There are workarounds which usually results in disabling the remote control.
    Unplugging the IR.
    Shutdown setpoint.exe (Logitech software)
    This is most commonly caused by having the Microsoft Media Center infrared device. Even if you don't have a Media Center version of Windows installed, just having the infrared receiver can cause problems.

    I finally found (again) the web site that describes the "best" fix for this (best in that it still allows use of the remote, but also allows typing punctuation characters in games, etc.:

    1. Go into Device Manager -> Keyboards.

    2. Right-click "Microsoft eHome MCIR 109 Keyboard", choose "Update Driver" ("Update Driver Software" on Vista and 7).

    3. Choose "Browse my computer for software" (XP users tell it not to install automatically and say you'll specify the location, then when it asks you where you would like it to search for drivers choose the option to choose from a list) then "Let me pick from a list of device drivers on my computer".

    4. Make sure "show compatible hardware" is checked, then select "HID-compliant device" and click next. Click any remaining "OK" or "Finish" buttons after Windows has installed the driver.
    I just realized I had this problem after tonight playing in Underfoot.
    Last week or so, I installed a WinTV HVR 2250 in my desktop, that came with a remote for Media Center.
    Interestingly enough, it installed Microsoft eHome Infrared Tranceiver, as a Human Interface Device, which also installed 3 keyboards (Microsoft eHome MCIR 109 Keyboard, Microsoft eHome MCIR Keyboard, and Microsoft eHome Remote Control Keyboard keys), all found under Device Manager.
    Little did I know that it was the culprit all along.
    I use a USB Keyboard/Mouse combo using a receiver, since I use them wirelessly. The set I have is Microsoft Wireless Desktop Elite (Microsoft Wireless Desktop Elite Keyboard with Wireless Intellimouse Explorer 2.0).
    I do use the remote control that my TV Tuner card came with so I can be lazy and use it with the IR receiver the tuner came with, but I did not want to loose that functionality.
    So, since I do not own any keyboard that has anything to do with Media Center, all I did was this (and was surprisingly easy):
    1) Open Device Manager
    2) Click on "Keyboards" to open the tree.
    3) Right-Click on "Microsoft eHome MCIR 109 Keyboard" and choose "Uninstall", then click "Ok".
    4) Right-Click on "Microsoft eHome MCIR Keyboard" and choose "Uninstall", then click "Ok".
    5) Right-Click on "Microsoft eHome Remote Control Keyboard keys" and choose "Uninstall", then click "Ok".
    6) Click on "Human Interface Devices" to open the tree.
    7) Right-Click on "Microsoft eHome Infrared Transceiver" and choose "Disable", then click "Ok".
    You do not have to reboot.
    Now if you ever DO get a keyboard that uses Media Center, you can then go back and Enable that device, which will reinstall those keyboards again after rebooting.
    Actually, rather than disabling the device, there is another workaround if you want to keep using it.
    In Device Manager under Keyboards, update the "Microsoft eHome MCIR 109 Keyboard" to a "HID-compliant device"
    Here's a screenshot: http://img218.imageshack.us/img218/1909/tilde.png
    Restart the game if you had it open, and presto, now you can type tilde's and still use your remote.