Netgear hang/disconnects

Discussion in 'Player Support' started by Pappasalt, Aug 23, 2021.

  1. Pappasalt Augur

    Ok, so I've been through a lot of different fixes for this such as deleting ini's, adjusting settings, etc. to no avail.

    I played on Selo just fine for years and coirnav/agnarr but since I've reformatted and reinstalled EQ and gotten a new modem/router I've had issues. I believe I've narrowed it down to the modem/router but can't find the issue, I've port forwarded the EQ ports listed. My modem/router is a Netgear Cax30. There is no other issues other than EQ and the primary problem is at random times it will just hang in that I can see every character moving but all npcs stop interacting, spells don't cast, and eventually I will totally d/c within a few minutes. The f11 command shows nothing wrong.

    ^it would seem someone 4 months ago listed a very similar issue with a very close router/modem model to mine and I was wondering if anyone knows of a fix or what not.
  2. Wulfhere Augur

    Any logs on your router with info?
    Run an internet performance test that checks for buffer bloat which can cause packet delays.
  3. Pappasalt Augur

    Don't see any logs that I know, have some packet loss but doesn't affect any other game other than EQ.

    This is an example of it happening and what it looks like, it literally just blocks out my spells/mob but i can still see people moving, etc. Sometimes I can even see chat still going. But it took me about 10 minutes to actually d/c there around 1:13:00.
  4. Skuz I am become Wrath, the Destroyer of Worlds.

    Are you using wireless or wired?

    For online games always go wired if you get connection issues to see if that helps, wireless is notorious for causing online game drop outs.
  5. Metanis Bad Company

    I agree with @Skuz, if at all possible use an Ethernet connection to your router.

    Then use something like the free version of DriverBooster from Iobit and ensure all your hardware drivers are up to date.

    Then also ensure your router's firmware is up to date.

    If none of those easy steps make a difference then continue with:

    Experiment with using a VPN to play the game. Google "best windows vpn" and do a trial on any one of them listed. I personally use Windscribe but that's because I got a fantastic deal on a lifetime subscription.

    Finally, adjust your TCP/IP MTU down to 1492 or even 1468. Here's a guide...
    MTU Size: What Is It and What Should It Be Set To? - Home Network Geek

    The reason for the VPN and MTU adjustment is because a very few ISPs (CenturyLink and Frontier come to mind) sometimes mess with your Internet traffic in an attempt to "optimize" it. For example your outbound traffic to DBG could be fine but your ISP could be blocking or attempting to combine the ACK packets back from the server.
    Skuz likes this.
  6. Pappasalt Augur


    Drivers are up to date across the board.

    Firmware is controlled by comcast.

    I've narrowed it down to either my newer router/modem and something in base firmware/firewall blocking something (ive already port forwarded, etc just in case).

    Or something to do with combat logging.
  7. Metanis Bad Company

    I have never seen a requirement to do either port forwarding or firewall configuration to get EQ working (unless you ran one of those lockdown scripts that disables everything!)

    The log thing would be very unlikely but you could try /loginterval 1 so your PC only writes to the log file once every second rather than every few milliseconds.

    You're down to VPN or MTU experimentation sounds like.
  8. Rogue001 Lorekeeper

    I've been having this same exact issue. The only thing that's changed on my set-up me is this windows update.

    2021-08 Cumulative Update for Windows 10 Version 21H1 for x64-based Systems (KB5005033)
    Successfully installed on ‎8/‎29/‎2021

    I'm hesitant to blame a windows update on the issue since I feel like we'd see more people post issues - but it's the ONLY change I can think of and it started happening shortly after.

    Also of note this wasn't like a normal windows security patch either - this seemed more like a creators up date or what ever they are called, as it walked me though the initial windows set up screens.

    This tends to happen more on raids. (it did happen once during a group session), but raids this happens to me non stop on my 3 boxes.

    Here's the troubleshooting I've been through so far
    • Rebooted
    • Reset modem / router (yes I'm hard wired)
    • Checked Ethernet drivers
    • Reinstalled EQ
    None if this has worked so I'm trying out some steps Skuz posted on a similar thread about flushing the dns etc.. I'll let you know how that works.

    Next steps is to test this on another computer...but jesus I don't feel like sending all of my UI, INI crap to my other computer and switching all the monitors around.
  9. Coursaire New Member

    I was having a similar issue and what mine was I had QoS turned on and once I shut that off I have not had a problem since.
  10. Rogue001 Lorekeeper

    QoS is off on my router - release / flushing DNS stuff didn't work.

    Trying a secondary computer - if it happens on the secondary computer it's likely the internet connection...maybe? The reason I don't think it's internet is because with internet connection issues EQ will reconnect, in this case the character that is having server sync issues does not reconnect. The other reason I don't think it's internet is because none of my other stuff is not disconnecting(discord, mumble, streaming) - in fact in the past I've had instances where my internet literally went down, I reset the modem, and it came back up and the game reconnected before I went LD.
  11. Yteran Lorekeeper

    What type of connection do you have? DSL? Fiber? Cable? Cellular?

    The way you describe it, it sounds to me like you're suffering from buffer bloat that eventually causes a disconnect from EQ servers when the bottleneck gets too bad. Whether that is at the node or edge router on your providers end, or at your router, or a problem with packet loss is anyone's guess. It could even be an optimization setting your provider uses to restrict the quantity of packets. It could be that your connection is unstable and is randomly going down/retraining. Need more information, like connection/router stats (signal to noise ratio, attenuation) if you're on DSL, for example.

    Does the rest of your internet work fine when this happens? What about other massively multiplayer games that produce a lot of packets? (Fortnite, Apex, Dota, WoW, etc.) Do those have issues, or play flawlessly?

    If you add to your eqclient.ini file the line ServerFilter=1 and in your in game options hide other combat, spells, bard songs etc under the chat tab, does that resolve the problem?

    I am on a very old Verizon DSL system; old enough that it can't handle the packet volume that is required for modern internet use, being oversold aside (10mbps between 25 households.) My only solution was to use serverfilter and hide everything but my own combat/spells and NPC combat/spells. I can't use parsers but I don't end up 10 seconds behind the raid anymore waiting for queued packets to be sent.
  12. Pappasalt Augur

    CPU - i9-9900k
    GPU - EVGA 2070
    PSU - EVGA 1k Watts
    Ram/Memory - 2 x16gb Gskill Ripjaws V series DDR4 3600
    Motherboard - MSI MEG Z390
    Harddrives - Samsung HD 103sj 1tb, x2 Samsung 850 EVO 250gb (EQ is on one of those), Samsung 860 EVO m.2 1tb
    Router/Modem - Netgear CAX30
    Windows version - Windows 10 build 10.0.19043
    Connection - Comcast cable, 300ish down/10 up

    I run with /log on, gamparse, gina at times but that doesn't seem to matter, and a custom UI.

    I have tried:

    Deleting all player ini files along with the eqclient.ini.
    Port Forwarding the listed ports online for EQ
    Putting myself entirely on the DMZ
    Refreshing my DNS entirely
    Lowering the MTU packets
    Sent a ticket in with no response as of yet
    There are other things I've done but honestly at this point I've lost track

    To be clear what is happening is that the game will just hang. I can see people moving, I can move, sometimes I can see chat going, but I can't actually interact. If I cast a spell, it will just grey out and won't come back up, I can't type, no log type chat is going just the text chats. And the creepy part is it will sit there, I've waited 10 minutes for the "youve been disconnected" to come up and even longer at times and I still have force my character to log out when trying to log back in. There are no issues with any other game, I play Apex, WoW, Heroes of the Storm, among many issue...heck I even stream regularly with no issue.

    Another example of it happening..

    You can see the bosses hps are not going down but can see people moving etc but I myself can't cast etc.

    Also it just happened again just logging into my alt, I moved like 2 feet...hung again and had to force crash, logged back in, stuck on loading, crashed again, logged back in fine.
  13. Yteran Lorekeeper

    Okay, since other games don't have any problems, here's what I suggest:

    Add the line ServerFilter=1 to your eqclient.ini file
    Hide other spells, other combat, bard songs, and anything else you don't really care about under EQ options/chat tab in game.

    The above setting filters packets at the server, reducing the total number of packets you receive.

    Try a different router.

    Try a different computer/eq installation.

    If none of the above solves your problem, then you either need to call your ISP and hope you get a technician who wants to troubleshoot a very specific problem (your route path to EverQuest servers) or you need to change your ISP.
  14. Yteran Lorekeeper

    That update caused a lot of problems. I believe it had some backdoor nonsense.

    What's your cryptographic services processor/ram/drive usage look like when you start having the problem?
  15. Pappasalt Augur

    So I think I've narrowed my issue down to my network card. Apparently Killer network cards limit/prioritize programs/bandwith and when looking up my crash seems to be an issue prior with Everquest.
  16. Metanis Bad Company

    Use Device Manager and find your network adapter, then open it's properties and check the Advanced tab:

    Disable anything to do with "green" energy savings modes. Disable Jumbo Frames. Disable Power Saving Mode.

    If there is a tab for "Power Management" remove the check next to "Allow the computer to turn off this device to save power."

    Remember you'll have to reboot to make sure these changes are "sticky".
    Skuz and CatsPaws like this.
  17. Ghaaruk2 New Member

    So after trying everything under the sun, I modified my DNS to the Google DNS - and
    I haven't had a disconnect since. Go figure.
    Metanis and CatsPaws like this.
  18. CatsPaws No response to your post cause your on ignore

    great info for future reference, thanks!
  19. Pappasalt Augur

    So, at this point I've exhausted everything. New network card in...fixed other issues but not EQ. Just got booted again.

    At this point it has to be between the ISP and EQ.
  20. Wulfhere Augur

    You never posted your Logs\dbg.txt file for examination?