Fixed Internally Necklace of Icephyxication

Discussion in 'Bug Reports' started by Xalatan, Mar 26, 2020.

  1. Xalatan New Member

    Got this item tonight. Equipped and right clicked, got the message "Your target doesn't meet the spell requirements". I targeted myself, and untargeted myself. I don't have "Ancestral Memories" under special AA. What am I missing? Had the same issues arise with "Taelosian Guard" with the item Velium Infused Necklace of Adroitness. I was buffless as well when I tried. Thanks.
    Zaray, Rondor and Duder like this.
  2. Cragzop Augur

    Those are both under the Ancient Flames line (x/8 - max is the Ancient Cloak of Flames from HH Naggy zone). So if you already have 7/8 or 8/8 … both of those are completely irrelevant. Pretty sure Ancestral is 7/8 and Taelosian is 6/8.

    The buff is just a placebo buff...does nothing for you. It's having the ranks in whatever in the Special tab of AAs that matter.

    As to why you aren't getting the placebo buff... no idea. You cannot buff block it, so it can't be that. I have 8/8 and can still cast my neck for the placebo buff. Can you still get placebo buffs from rings, belt, face, ear?
  3. Rondor Elder

  4. Xalatan New Member

    I have none of those you listed in my special AA tab. And Yes, I can cast the ring, ear, face, etc with no problems.
  5. Xalatan New Member

  6. Ngreth Thergn Developer

    I gave myself a ticket to look into this. No ETA at this time.
  7. Xalatan New Member

    Thank you!
  8. Duder Augur

    As note, I don't think the clicks from any era for this click type are working. I have not tested it but have seen numerous incidents inquired about. So it is not exclusive to the Necklace of Icespyxiation
  9. Ngreth Thergn Developer

    Found the issue. Should be fixed next patch.
    Duder likes this.

Share This Page