Mercenary Purchase

Discussion in 'Player Support' started by Grove, Jan 1, 2013.

  1. Grove Elder

    I am posting in behalf of a guild member. He has a gold account.

    He had a mercenary, which he deleted with the intention of purchasing a new one. Something has gone wrong, however. Upon selecting Barbarian, Tier 3 (tank type) he has the "Hire" button showing. However, when this button is pressed he gets an edit message: "pending mercenary purchase"

    It seems that there are several ways to resolve this, but I cannot advise how to do any of them. 1) Find out what said purchase is and proceed with it. 2) Cancel said purchase with or without knowing what it is.

    Any help?.
  2. Grove Elder

    Additional information...

    Guildie again tried a purchase, hitting "Hire". This time, somehow he was able to find a Manage Mercenary window. When there, he hit the "Info" tab and received the following edit: "Unknown DB String 0 - 23".
  3. Big Al New Member

    I have this identical problem... up to and including the J3 merc. Even more confusing is it actually works with the Alaran Spirit merc, however fails with every other one i've tried.
  4. Shelak New Member

    As of May 11th, 2013, I am experiencing this problem too, on multiple accounts. I know there exists a solution combination of deleting particular files, camping (to desktop), zoning, dismissing, rehiring. But I have not narrowed it down reliably yet. Camping(to desktop)/zoning can take long time... In addition to having to try them randomly, multiple multiple times. Has someone found reliable way to fix this?

    Any help would be greatly appreciated!

    Edit: These are the files I've been deleting are from this post:

Share This Page