Fixed Internally Mercenary Contract

Discussion in 'Resolved' started by Malbro, Dec 9, 2020.

  1. Malbro Augur

    I claimed and used the contract of the othmir and it is still in my bag. Shouldn't it have been used up?
  2. pawpaw New Member

    You get 999 of the merc contracts so maybe you accidently claimed it twice.
  3. Khyrra Elder

    This happened to me as well. I deleted the first contract and tried again and nothing happened.
  4. Xianzu_Monk_Tunare Augur

    998 contracts remaining, Othmir Merc available. Contract of the Othmir still in inventory. It is a bug.
  5. Khyrra Elder

    Has this been resolved yet?

    Its still not working.
  6. Yinla Ye Ol' Dragon

    There hadn't been a patch since CoV release so not fixed yet.
  7. Khyrra Elder

    So new patch :
    Claim was approved but contract is still in my inventory.
    So I still can't get my Othmir mercenary.

    Khyrra
  8. Ngreth Thergn Developer

    Having the contract does not stop you getting the Othmir mercenary.
    You still have to click the contract to gain the mercenary. The bug was that the contract stayed in inventory after you clicked, and were able to get the mercenary.
    Did you right-click the contract?
  9. Khyrra Elder

    Hi Ngreth

    I did right click the contract and I even just now ran back to Iauld Atiqa to see if Othmir mercenaries were available - and sadly no.

    Apologies for late reply.
  10. Ryuujin New Member

    Just chiming in to say this bug still exists for me on Coirnav. Have claimed from window but can not right-click contract to claim mercenary.

    Threat shows fixed internally, any ETA until released to live?
  11. Warpeace Augur


    Probably the next full patch.
  12. Khyrra Elder

    I still cannot obtain the Othmir mercenary (Ragefire server).

    Anyone else managed to claim this mercenary?
  13. Ryuujin New Member

    Negative, doesn't seem like last patch pushed the fixed. Still broken for me on Coirnav.
  14. Dessek New Member

    Still broken on Coirnav as of March 10 patch.
    Not trying to be an a-hole, but it's been 3 months. If it was fixed internally why hasn't it been pushed to live in the last two patches?
  15. Ratalthor Developer

    The original issue in this thread was related to the contract not getting removed from your inventory after use. This issue is fixed, so I am moving the thread to Resolved.

    In this thread, a different issue related to not being able to use the contract at all on progression servers came up. This is a separate issue, so I am creating a new thread here for you to follow and track the issue.

Share This Page