Mercenary bugged post server move / post heroic

Discussion in 'Bug Reports' started by Winimum - Mischief, Sep 21, 2022.

  1. Winimum - Mischief New Member

    I just upgraded my character to 100 heroic.
    I recently moved him from The Rathe to Cazic Thule.
    Since I did the server move I get these messages every time I zone "You no longer meet the requirements for this mercenary" and "you no longer have a mercenary"
    I currently do not have a mercenary visible on any interface
    I did not receive a mercenary from my heroic upgrade
    When i try to hire a mercenary, I get the message "you already have a pending mercenary purchase"
    Please help me resolve this and get my heroic mercenary and other mercenary issues solved.
  2. Soulbanshee Augur
    Winimum - Mischief likes this.
  3. Joules_Bianchi A certain gnome

    Unsuspend / dismiss / rinse and repeat until you have NO merc window and cannot toggle one. type alt o and click keys tab / UI on the pulldown context menu / Mercenary Window Toggle setting has no default value iirc. Add a keystroke, type it and if no window pops, you are now FREE to resume your mercenary friendly life.
    Winimum - Mischief likes this.
  4. Conq Augur

    Merc's are the Devil.
  5. Winimum - Mischief New Member

    Thanks, using a method on one of those threads I spammed Dismiss on Merc window until I had no Merc window and it solved that part. Anyone have ideas about getting your heroic merc if you were unable to get it when you went heroic? In other words, I canhire mercs now, but I still did not receive my merc for doing heroic 100.
  6. Joules_Bianchi A certain gnome

    for that i'm guessing you can file a petition and wait, or, go hire any merc you want, note the PP cost and petition that, but have a merc until it is resolved. Or just hire a merc and eat the 200 PP +/- and go loot a diamond to pay for it, which is much quicker than filing a petition at all.